LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-11-2007, 07:43 AM   #1
mouse_x
LQ Newbie
 
Registered: Jan 2007
Location: Norway
Distribution: Debian Etch
Posts: 15

Rep: Reputation: 0
Problems with mouse in Gnome (debian)


System: Debian Sarge Stable, don't know witch version, just installed it yesterday so I guess it's the newest? Uses xfree86, has Gnome installed, will probably use KDE later..

At first x didn't start because the mouse was missing, then I corrected some file (etc/X11/XF86Config-4) and if found the mouse. But now when I start Gnome, the mouse goes to the bottom left corner, and when I try to move it, it jumps right back after a second or two.. I use a standard PS/2 2-button mouse, no cordless/usb/optical bs.. I have tried to search, but all of you uses USB/whatnot mouses and the settings are different..

I've tried a lot of different settings, what should I use?

The previously mentioned file is now like this:


Code:
Section "InputDevice"
Identifier    "Configured mouse"
Driver        "mouse"
Option        "CorePointer"
Option        "Device"          "/dev/psaux"
Option        "Protocol"        "ImPS/2"
Option        "Emulate3buttons" "true"
Option        "ZAxismapping"    "4 5"

Last edited by mouse_x; 01-11-2007 at 08:02 AM.
 
Old 01-11-2007, 11:54 PM   #2
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 51
The xfree86 is outdated, xorg is the new one. So probably you have a old version of Debian.
Have you tried 'dpkg-reconfigure xfree86' ?
 
Old 01-12-2007, 12:15 AM   #3
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
Sarge was set to be retired December 4th, 2006, but it didn't happen yet. Apparently they are trying to iron out some bugs before they release etch as stable.

In any case, sarge still uses xfree86. That will very soon be retired, but nobody really knows if that will happen today, tomorrow, next week, or next month.

I strongly urge you to change your /etc/apt/sources.lst from stable to etch. Once you do that, apt-get update and apt-get upgrade will install xorg in place of xfree86. Xfree86 was a clunky beast, and xorg is vastly superior to it.

Just as a point of order, for a home desktop system, debian stable is 100% the wrong way to go. Stable has software that is at least 18 months old, and it is used primarily for servers, that people want to update as little as possible. The vast majority of stable updates are done for security reasons, not functionality.

On my home desktop and work laptop I run debian unstable. Despite the name, I've never had a moments problem with it, and it has been my only distro for more than 2 years. if the cutting edge of unstable scares you, go with the middle ground of testing. When new software comes out, it gets in unstable immediately. If it survives there for a about a month with no huge bugs found, it will make testing. It similiarly trickles down to stable, but that is a much longer process.

As shrikant.odugoudar wisely told you, you can do a dpkg-reconfigure xfree86, but it isn't worth saving at this point. The move to Etch is soon to come, and then you'll be forced to make the change, so you may as well do it now.

Peace,
JimBass

Last edited by JimBass; 01-12-2007 at 12:17 AM.
 
Old 01-12-2007, 01:39 AM   #4
mouse_x
LQ Newbie
 
Registered: Jan 2007
Location: Norway
Distribution: Debian Etch
Posts: 15

Original Poster
Rep: Reputation: 0
Ok, thanks for the info But it's not my home desktop system (maybe I should have mentioned it), it's to test some things at work. I'm setting up a second computer, and have to set ut up to be like the system the software was configured on, that's why I'm using Stable.. It may be used as a server later on..

I have used 'dpkg-reconfigure xfree86' and tried alot of different settings.. But I think I'm not getting it right somehow..? That's why I posted my settings.. The debian system set my mouse to /dev/mouse as default, but I when I set it to /dev/psaux it actually found it. I first used a sort of link (/dev/mouse -> /dev/psaux or something) and then changed it in the file later..

Any tips?
 
Old 01-12-2007, 01:54 AM   #5
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
Mouse can get funky, in particular when you change from ps2 to USB. /dev/psaux sounds good though.

Why run a gui on a server? If it is a true server, it would be better served running GUI free. Make it CLI only. We have about 20 boxes at work, and there isn't a GUI running on any of them. Don't waste system resources drawing pictures, when 99% of the time you don't need the pics.

You're out of Redmond world now. Every single thing servers do can be done from the command line. You have no need to be drawing pictures all over the unit. Since you said this is a practice box, give it a shot and see. Chances are good to great that it will do everything you need.

Peace,
JimBass
 
Old 01-12-2007, 02:27 AM   #6
mouse_x
LQ Newbie
 
Registered: Jan 2007
Location: Norway
Distribution: Debian Etch
Posts: 15

Original Poster
Rep: Reputation: 0
I know everything can be done from the command line, just not by me But I'm getting there (slowly).. As I said earlier, I'm going to install the same software as some of our developers use, so I can test their new stuff.. So it's not going to be used as only a server.. But thanks for the input Jim

I finally got it working by copying the info from our other debian machine (why didn't I think of it before?) The file also says that if it's written to manually, you have to make some changes before getting it to be updated by xfree86 again, could that be the reason none of my changes worked?

For all others in the future with the same problem:
(I have no idea why there is two devices here and I only had one?)
Code:
Section "InputDevice"
Identifier    "Configured Mouse"
Driver        "mouse"
Option        "CorePointer"
Option        "Device"          "/dev/psaux"
Option        "Protocol"        "PS/2"
Option        "Emulate3buttons" "true"
Option        "ZAxismapping"    "4 5"
EndSection

Section       "InputDevice"
Identifier    "Generic Mouse"
Driver        "mouse"
Option        "CorePointer"
Option        "Device"          "/dev/input/mice"
Option        "Protocol"        "ImPS/2"
Option        "Emulate3buttons" "true"
Option        "ZAxismapping"    "4 5"
EndSection
 
  


Reply

Tags
debian, mouseconfig


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian - can't use keyboard/mouse Gnome 1jamie Debian 2 09-13-2004 12:40 PM
Debian mouse problems muxman Debian 9 09-03-2004 06:42 PM
Debian mouse problems muxman Linux - Hardware 4 04-28-2004 04:11 AM
debian mouse problems trendkiller Linux - Software 4 03-09-2004 11:02 AM
Debian mouse problems elkrammer Linux - Distributions 5 07-16-2002 03:46 PM


All times are GMT -5. The time now is 11:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration