LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-11-2004, 08:39 AM   #1
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Rep: Reputation: 15
Problems with Kernel 2.6.2 (sorry posted it in wrong forum before)


hi, i havent found a solution for this yet.

i am running sid/sarge debian on my comp. before i was using 2.4.24 and 2.4.20 and everything worked fine.
yesterday i copied my old .config to the new kernel source, set up the kernel and compiled it.
when i boot with my old lilo (vga=791) the screen will stay blank. as soon i remove the vesa setting it works but using a terrible low resolution.

so i didnt compile framebuffer support into the kernel it seems, but i did. as well i checked the box for vesa driver.

i am running a nvidia geforce card, in case this should be relevant.

is there anything else i missed or is this thing just buggy within the new kernel??? i need this new kernel due problems with some other hardware. as well i am nosy ;-)

thanks for help
 
Old 02-11-2004, 09:48 AM   #2
apepost
Member
 
Registered: Oct 2003
Distribution: Fedora core 4
Posts: 113

Rep: Reputation: 15
What does the video relative parts of your /etc/X11/XF86Config (or similiar file on your system) look like?
 
Old 02-11-2004, 01:59 PM   #3
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Original Poster
Rep: Reputation: 15
thanks for answer.

sorry my question wasn't clear. x11 is working fine. i am writing this message within KDE under 2.6.2.

the only problem is that i have no console at the moment. it seems that something is missing. if i add vga=791 to my lilo.conf the screen stay black. as i remove this option my screen wont be blank but i will get a resolution of 640x480 or something similar in my console....

within 2.4.24 everything was fine choosing VESA console or smth like this and turing on Frame buffer device.
in 2.6.2 only frame buffer device option is left it seems...

any suggestions?
 
Old 02-11-2004, 04:26 PM   #4
bnice
Member
 
Registered: Feb 2004
Location: Sacramento, CA
Distribution: Slack 9.1, slackware-current
Posts: 284

Rep: Reputation: 30
Quote:
so i didnt compile framebuffer support into the kernel it seems, but i did. as well i checked the box for vesa driver.
Did you also check "Framebuffer Console Support"?
 
Old 02-12-2004, 02:59 AM   #5
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Original Poster
Rep: Reputation: 15
yes i checked it. anything else i could forget???
do i need to compile a driver for my nvidia geforce now?? (x11 is working without it at the moment) console doesnt.
 
Old 02-12-2004, 03:04 AM   #6
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Original Poster
Rep: Reputation: 15
sorry ive read your answer again. fb CONSOLE support. not sure if i checked it. is it within the console menu? i checked every checkbox within this menu to be sure ;-)
i am not able to check if its enabled atm (at work). ill do it this evening. thanks for help meanwhile
 
Old 02-12-2004, 03:26 AM   #7
S_Warlock
Registered User
 
Registered: Feb 2004
Location: Sweden Södertälje
Distribution: Archlinux, crux and gentoo
Posts: 32

Rep: Reputation: 15
Selution to your problem

set your vga to normal in your lilo.conf.
Change vga=791 to vga = normal then save and tape lilo no errror then reboot.

/ Teo
 
Old 02-12-2004, 03:34 AM   #8
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Original Poster
Rep: Reputation: 15
Re: Selution to your problem

Quote:
Originally posted by S_Warlock
set your vga to normal in your lilo.conf.
Change vga=791 to vga = normal then save and tape lilo no errror then reboot.

/ Teo
ya it will solve one problem. i will have a console again. but this console is with a terrible resolution :-) i wont work with this resolution. even MSDOS has a better one.
 
Old 02-12-2004, 04:10 AM   #9
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
Um yeah I have had this same problem too, but there is a simple solution. You just have to recompile your kernel. This time make sure to include the proper fonts in the compile. I dont recall off the top of my head where they are exactly BUT you will know when you find them. There are two that you should select 8x8 and 8x16 or something like that. Whatever the case is, if you dont select (maybe at least one but ive always selected both of) these fonts, then I am sure that you will be blackscreened.

がんばって

Later.

Ok Im nice doubleplus nice. I checked for you:
Graphics support --->
Console display driver support --->

<*> Framebuffer Console support x x
x x[*] Select compiled-in fonts x x
x x[*] VGA 8x8 font x x
x x[*] VGA 8x16 font

You should be golden
 
Old 02-12-2004, 09:21 AM   #10
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Original Poster
Rep: Reputation: 15
got another source for help within another thread. in case someone has the same problems.

http://www.linuxquestions.org./quest...652#post752652

ill post if FB_CONSOLE is working again or not when i recompiled. thx for help meanwhile.
 
Old 02-12-2004, 12:03 PM   #11
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Original Poster
Rep: Reputation: 15
oki just to clear things out:

with these settings fb for console wasn't working:
Code:
#
# Console display driver support
#
CONFIG_VGA_CONSOLE=y
CONFIG_MDA_CONSOLE=m
CONFIG_DUMMY_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_PCI_CONSOLE=y
# CONFIG_FONTS is not set
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y

#
# Logo configuration
#
CONFIG_LOGO=y
as well this one was enabled:

Code:
#
# Graphics support
#
CONFIG_FB=y
CONFIG_FB_CYBER2000=m
# CONFIG_FB_IMSTT is not set
CONFIG_FB_VGA16=m
CONFIG_FB_VESA=y
CONFIG_VIDEO_SELECT=y
CONFIG_FB_HGA=m
CONFIG_FB_RIVA=m
# CONFIG_FB_I810 is not set
CONFIG_FB_MATROX=m
CONFIG_FB_MATROX_MILLENIUM=y
CONFIG_FB_MATROX_MYSTIQUE=y
CONFIG_FB_MATROX_G450=y
CONFIG_FB_MATROX_G100=y
CONFIG_FB_MATROX_I2C=m
CONFIG_FB_MATROX_MAVEN=m
CONFIG_FB_MATROX_MULTIHEAD=y
CONFIG_FB_RADEON=m
CONFIG_FB_ATY128=m
CONFIG_FB_ATY=m
CONFIG_FB_ATY_CT=y
CONFIG_FB_ATY_GX=y
# CONFIG_FB_ATY_XL_INIT is not set
CONFIG_FB_SIS=m
CONFIG_FB_SIS_300=y
trying to disable config_fonts now.
 
Old 02-12-2004, 02:15 PM   #12
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Original Poster
Rep: Reputation: 15
finally i got it.

the way i dit it:
i deleted the original source from www.kernel.org and downloaded the new kernel-source-2.6.2.deb via apt-get.
i used the old config file and reran the compile the debian way (make-kpkg) and installed the kernel. now it works and i have even 2 penguin logos at boot time hahaha.

i think there was a patch missing. debian doc says there are some debian patches applied to it...

well its working. :-)

thanks for help everyone
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Provide newbies with forum in which they last posted. scurver LQ Suggestions & Feedback 1 11-30-2004 03:01 PM
Posted this in the worng forum before maybe you guys could help.... sph90457 Linux - Games 1 10-22-2003 05:59 PM
originaly posted in newbie forum Ashtray Linux - Networking 1 07-16-2003 06:36 AM
Maybe on the wrong forum... Crazy Banana Linux - Hardware 2 11-24-2002 06:40 AM
Important Partitioning Question (also posted in Installation forum). Please HELP! Soulstice Linux - Newbie 12 07-14-2001 04:44 PM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration