LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-18-2005, 08:52 PM   #1
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Rep: Reputation: 31
Problems with installing Philips To U cam Pro


I Have the Philips to U cam pro.
I'd like to use it under Linux, but there seems to be no way to get it running.
i learned on my search for help on the net, that this is a driver issue.
The problem can be fixed by updating ov511 to the latest version (2.27). The problem is, the kernel module does not compile under FC4!

This happens while 'make'-ing:
Code:
    Building OVCam drivers for 2.6 kernel.
    PLEASE IGNORE THE "Overriding SUBDIRS" WARNING
make -C /lib/modules/2.6.11-1.1369_FC4/build SUBDIRS=/home/bereziak/Desktop/ov511-2.27 modules
make[1]: Entering directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'
  CC [M]  /home/bereziak/Desktop/ov511-2.27/ov511_core.o
/home/bereziak/Desktop/ov511-2.27/ov511_core.c:1674: error: ‘I2C_ADAP_CLASS_CAM_DIGITAL’ undeclared here (not in a function)
/home/bereziak/Desktop/ov511-2.27/ov511_core.c: In function ‘ov51x_mmap’:
/home/bereziak/Desktop/ov511-2.27/ov511_core.c:4884: warning: implicit declaration of function ‘remap_page_range’
make[2]: *** [/home/bereziak/Desktop/ov511-2.27/ov511_core.o] Error 1
make[1]: *** [_module_/home/bereziak/Desktop/ov511-2.27] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.11-1.1369_FC4-i686'
make: *** [default] Error 2
installing makes no sence afterwards becoude there is no *.ko file that could be added to the Kernel modules.
Hence, it doesn't work.

So, um... maby someone else had to tackle this problem and came out victorius?
Any help is very appreciated!
 
Old 11-13-2005, 03:19 PM   #2
foolsh
Member
 
Registered: Apr 2005
Location: IL
Distribution: kubuntu
Posts: 56

Rep: Reputation: 15
http://home.insightbb.com/~foolsh/

Last edited by foolsh; 04-24-2006 at 02:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips "Fun Cam" webcam not working DaneM Linux - Hardware 5 09-09-2011 09:01 PM
Intel Pro cam and Suse!!!! agentdunken Linux - Hardware 1 08-31-2005 08:38 PM
Problems using Philips ToUcam PRO II with 'streamer' and 'xawtv' kenhall4 Mandriva 3 07-25-2005 07:20 PM
SuSE 9.1 + Philips ToUcam Pro iain.ross Linux - Hardware 0 08-06-2004 06:27 AM
IBM PC Cam Pro...No Driver bullwinkle Linux - Hardware 0 07-18-2004 04:27 AM


All times are GMT -5. The time now is 08:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration