LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-21-2005, 07:24 PM   #1
tjulius
LQ Newbie
 
Registered: Apr 2005
Posts: 15

Rep: Reputation: 0
Problems setting up ProFTP


I'm just getting going on Linux, running RedHat Enterprise edition.

I'm trying to set up ProFTP, and I used the tutorial here but took a wrong turn somewhere. Now I'm trying to follow the instructions at redhat.hostinghacks.net/proftp/ and have made better progress, but am now stuck on one point.

After I set up the proftpd init script (as stored in etc/init.d), I chmod it to 755, add it to chkconfig, and then give the command: service proftpd start.

This calls the start function in the script, which hoses out on this line:
daemon proftpd $OPTIONS

as such:

daemon: command not found.

I did it from the command line and got:

-bash: daemon: command not found

What's not found? Is daemon not found? If not, what should I use, or what should I install? Is proftpd not found? If so, where should it be, and with what permissions?

I think I'm just missing some little step here. Soooo close, and yet soooo far...

Thanks for any insight.

- t
 
Old 04-22-2005, 01:17 AM   #2
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
Quote:
daemon: command not found
It's telling you right there . It's saying that the command 'daemon' cannot be found. Looks like your startup script is somewhat incorrect as proftpd's binary should not be called daemon. If you can't disect and fix the startup script then I suggest you write your own.

-twantrd
 
Old 04-22-2005, 01:59 AM   #3
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,762

Rep: Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587
Quote:
This calls the start function in the script, which hoses out on this line:
daemon proftpd $OPTIONS
as such:
daemon: command not found.
Perhaps you have to put the directory where you installed proftpd in your PATH. Or write down the whole path to proftpd in the startup script:
Code:
 daemon /path/to/proftpd $OPTIONS
 
Old 04-22-2005, 07:00 AM   #4
tjulius
LQ Newbie
 
Registered: Apr 2005
Posts: 15

Original Poster
Rep: Reputation: 0
But if daemon itself is not found....???

??
 
Old 04-22-2005, 08:40 AM   #5
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,762

Rep: Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587
Replace daemon with startproc and see what happens.
 
Old 04-22-2005, 09:46 AM   #6
tjulius
LQ Newbie
 
Registered: Apr 2005
Posts: 15

Original Poster
Rep: Reputation: 0
I actually had done that

I have used loadproc and startproc, all were not found.

I didn't come running here first; I've actually invested (wasted, maybe) a fair amount of time on this.

I've also compared it to other entries in init.d... for instance, syslog can be started, and is command is:

start() {
echo ... something ....
daemon syslogd $SYSLOGD_OPTIONS
.. some other stuff..
}


so that works just fine. Syntactically it's a little different... it has start(){}, and I have start) ;;

It also starts with bin/bash, and I start with bin/sh.. does that make a difference? I tried bin/bash, but no difference, although I didn't try changing the whole syntax around. And the scripts I referenced were explicitly written for redhat, so one would think they work.
 
Old 04-22-2005, 11:15 AM   #7
tjulius
LQ Newbie
 
Registered: Apr 2005
Posts: 15

Original Poster
Rep: Reputation: 0
Found that part of the problem

I compared it against syslog, which did seem to run, and traced it to the beginning of the script.

I had:

./etc/rc.d/init.d/functions

Syslog had:

. /etc/init.d/functions

To make a long story short, it was the space between the period and the / (not so much the directory). There is a file called "functions" in /etc/rc.d/init.d/, and there is a function "daemon" in it. Since /etc/... is off the root, and not relative, I realized the space was not a type but was intentional, changed it, and that problem went away.

There's now a new problem "execvp: No such file or directory", but I'm just beginning to look at that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems setting up bind9 hwa Linux - Networking 2 04-10-2005 10:47 PM
PROFTP User Account Problems Snakeage Linux - General 3 12-19-2003 05:44 PM
ProFtp problems chewysplace Linux - Software 0 11-21-2003 07:04 PM
proftp conf problems ... phoeniXflame Linux - Software 1 06-25-2003 11:36 AM
ProFTP login problems Syncrm Linux - General 1 05-17-2002 01:35 PM


All times are GMT -5. The time now is 03:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration