LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-04-2006, 11:45 PM   #1
jaychamp
LQ Newbie
 
Registered: Jan 2006
Location: FL
Distribution: Kubuntu(Dapper)
Posts: 26

Rep: Reputation: 15
Problems running Buildset


Trying to install an icon theme and when I try to run ./buildset I get the following:

Code:
Checking for kdialogFound /usr/bin/kdialog
Checking for unrar no.
Checking for rar no.

No unrar program found (unrar | rar).

I will ask for decompressed directory.
Checking for bzip2... found /usr/bin/bzip2
Checking for tar...  found /bin/tar
Checking for convert...  found /usr/bin/convert

Dependencies met - this script is using:
                /usr/bin/bzip2 as compressor
                /bin/tar as tar path
                /usr/bin/convert as convert path
                There is no unrar found,
        BUILDER WILL WORK ONLY WITH ALREADY EXTRACTED DIRECTORY
unrar functions
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdialog: cannot connect to X server :0.0
wrong dir
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
 
Old 06-05-2006, 01:29 AM   #2
soulxcavtor
Member
 
Registered: May 2006
Location: USA.FLorida
Distribution: Mandriva 2006 PowerPack
Posts: 238

Rep: Reputation: 30
Looks like something needs to be extracted first, before it can be executed and apparently thats not happeningm kdialog cannot find the correct directory (probably because its in some type of compression format). I dont know what I'm talking about though, hopefully youll get someone better to help u

Last edited by soulxcavtor; 06-05-2006 at 01:33 AM.
 
Old 06-05-2006, 01:18 PM   #3
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Two things to mention:

1. unrar and rar are arching tools. You can get the package for your distrobkution (usually) through the Universal repository under non-free. It seems you do not have that installed

2. The refusal of the X server is probably because the build is taking place in the wrong environment (possibly should be root). I have only experienced this once, and this was my issue.

Bob
 
Old 06-05-2006, 03:13 PM   #4
jaychamp
LQ Newbie
 
Registered: Jan 2006
Location: FL
Distribution: Kubuntu(Dapper)
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks guys, I'll give that a go when I get home from work. Will post results
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems running thunderbird? Erik_the_Red Linux - Software 4 12-05-2005 04:40 PM
Problems running Azureus Mr.H Linux - Software 11 06-13-2005 12:47 PM
Problems running Xchat 2.0.8 Zé Tom Linux - Software 2 04-14-2004 04:28 PM
Problems with running Amsn krackerroot Linux - Software 7 10-12-2003 11:41 AM
Problems running Setup Josnap Slackware 3 09-02-2003 04:29 AM


All times are GMT -5. The time now is 06:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration