LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-30-2005, 03:03 AM   #1
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Rep: Reputation: 30
Problems loading etho upon boot


Recently, I switched to DSL. And during boot, the "Bringing up Interface eth0" hangs about 2 minutes.

I sure I cant disable the eth0 because its used for the DSL newtwork card. Is there an easy soltuion to this?
 
Old 01-30-2005, 05:18 AM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Please post /etc/resolv.conf , /etc/hosts and the output of the command (as root) of lspci. Mine, for your reference:
Code:
; Duron 950 tinwhistle /etc/resolv.conf file
; generated by /sbin/dhclient-script
nameserver 205.244.112.20
nameserver 206.74.254.2
nameserver 205.244.200.3
nameserver 204.116.57.2
Code:
# Duron tinwhistle /etc/hosts file
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1       tinwhistle      localhost       localhost.localdomain
192.168.0.2     bones
192.168.0.3     tinwhistle
192.168.0.4     uilleann
Code:
<snip>
00:03.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Et
hernet (rev 90)
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139
C+ (rev 10)
<snip>
 
Old 01-30-2005, 11:27 AM   #3
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
This is not the first time this is happened. It also happened when I had dial-up modem. I fixed the problem by the following actions:

/etc/modules.config
#eth0=to disable eth0 upon boot

I just removed the # where said eth0. And that resolved the issue.

Also one thing to note here. I am on a dynamic IP servic and not Static. My IP changes on DSL.

So, please help me on this please. I am on my Windows box most of the time to post these questions and replies so I hat to go back and forth and so. So I cant give you the output. Just explain on how we could resolve this issue please.
 
Old 01-30-2005, 11:46 AM   #4
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Im not able to get the putput of the following /etc/resolv.cong and /etc/hosts One says permission denied and other No such directory. But got the output for lspci:

Code:
00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 05)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 05)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 05)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 05)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 05)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 05)
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 420] (rev a3)
02:08.0 Ethernet controller: Intel Corp. 82801BA/BAM/CA/CAM Ethernet Controller (rev 03)
02:09.0 Serial controller: US Robotics/3Com 56K FaxModem Model 5610 (rev 01)
But like I said, this happened to me when I had dial-up. I resolved by: removing the # under where it says something about eth0 under /etc/modules.config.

I went there now, and I see this under /etc/modules.config: What should I do in here to resolve this issue???

probeall scsi_hostadapter ide-scsi
probeall usb-interface usb-uhci
#alias eth0 eepro100
alias sound-slot-0 i810_audio
#alias eth0 eepro100

#alias eth0 eepro100
alias eth0 eepro100

Last edited by wardialer; 01-30-2005 at 11:49 AM.
 
Old 01-30-2005, 12:01 PM   #5
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
A vfat (fat32) partition is real handy for passing info to Windows as Linux can safely write to that particular Windows file system. Then you could write a text file to that partition, then command unix2dos /path/to/<filename> to convert to the Microsoft format (it uses an extra carriage return with the linefeed), then you could pass info back and forth between the uncooperative OS and Linux.

OK, this identifies your ethernet card:
Code:
<snip>
02:08.0 Ethernet controller: Intel Corp. 82801BA/BAM/CA/CAM Ethernet Controller (rev 03)
<snip>
In order to administer your box, you must be root, so use this command for full root access:

su -

(note the dash)

I am on DSL as well, so It still sounds as if your /etc/hosts file (or whever Mandrake may put it) isn't correct for the loopback device.

Can you read these?:

man hosts

or

info hosts

Make sure the loopback is identified correctly, i.e. this part:
Code:
# Duron tinwhistle /etc/hosts file
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1       tinwhistle      localhost       localhost.localdomain
<snip>
If not, try creating the file, changing to fit your box.

Also, make sure that the module (linux google should give some hints for your particular kernel module) for your eth0 is loaded:
Code:
Sun Jan 30 11:54 AM root@tinwhistle ~ # lsmod
<snip>
8139too                16392   1
mii                     3992   0  [8139too]
sis900                 15372   1
<snip>
Any error messages using these commands as root?

ifdown eth0
ifup eth0

Basic system administration
To change to the full root account (system administrator), if you are running X, open an x terminal and use these commands from your user account. Note the change in the prompt. You can do the same from a virtual terminal as well, but you can't open an x terminal to do so.
Code:
[fancy@tinwhistle fancy]$ su -
Password: <give root password and press enter>
[root@tinwhistle root]#
Remember, now whatever you command in root (it's the "god" mode. You can bless or destroy at your whim) usually gets done if enough system is left to carry out the command. Sit on your hands and read the commands you type at least 3 times before pressing the enter key when in root.

Last edited by fancypiper; 01-30-2005 at 12:12 PM.
 
Old 01-30-2005, 12:14 PM   #6
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
I cant get to the /etc/hosts. Permission denied. I did an 'su-' and then my password. But no luck. Like I said, this also happened when I was using a dial-up and I did some small setting by removing or adding (I forgot) the '#' next to where it says about eth0 under /etc/modules.config.
 
Old 01-30-2005, 12:19 PM   #7
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Quote:
Originally posted by wardialer


But like I said, this happened to me when I had dial-up. I resolved by: removing the # under where it says something about eth0 under /etc/modules.config.

I went there now, and I see this under /etc/modules.config: What should I do in here to resolve this issue???

probeall scsi_hostadapter ide-scsi
probeall usb-interface usb-uhci
#alias eth0 eepro100
alias sound-slot-0 i810_audio
#alias eth0 eepro100

#alias eth0 eepro100
alias eth0 eepro100
I would remove all references except for only one to the eepro100 module, if that is the correct one for your ethernet card.

As it stands, you are attempting to bring it up more than once. Mandrake may use some kind of script to undo your manual changes (one reason I don't use Mandrake, plus their wanting payment to use the user's page.

# Mandrake links
Mandrake home page
Mandrake Users website (needs money to access now)
Software management configuration: Easy urpmi config for Mandrake
Software management: urpmi mini-HOWTO
Software management: All You Ever Wanted to Know About Urpmi But Never Dared Asking Before
You didn't install the developmental packages? As root, command:
urpmi gcc
An Introduction to the Midnight Commander. You can install it by commanding:
urpmi mc
Midnight Commander home page
 
Old 01-30-2005, 12:25 PM   #8
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Quote:
Originally posted by wardialer
I cant get to the /etc/hosts. Permission denied. I did an 'su-' and then my password. But no luck. Like I said, this also happened when I was using a dial-up and I did some small setting by removing or adding (I forgot) the '#' next to where it says about eth0 under /etc/modules.config.
Like I said, it looks as if Mandrake has a script that adds it back to your /etc/modules.conf file.

# For finding or locating files
find
locate
which
whereis

See man pages for flags needed for the find command, especially. If you have run (usually in a cron job for around 4 AM in most distros) the command updatedb, locate will find it quickly.

It can be a long list, so pipe to less:

locate hosts | less
 
Old 01-30-2005, 12:44 PM   #9
infantpenguin
LQ Newbie
 
Registered: Jan 2005
Distribution: debian
Posts: 26

Rep: Reputation: 15
Hey wardialer, I feel your pain. I have Mandrake and it is hanging on the same thing.
Fancypiper: where should one start to fix this problem if one intends to have the possibility to use ethernet, modem and internal wireless?
/linux still hangs a good 3 minutes less than windows xp
 
Old 01-30-2005, 03:19 PM   #10
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
Ok, Please explain step by step on what to do. Im still confused. I appologize.

What do you want me to comment out under the /etc/module.config???

I want this problem to be solved ASAP. It hangs for like 3 minutes. But like I said, I still cant access the /etc/hosts directory. So, theres something in /etc/modules.config that I need to do below? What should be removed as it says eepro100 many times and I do not really know which one do you want me to keep.
The network card (eepro) is the correct one. I checked under Windows its a Intel Pro/100E


probeall scsi_hostadapter ide-scsi
probeall usb-interface usb-uhci
#alias eth0 eepro100
alias sound-slot-0 i810_audio
#alias eth0 eepro100

#alias eth0 eepro100
alias eth0 eepro100

Last edited by wardialer; 01-30-2005 at 03:24 PM.
 
Old 01-30-2005, 06:04 PM   #11
wardialer
Member
 
Registered: Sep 2004
Distribution: SUSE Linux Pro 9.3
Posts: 375

Original Poster
Rep: Reputation: 30
I guess know one knows how to solve this issue. Please, I need this resolved as soon as possible.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis, GRUB and XP boot loading problems eccentric4 MEPIS 9 09-25-2005 07:32 PM
solaris boot problem boot error loading interpreter(misc/krtld) Johncy_j Solaris / OpenSolaris 5 08-18-2005 02:47 AM
Problems loading ivtv drivers at boot cdhgee Linux - Software 0 08-16-2005 06:26 AM
found etho, but no eth1? Help! fa_king Red Hat 3 01-05-2005 05:40 PM
etho not initializing oke Linux - Newbie 4 12-10-2002 08:08 AM


All times are GMT -5. The time now is 06:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration