LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-02-2007, 01:46 AM   #1
kantor_98
Member
 
Registered: Jan 2007
Posts: 68

Rep: Reputation: 15
Problems installing vlc


OK, i think it is still a repo problem, but... i try to inslall vlc
yum -y install videolan-client
I received a lot of messages, like:

vlc-0.8.6b-1.lvn6.i386.rp 100% |=========================| 86 kB 00:02
---> Package vlc.i386 0:0.8.6b-1.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: libjack.so.0 for package: vlc
--> Processing Dependency: libwx_baseu-2.6.so.0(WXU_2.6) for package: vlc
--> Processing Dependency: libxosd.so.2 for package: vlc

etc, etc, etc and after that

--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libtar to pack into transaction set.
libtar-1.2.11-8.fc6.i386. 100% |=========================| 4.0 kB 00:00
---> Package libtar.i386 0:1.2.11-8.fc6 set to be updated
---> Downloading header for libdca to pack into transaction set.
libdca-0.0.2-3.lvn6.i386. 100% |=========================| 3.6 kB 00:00
---> Package libdca.i386 0:0.0.2-3.lvn6 set to be updated

etc, etc, etc, and after that, again:

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
vlc i386 0.8.6b-1.lvn6 livna 6.1 M
Installing for dependencies:
SDL_image i386 1.2.5-4.fc6 extras 43 k
aalib i386 1.4.0-5.fc6.rf dries 98 k
dirac i386 0.6.0-1.fc6.rf dries 924 k
ffmpeg-libs i386 0.4.9-0.35.20070204.lvn6 livna 1.6 M
freeglut i386 2.4.0-11.fc6 extras 142 k
jack-audio-connection-kit i386 0.102.20-3.fc6 extras 137 k
libcaca i386 0.99-0.1.beta11.fc6 extras 160 k
libcddb i386 1.3.0-1.fc6.rf dries 70 k
libcdio i386 0.77-3.fc6 extras 258 k
libdca i386 0.0.2-3.lvn6 livna 103 k
libdvbpsi i386 0.1.5-2.lvn6 livna 39 k
libdvdnav i386 0.1.10-3.fc6 freshrpms 90 k
libdvdread i386 0.9.7-2.fc6 extras 66 k
libebml i386 0.7.7-2.fc6 extras 72 k
libfreebob i386 1.0.0-3.fc6 extras 155 k
libmatroska i386 0.8.0-4.fc6 extras 199 k
libshout i386 2.2.2-1.fc6 extras 43 k
libsndfile i386 1.0.17-1.fc6 extras 230 k
libtar i386 1.2.11-8.fc6 extras 29 k
libupnp i386 1.4.3-1.fc6 extras 108 k
lirc i386 0.8.1-1.fc6 extras 240 k
mpeg2dec i386 0.4.1-2.lvn6 livna 101 k
svgalib i386 1.9.25-3.fc6 extras 465 k
twolame i386 0.3.9-1.fc6 freshrpms 78 k
vcdimager i386 0.7.23-5.fc6.rf dries 642 k
wxGTK i386 2.6.3-2.6.3.2.3.fc6 extras 3.5 M
xosd i386 2.2.14-9.fc6 extras 47 k

Transaction Summary
================================================== ===========================
Install 28 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 16 M
Downloading Packages:
(1/28): libtar-1.2.11-8.f 100% |=========================| 29 kB 00:00
(2/28): libdca-0.0.2-3.lv 100% |=========================| 103 kB 00:03
(3/28): libfreebob-1.0.0- 100% |=========================| 155 kB 00:02
(4/28): libcddb-1.3.0-1.f 100% |=========================| 70 kB 00:00
(5/28): libupnp-1.4.3-1.f 100% |=========================| 108 kB 00:01
(6/28): lirc-0.8.1-1.fc6. 100% |=========================| 240 kB 00:04
(7/28): wxGTK-2.6.3-2.6.3 100% |=========================| 3.5 MB 00:44
(8/28): libshout-2.2.2-1. 100% |=========================| 43 kB 00:00
(9/28): SDL_image-1.2.5-4 100% |=========================| 43 kB 00:00
(10/28): libmatroska-0.8. 100% |=========================| 199 kB 00:02
(11/28): libcaca-0.99-0.1 100% |=========================| 160 kB 00:01
(12/28): libcdio-0.77-3.f 100% |=========================| 258 kB 00:04
(13/28): libebml-0.7.7-2. 100% |=========================| 72 kB 00:00
(14/28): vcdimager-0.7.23 100% |=========================| 642 kB 00:02
(15/28): libsndfile-1.0.1 100% |=========================| 230 kB 00:03
(16/28): twolame-0.3.9-1. 100% |=========================| 78 kB 00:00
(17/28): svgalib-1.9.25-3 100% |=========================| 465 kB 00:05
(18/28): ffmpeg-libs-0.4. 100% |=========================| 1.6 MB 01:06
(19/28): libdvbpsi-0.1.5- 100% |=========================| 39 kB 00:00
(20/28): dirac-0.6.0-1.fc 100% |=========================| 924 kB 00:03
(21/28): libdvdnav-0.1.10 100% |=========================| 90 kB 00:01
(22/28): jack-audio-conne 100% |=========================| 137 kB 00:02
(23/28): libdvdread-0.9.7 100% |=========================| 66 kB 00:01
(24/28): xosd-2.2.14-9.fc 100% |=========================| 47 kB 00:00
(25/28): vlc-0.8.6b-1.lvn 100% |=========================| 6.1 MB 04:22
(26/28): aalib-1.4.0-5.fc 100% |=========================| 98 kB 00:00
(27/28): freeglut-2.4.0-1 100% |=========================| 142 kB 00:02
(28/28): mpeg2dec-0.4.1-2 100% |=========================| 101 kB 00:02
Running Transaction Test
Finished Transaction Test

I was OK until there, but then appear:

Transaction Check Error: file /usr/lib/libavcodec.so.51 from install of ffmpeg-libs-0.4.9-0.35.20070204.lvn6 conflicts with file from package ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/libavformat.so.51 from install of ffmpeg-libs-0.4.9-0.35.20070204.lvn6 conflicts with file from package ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/libavutil.so.49 from install of ffmpeg-libs-0.4.9-0.35.20070204.lvn6 conflicts with file from package ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/drawtext.so from install of ffmpeg-libs-0.4.9-0.35.20070204.lvn6 conflicts with file from package ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/fish.so from install of ffmpeg-libs-0.4.9-0.35.20070204.lvn6 conflicts with file from package ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/imlib2.so from install of ffmpeg-libs-0.4.9-0.35.20070204.lvn6 conflicts with file from package ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/null.so from install of ffmpeg-libs-0.4.9-0.35.20070204.lvn6 conflicts with file from package ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/ppm.so from install of ffmpeg-libs-0.4.9-0.35.20070204.lvn6 conflicts with file from package ffmpeg-0.4.9-0.8.20070109.fc6
file /usr/lib/vhook/watermark.so from install of ffmpeg-libs-0.4.9-0.35.20070204.lvn6 conflicts with file from package ffmpeg-0.4.9-0.8.20070109.fc6

Ugly, isn't ? When I give
whereis vlc
I recive message
vlc:
and that is all. What can I do now ? It is installed ? I must uninstall it ? Have I set repo that are not compatible ? I must confess that I was surprised by sequences like:

libcddb i386 1.3.0-1.fc6.rf dries 70 k
libcdio i386 0.77-3.fc6 extras 258 k
libdca i386 0.0.2-3.lvn6 livna 103 k
libdvbpsi i386 0.1.5-2.lvn6 livna 39 k
libdvdnav i386 0.1.10-3.fc6 freshrpms 90 k

Why it take parts from different repos ? There is not the whole vlc in a single repo ? (I reffer to the fact that it takes pieces of repo from livna, other pieces from freshrpm and so on...).
OK, don't forget my main question:: what can i do now refferring to vlc ????
 
Old 05-02-2007, 02:28 AM   #2
Gryyphyn
Member
 
Registered: Dec 2006
Location: Ogden, UT (Go OALUG!)
Distribution: OpenSuSE 10.1
Posts: 61

Rep: Reputation: 15
Unhappy

Well, you could check your repos against the videolan.org repo suggestions. Often times they'll list repos to add to your list/pull from that have everything you need with compiled scripts to guide tar. If that doesn't work you may have to do a package download and install manually. That's what I had to do because I'm on OpenSUSE (doesn't like to play with package repos very well...). Good luck.

Gryyphyn, out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Installing VLC Player. LoveKing Linux - Software 7 03-29-2006 10:02 AM
Problems installing VLC bmccorm2 Linux - Newbie 2 10-20-2005 03:48 PM
help installing vlc on 9.3 shadowsa Suse/Novell 1 09-28-2005 02:40 AM
Installing VLC st95accord Fedora 4 05-15-2005 11:26 AM
Still having problems with installing VLC djljjm Linux - Newbie 1 11-19-2004 05:19 PM


All times are GMT -5. The time now is 10:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration