LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2004, 09:12 AM   #1
timmytytim
LQ Newbie
 
Registered: Dec 2004
Location: Amsterdam
Distribution: Fedora Core 3
Posts: 10

Rep: Reputation: 0
Question Problems installing D-Link DWL-520+ on FC3


Hello,

I am very new to linux and I know absolutely next to nothing about it. This morning I finally managed to install FC3 on one of my old systems. Everything seems to work as it should except for my D-Link DWL-520+ Wireless PCI adapter. Now i think i have downloaded the correct drivers.

I downloaded the following file: acx100-0.2.0pre8_plus_fixes_43.tar.gz

This seemed to be the most recent file. However now that I have this file I have no clue what to do with it. How do I install these drivers? Do I need to write some commands in the terminal? Anyone willing to help out a lost newby?

Thanks.

Tim
 
Old 12-26-2004, 09:44 AM   #2
matthias49
LQ Newbie
 
Registered: Dec 2004
Posts: 12

Rep: Reputation: 0
there must be a how-to somewhere in the package you downloaded, containing all the appropriate commands to type.

Otherwise, you wanna search the linuxquestions.org, I think I saw a thread where the questions was tackled.

Good luck,

Matt
 
Old 12-26-2004, 01:11 PM   #3
timmytytim
LQ Newbie
 
Registered: Dec 2004
Location: Amsterdam
Distribution: Fedora Core 3
Posts: 10

Original Poster
Rep: Reputation: 0
Yea. there is a README. I've tried to follow all the instructions but I simply can't manage to get it to work. FC3 is not even dedecting my wireless adapter. I've also got a normal ethernet adapter.. and it does detect that. But for some reason it does not detect the wireless adapter.

Could anyone who has had experience with this please help me?
 
Old 12-26-2004, 01:28 PM   #4
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Well what problems are you having when following the README file? Is it giving you error messages? What does it tell you to do?
 
Old 12-26-2004, 03:11 PM   #5
timmytytim
LQ Newbie
 
Registered: Dec 2004
Location: Amsterdam
Distribution: Fedora Core 3
Posts: 10

Original Poster
Rep: Reputation: 0
Well first of all it tells me to install the firmware provided by the windows driver...

It tells me to move the following files (which are the Windows 2000 drivers for the D-Link DWL-520+ Wireless PCI Adapter): WLANGEN.BIN, RADIO0d.BIN and RADIO11.BIN to the firmware/ directory. I assumed that the lib/firmware directory is meant by this so thats where i moved them.

Then it tells me that I'm done with the firmware part and I should be "Ready to roll"..

So then I move onto the next section.. called "Linux 2.6 Driver Intallation"

Then I follow the "make inject" command.. At first it then tries to extract files into the /usr/src/linux/drivers/net/wireless/acx directory, however it tells me that it does not exist. So I made that directory.. and tried it again.. Now i get the following error messages..

-Checking for /usr/src/linux/drivers/net/wireless/Kconfig...
*** Cannot open /usr/src/linux/drivers/net/wireless/Kconfig for read at ./script
s/inject_kernel_tree line 86
make: *** [inject] Error 2

So I'm pretty much stuck now.. And I really dont know much about Linux yet since today is the first time I've installed it. But I really wanna learn how to get to use it cuz it looks damn nice, and already seems a lot better than windows! I really wanna get this fixed. Any help would be appreciated, or any link that explains it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
d-link dwl-520 Rev. E redneckcowboy Linux - Wireless Networking 0 10-07-2004 06:19 PM
Installing D-Link DWL-520+ on Fedora Core 2 coolman_no7 Linux - Newbie 5 08-13-2004 08:08 PM
D-Link DWL-520 Drivers mjrdzine Linux - Wireless Networking 33 07-23-2004 08:33 PM
D-link DWL-520+; No such device nsX Linux - Hardware 9 11-12-2003 10:54 PM
d-link dwl-520 hydrokracker Linux - Networking 2 02-16-2003 05:09 AM


All times are GMT -5. The time now is 04:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration