LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-19-2004, 07:51 PM   #1
Thorin98
LQ Newbie
 
Registered: Apr 2004
Location: UK
Distribution: Red Hat Linux 9.0
Posts: 1

Rep: Reputation: 0
Question Problems installing Apache 2.0.49, PHP 4.3.6, and GD 2.0.22


I'm a Linux newbie, running Red Hat 9.0. I've currently got Apache 2.0.40, PHP 4.2.2 and GD 1.6.2. My aim is to upgrade to GD 2, as I'm using Coppermine gallery, and want better quality resized images in it.

I read various things and decided it would be easiest to update PHP to the latest version (4.3.6) as it includes a version of GD 2. I can't remember what phase of the install I got to, but it told me that I needed a newer version of Apache 2. I then attempted to install apache 2.0.49 from source code. This appeared to have been completed successfully, but Apache 2.0.40 still seems to be running, and I can't find the new version (I'd stopped httpd before I installed the new version, and then started it again after the installation). I then tried a different tack again, and tried to install GD 2.0.22. This appeared to complete successfully, but I can't use GD 2 commands, and phpinfo() tells me I still have 1.6.2.

I think I now have two options available:

Get GD 2.0.22 working, I think I need to rebuild PHP to use it, although I'm not sure if I'm right about that, or how to go about it.

Properly install Apache 2.0.49 and then php 4.3.6.

Basically I've just gotten into a bit of a muddle with this. I don't think I've ever managed to successfully install anything by doing a ./configure, make, make install in linux before, I always seem to encounter problems of some sort, so I'm still very much a linux newbie! Any help would be greatly appreciated.

Last edited by Thorin98; 04-19-2004 at 07:55 PM.
 
Old 04-20-2004, 03:13 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,534

Rep: Reputation: 132Reputation: 132
but Apache 2.0.40 still seems to be running...

u can install several versions of apache but if u start the old one - the old one will be running ;-).
what i want to ask is: maybe simply the wrong start command?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing PHP onto Apache LinuxStart Linux - Software 2 07-10-2005 02:39 PM
apache problems after installing PHP madBASHer Programming 1 05-20-2005 04:55 PM
Problems installing Apache/PHP from source minorgod Mandriva 0 09-11-2004 08:45 PM
slackware, apache and PHP from .tgz - problems with PHP szymon Slackware 2 09-06-2004 05:57 PM
need help installing php with apache jsbush Linux - Newbie 3 11-17-2003 10:06 PM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration