LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-13-2004, 02:37 PM   #1
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Rep: Reputation: 15
Problems installing ALSA: insmod snd-intel8x0 fails.


All,

I am 'attempting' to install ALSA on my Linux machine. I am using RH9 kernel 2.4.20-24.9 and have an unsupported Intel soundcard, hence the switch to ALSA (latest version 1.0.1).

After all of the unpacking, ./configure-ing, make-ing, and make install-ing (drivers, libs, and utils), I try to execute the following command:

modprobe snd-intel8x0 --> and get the following errors:

/lib/modules/2.4.20-24.9/kernel/sound/acore/snd.o: unresolved symbol schedule_work
/lib/modules/2.4.20-24.9/kernel/sound/acore/snd.o: insmod (previous directory string) failed
/lib/modules/2.4.20-24.9/kernel/sound/acore/snd.o: insmod snd-intel8x0 failed

After scouring various forums on the net, I have yet to find an answer. Anyone out there had a similar experience and find a way to fix the problem? Does anyone out there possibly know how to fix something like this?

Thanks,

Bret
bwebb@coastal.ufl.edu
 
Old 01-13-2004, 02:48 PM   #2
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
What is your soundcard?

Since you've got ALSA installed now, try (as root)

alsaconf

This should detect your PCI sound card and any modules that go with it (hopefully). If it works, type

alsamixer

Use M to mute/unmute the channels you wish and your arrow keys to increase/decrease levels as well as move to the next channel. Type Esc. to exit it after you're done. Next type:

alsactl store

to save changes.

Hope this helps.
 
Old 01-13-2004, 03:02 PM   #3
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Original Poster
Rep: Reputation: 15
Ah, see I don't think ALSA installed properly...which is why the error occurs?!

I have the Intel Corp. 82801EB AC'97 card. I ran alsaconf, it found it and wrote the appropriate (I think) lines to the modules.conf file, but it doesn't recognize alsamixer. When I execute alsamixer, I get the following respons (even when trying to execute it from the /alsa/alsa-utils-1.0.1/alsamixer/ directory):

alsamixer: function snd_ctl_open failed for default: No such file or directory

alsamixer is definitely in that subdirectory, but it fails to recognize its existence.

Any ideas? Thanks for the response.

Bret
 
Old 01-13-2004, 03:17 PM   #4
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Hmmm....you're running as root right?

It seems as though the actual "alsamixer" file is trying to open the sound control device (hence snd_ctl_open) and can't find it. I would open up the alsamixer executable file itself and see what it's trying to open with the snd_ctl_open file. There will be a call to something. I would then do a locate <whatever it's trying to find> at the CLI and see if I can find it. If it's not where alsamixer is looking, then I would create a symbolic link (symlink) to the place it's looking using the ln -s <real location> <linked location> command.

Hope this helps.
 
Old 01-13-2004, 03:29 PM   #5
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Original Poster
Rep: Reputation: 15
Texicle,

Thanks again for the response. I am, of course, running as root but I think that we've now eclipsed my level of Linux ability. I'm not sure how to open an executable file and read it?! I appreciate your help up until now and don't expect you to waste your time teaching me such things.

I'll do some more investigating and see what I can come up with. There are a lot of questions on the web regarding unresolved symbol errors when excuting modprobe snd-your_card_model#, but little in the way of explanations or solutions.

Thanks again,

Bret
 
Old 01-13-2004, 03:35 PM   #6
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Well, I like to use vi, but other like pico and others out there. To open it in vi, do this:

vi </path/to/alsamixer/filename> --obviously with the correct info

You can use your arrow keys to navigate as well as use page up/down. You exit vi by typing

Esc then : then q!. Basically, the ! will omit any changes you made to it in case you accidentally changed something. More on vi editing will come later as you get into it more. It's fun to learn too.

Anyway, this will open the file for you and you'll see what it's looking for. After you're done and you've Esc :q! out of it, time to go looking for the file.

It's not eclipsing your level of Linux ability...it's learning something new. Welcome to the wonderful world of Linux--you'll always be learn something new.
 
Old 01-13-2004, 03:43 PM   #7
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Original Poster
Rep: Reputation: 15
Texicle,

Hey, I really appreciate your help and unfortunately I wasted your time on that last post. I am an avid user of vi, but when I open alsamixer* (the executable) it just gives me nasty stuff on the screen. I suppose I thought that there was a different way to read an executable file.

Yeah, I've been a Linux 'user' for about one year now, but now I'd like to become a Linux USER!!! I am forcing myself how to learn this OS so that I can be more productive. I realize now that there are a lot of people out there trying to learn as well, so that makes it more fun. Life is also much easier with helpful messageboards and helpful subscribers :-)

Thanks,

Bret
 
Old 01-13-2004, 03:58 PM   #8
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Original Poster
Rep: Reputation: 15
Texicle,

So, when I vi the alsamixer exectuable and search for the string 'snd_cntrl_open' it comes up in about three different locations. It appears that many things are pointing to the directory /proc/asound which doesn't even exist on my system. The directory /proc/ is definitely there, but there is no 'asound' subdirectory.

Other areas of the executable contain references to libm.so files in the proximity of the 'snd_cntrl_open' call, but I don't know if that is relevant or not.

I cannot for the life of me figure out what it might be trying to open with 'snd_cntrl_open'.

Thanks again,

Bret
 
Old 01-13-2004, 03:59 PM   #9
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Not a waste of time. Maybe someone else will read this and learn something.

As for the alsamixer putting crazy stuff on the screen, I'll have to look at it on my own system. I'm at work right now and won't be able to check at home for another 6 hours or so. When I get there I'll take a peek at my alsa stuff and see what's up.

BTW, I'm learning this OS just as you are. That's what I love about it--always something new and neat waiting to be discovered around the corner.
 
Old 01-13-2004, 11:29 PM   #10
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
I opened up the alsamixer executable and got crazy stuff too, but since you mentioned the /proc/asound I thought I'd check my system. I've got it..and it's loaded with other directories too. Maybe you should re-install ALSA. Sorry man.

EDIT: contents of my /proc/asound

Code:
root@phrankenstein:/proc/asound# ls
AudioPCI@  card0/  cards  devices  modules  oss/  pcm  seq/  timers  version

Last edited by Texicle; 01-13-2004 at 11:32 PM.
 
Old 01-14-2004, 06:18 AM   #11
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Original Poster
Rep: Reputation: 15
Texicle,

Yep, it's definitely supposed to be there. I finally found my answer in the ALSA-users mail archives.
Going back to the initial problem - not being able to run modprobe snd-intel8x0 - it turns out that there is some sort of incompatibility issue between the Linux kernel and the RedHat 9 kernel...go figure! The solution was simple and I posted it to this forum, which will hopefully save someone else a few headaches in the future.

So, with the fix I finally got everything installed and there is now a subdirectory /asound/ in the /proc folder. Alsamixer does open up now, but I'm still lacking sound. I've checked every mixer on my computer (alsamixer, aumixer, kmixer, linux volume controls) to ensure that the mutes are turned off and I've set the volume to about 60-70%, but still no dice.

Thanks for all of your help! You're assistance encouraged me to forge ahead and find the answer.

Many thanks,

Bret
 
Old 01-14-2004, 02:30 PM   #12
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
I'm glad you got everything working.

BTW, as for your sound, this is going to sound really stupid and basic, but have you checked to make sure your speakers are plugged in correctly? I went 5 days reconfiguring all kinds of madness to get my sound working right, and finally I decided to pull the sound card and put in a new one. That's when I noticed the speakers were plugged into the Mic jack. LOL

So, check your cables, make sure that /dev/dsp has permissions for your user as well and not just root. Oh yeah, does sound work as root at all while in X?

And, can you post the solution here as well so anyone who happens upon this thread in the future will be able to find it quickly? Thanks.
 
Old 01-14-2004, 02:58 PM   #13
BWebb
Member
 
Registered: Jan 2004
Posts: 32

Original Poster
Rep: Reputation: 15
Texicle,

Hey, I finally got it working today. Everything was plugged in correctly, but I had neglected to change the permissions for /dev/dsp!!! Hahahahahah...I had done it everytime I tried to install unsuccessfully, but forgot to execute it again once I finally got everything installed correctly. What a hoot.

chmod a+rw /dev/dsp /dev/mixer /dev/sequencer --> This fixed the problem immediately.

Here is the solution to 'unresolved symbol schedule_work' or 'insmod snd-intel8x0 failed'

Unpack the alsa-drivers-xxx, run ./configure (with appropriate options and arguments, which in my case I used the following

./configure --with-cards=intel8x0 --with-sequencer=yes

Now the next step is to do the following (while still in the alsa-drivers-xxx directory)

mkdir -p include/linux
touch include/linux/workqueue.h

Now, do make; make install and then move on to the alsa-libs-xxx and alsa-utils-xxx folders and run:
./configure; make; make install ---> this is of course after you've unpacked everything :-)

Now you should be up and running! Thanks again for your help Texicle!!!

Cheers,

Bret
 
Old 01-14-2004, 04:36 PM   #14
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30


I had a feeling /dev/dsp would be causing you a problem. The smallest oversight can cause major headaches. I'm glad you got everything working.
 
Old 01-18-2004, 03:34 AM   #15
jah8102
LQ Newbie
 
Registered: Jun 2003
Posts: 7

Rep: Reputation: 0
BWebb

i had the exact same problem and also found the touch solution on an alsa forum. I applied it and everything worked like a charm. BUT i later restarted and sound stoped working. On bootup it said unresolved symbol so i figured it was the same. problem doing a

depmod -ae give the same error

depmod: *** Unresolved symbols in /lib/modules/2.4.20-28.9/misc/snd.o
depmod: schedule_work
depmod: *** Unresolved symbols in /lib/modules/2.4.20-28.9/snd.o
depmod: schedule_work

The thought i would just recompiile the alsa-driver but no change. Alsamixer works fine, doing the mod probe for all modules gives no errors but there is just no sound!!!

I am a fairly new to linux so i'm totally clueless what to do now.
help! anyone
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
alsaconf fails to load driver for snd-intel8x0 jojotx0 Linux - Software 5 08-01-2007 04:47 PM
snd-intel8x0 can't be found after recompiling 2.4.26(NOT AN AVARAGE ALSA QUESTION!!!) kornerr Linux - General 5 06-02-2005 12:02 PM
Alsa & snd-intel8x0 error hayesben Slackware 12 12-26-2004 04:42 PM
insmod fails on ALSA cs4232 isapnp driver PMCanoe Fedora 0 04-17-2004 07:03 PM
I say snd-intel8x0, you say i810_audio! - ALSA on P4GE-V motherboard robertmarkbram Linux - Hardware 0 06-06-2003 03:05 AM


All times are GMT -5. The time now is 09:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration