LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2014, 02:29 PM   #1
criztian
LQ Newbie
 
Registered: Jun 2014
Posts: 1

Rep: Reputation: Disabled
Problems in Kali Linux 1.0.7


Hi, I'm completely new to Linux and for some reason I have a lot of problems.

When trying to start Software Center I get the message "Items cannot be installed or removed until the package catalog is repaired. Do you want to repair it now?"

When trying to repair the package catalog (repairing installed software) I get "Package operation failed. The installation of removal of a software package failed." The details are:

installArchives() failed: Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 379895 files and directories currently installed.)
Preparing to replace libc-bin 2.13-38+deb7u1 (using .../libc-bin_2.15-0ubuntu10.5_amd64.deb) ...
Unpacking replacement libc-bin ...
dpkg: error processing /var/cache/apt/archives/libc-bin_2.15-0ubuntu10.5_amd64.deb (--unpack):
trying to overwrite '/usr/share/man/man1/getent.1.gz', which is also in package manpages 3.44-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db ...
Errors were encountered while processing:
/var/cache/apt/archives/libc-bin_2.15-0ubuntu10.5_amd64.deb
dpkg: dependency problems prevent configuration of libc6-dev:amd64:
libc6-dev:amd64 depends on libc6 (= 2.15-0ubuntu10.5); however:
Version of libc6:amd64 on system is 2.13-38+deb7u1.

dpkg: error processing libc6-dev:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc-dev-bin:
libc-dev-bin depends on libc6 (>> 2.15); however:
Version of libc6:amd64 on system is 2.13-38+deb7u1.

dpkg: error processing libc-dev-bin (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:

---

When trying to "sudo apt-get install -f" in terminal, I get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
accountsservice apg baobab caribou caribou-antler cheese-common
cups-pk-helper dnsmasq-base empathy-common fonts-cantarell gcalctool gdm3
gnome-backgrounds gnome-control-center-data gnome-dictionary
gnome-disk-utility gnome-font-viewer gnome-icon-theme-extras
gnome-online-accounts gnome-packagekit gnome-packagekit-data
gnome-screenshot gnome-system-log gstreamer0.10-nice gucharmap
libavahi-common-data:i386 libavahi-gobject0 libavahi-ui-gtk3-0
libcaribou-gtk-module libcaribou-gtk3-module libchamplain-0.12-0
libchamplain-gtk-0.12-0 libclutter-imcontext-0.1-0
libclutter-imcontext-0.1-bin libcluttergesture-0.0.2-0 libcryptsetup4
libgadu3 libgdict-1.0-6 libgdict-common libgdu-gtk0 libgeocode-glib0
libgnome-media-profiles-3.0-0 libgupnp-igd-1.0-4 libjim0debian2
libmeanwhile1 libmx-1.0-2 libmx-bin libmx-common libnice10 libnm-glib-vpn1
libnm-gtk-common libnm-gtk0 libpurple-bin librest-extras-0.7-0
libsocialweb-client2 libsocialweb-common libsocialweb-service libsocialweb0
libunique-3.0-0 libwine-gecko-1.4 libxcb-dri2-0-dev libxxf86vm-dev
libzephyr4 mesa-common-dev mobile-broadband-provider-info modemmanager
mousetweaks network-manager network-manager-gnome openjdk-7-jre-lib
pidgin-data polenum samba sound-theme-freedesktop tdb-tools telepathy-gabble
telepathy-logger telepathy-salut vino
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libc-bin libc6
Suggested packages:
glibc-doc
The following packages will be upgraded:
libc-bin libc6
2 upgraded, 0 newly installed, 0 to remove and 413 not upgraded.
2 not fully installed or removed.
Need to get 0 B/5,836 kB of archives.
After this operation, 1,100 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 379895 files and directories currently installed.)
Preparing to replace libc-bin 2.13-38+deb7u1 (using .../libc-bin_2.15-0ubuntu10.5_amd64.deb) ...
Unpacking replacement libc-bin ...
dpkg: error processing /var/cache/apt/archives/libc-bin_2.15-0ubuntu10.5_amd64.deb (--unpack):
trying to overwrite '/usr/share/man/man1/getent.1.gz', which is also in package manpages 3.44-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db ...
Errors were encountered while processing:
/var/cache/apt/archives/libc-bin_2.15-0ubuntu10.5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

---

My /etc/apt/sources.list looks like this, even if I'm running Kali Linux:

#############################################################
################### OFFICIAL UBUNTU REPOS ###################
#############################################################

###### Ubuntu Main Repos
deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb http://download.virtualbox.org/virtualbox/debian wheezy contrib

###### Ubuntu Update Repos
deb http://us.archive.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

###### Ubuntu Extras Repo
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

---

When doing a "sudo cat /etc/*-release", I get this:

PRETTY_NAME="Ubuntu 13.10"
NAME="Ubuntu"
ID=ubuntu
VERSION="13.10"
VERSION_ID="13.10"
ID_LIKE=debian
ANSI_COLOR="0;34"
HOME_URL="ttp://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

---

But "lsb_release -a" turns out like this:

No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux Kali Linux 1.0.7
Release: Kali Linux 1.0.7
Codename: n/a

---

I've done a lot of things wrong, I guess. Please help.
 
Old 06-18-2014, 05:36 AM   #2
//////
Member
 
Registered: Nov 2005
Location: Land of Linux :: Finland
Distribution: tri boot :: Fedora 22 && 23 && Rawhide == Testing Systemd
Posts: 222

Rep: Reputation: 50
mixing ubuntu sources with kali linux breaks the system. if i were u i would make a new install of kali and stick with kali sources.
 
Old 06-18-2014, 10:50 AM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Also, if you are new to Linux, Kali Linux is definitely a good choice, it is a special purpose distribution made by network and security experts for network and security experts.
You will be better off with starting with one of the mainstream desktop distributions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kali live usb install and boot problems with uefi Surgikill Linux - Laptop and Netbook 12 07-23-2014 01:53 PM
[SOLVED] Problems booting Kali in Vbox Mac-osx testera1 Linux - Newbie 2 10-16-2013 07:34 PM
kali linux iceman81 Linux - Newbie 3 09-03-2013 04:45 PM
Kali Linux in VirtualBox starcityque Linux - Newbie 3 04-19-2013 12:23 PM


All times are GMT -5. The time now is 08:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration