LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-05-2007, 11:05 AM   #1
Slasher66
LQ Newbie
 
Registered: Mar 2006
Posts: 11

Rep: Reputation: 0
problems going from 2.6.17.13 to 2.6.21.1


First I wonna say I'm new to linux
..... ohhh and sorry for my English
So I installed slackware 11 about a week ago and since the somehow I menaged to get things working(sound, nVidia driver, network). Then I decided to compile my own kernel(I installd slack with huge26). The compilation went well and it booted successfully, but without alsa and the network working.
- My network card uses dmfe tulip module wich was loaded when I checked lsmod but I don't even have ping to the router and dhcp does nothing.

- I used alsaconf and it detected intelAC97 and installed it successfully without errors but when I start X, there is no sound going out of my speakers

I'm pretty sure I've got the right modules loaded, can someone wiser then me tell me why things on 2.6.17 are working and on 2.6.20 not
 
Old 05-05-2007, 11:09 AM   #2
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 802

Rep: Reputation: 101Reputation: 101
.config

When you rebuild your own custom kernel, just use the config file from the huge26 kernel. It should be something like /boot/config-huge-2.6.18.8. Just load that up when you do make xconfig or whatever you use. It will automatically load all the config options of the huge26 that it can. Then when you start to feel more comfortable doing custom kernels, then you can leave out all the stuff you don't need or want. Also, with the new kernel, try running alsamixer. Then adjust all your levels and run alsactl store. Also, try running netconfig as root and see if that helps with your network problems.

Last edited by manwichmakesameal; 05-05-2007 at 11:12 AM.
 
Old 05-05-2007, 12:52 PM   #3
Slasher66
LQ Newbie
 
Registered: Mar 2006
Posts: 11

Original Poster
Rep: Reputation: 0
well I've tried netconfig on the newly compiled kernel with no success
 
Old 05-05-2007, 01:48 PM   #4
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 802

Rep: Reputation: 101Reputation: 101
lsmod

What is the output of lsmod?
 
Old 05-05-2007, 02:16 PM   #5
Slasher66
LQ Newbie
 
Registered: Mar 2006
Posts: 11

Original Poster
Rep: Reputation: 0
Thats the funny thing lsmod shows the dmfe module, I even tried to remove it and load it again but the result is the same. I am quite sure the right module is dmfe cous I had similar problem with 2.6.17 only then it was the wrong module loaded, I tried all tulip modules and it was dmfe that worked flawlessly
 
Old 05-05-2007, 02:33 PM   #6
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 802

Rep: Reputation: 101Reputation: 101
What is the output of /sbin/ifconfig?
 
Old 05-07-2007, 12:03 PM   #7
Slasher66
LQ Newbie
 
Registered: Mar 2006
Posts: 11

Original Poster
Rep: Reputation: 0
Well nothing, it shows eth0 only if i get it up manually- "ifconfig eth0 192.168.2.101 up" but there is no ping to the router
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 11 on a laptop (problems and problems and problems) kizersouzay Slackware 20 02-08-2007 11:52 AM
Marvell Yukon Network driver problems, Lilo Windows boot Problems mellowdog Slackware - Installation 7 01-25-2006 03:18 AM
cisco 350 wireless problems and suse x-server problems incognito9 Linux - Wireless Networking 5 10-14-2004 08:53 AM
Problems, problems, problems. Lets start with the soundcard Kre8ive Linux - Newbie 5 08-07-2003 02:20 AM
Problems, problems, problems. Lets start with the ES 1868 AudioDrive Kre8ive Linux - Newbie 1 08-06-2003 08:04 PM


All times are GMT -5. The time now is 12:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration