LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-20-2013, 06:52 AM   #1
AndyInMokum
Member
 
Registered: Jun 2013
Location: Amsterdam, The Netherlands
Distribution: Peppermint Six 32-bit & 64-bi
Posts: 53

Rep: Reputation: Disabled
Problems dual booting from a Laptop with an external hard drive


Good afternoon all.

Notebook: Fujitsu Amilo Li3710
Processor: Intel Celeron Dual-Core T1600 2.2GHz 4GB RAM
Graphics Adapter: Intel Graphics Media Accelerator (GMA) 4500MHD

External Hard drive: LaCie 200GB

OSs: Linux Mint Debian Edition on the Laptop
openSUSE 12.3 on the external 200GB LaCie




I've managed to get a working version of openSUSE 12.3 installed onto my LaCie external hard drive; very nice it is too. The Grub2 boot loader is installed to the MBR of the LaCie. My problem is probably trivial for you experts but it is a real headache for me . Firstly, when I boot up my Fujitsu Siemens laptop, I only intermittently arrive at the very pretty openSUSE boot screen. This contains my installations of openSUSE and Linux Mint Debian Edition and their respective safe modes etc - great. That is working perfectly, (when I get to the screen). If I boot up the laptop without the LaCie attached. I go straight to:


error: no such device, (a bunch of alpha numerics)

Entering rescue mode...

grub rescue>


Here I enter "ls" and hit enter and I get


(hd0) (hd0, msdos 6) (hd0, msdos 5) (hd0, msdos 4) (hd0, msdos 3)
(hd0, msdos 2) (hd0, msdos 1) (hd1) (hd1, msdos5) (hd1, msdos1)


I want to reset my Grub2 boot loader to load Mint independently of openSUSE's boot loader. When I installed Mint, the Grub boot loader was installed to the MBR of the laptop, as per norm. Now my knowledge fails me. What must I do to restore the boot loader? Am I going to be able to boot up both OSs normally? Is the solution going to be permanent or, will I have to go through the boot loader rescue process every time I boot up without the LaCie attached? Why is the connection to openSUSE's boot loader screen intermittent?

As Linux Mint Debian Edition is already bootable from openSUSE's boot loader screen. Would moving openSUSE's boot loader to the laptop resolve the issue? My reasoning being if, it is on the laptop, it will see the LaCie when it is attached and when it is not it will only see Mint. If this is correct, could you please advise on how to do this. Please be aware that I'm very much a newbie to Linux, so please could you keep any advice just one notch up from "idiot". Your help is very much appreciated.

Last edited by AndyInMokum; 06-20-2013 at 06:56 AM.
 
Old 06-20-2013, 08:14 AM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,187

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Quote:
If I boot up the laptop without the LaCie attached. I go straight to:
To clarify, you have Mint on the laptop internal drive and Opensuse on the external, is that correct? If so, the behavior you seem to be describing would be that you installed the Opensuse Grub to the mbr of the internal drive. If you have both Mint and Opensuse on the external and previously had the Mint bootloader in the mbr of the internal then you probably overwrote the Mint Grub with Opensuse Grub. If you want Mint to be the primary bootloader, you would boot Mint and install its Grub.

Not sure what you mean by 'intermittent' in this case?
Is your internal drive empty? You don't indicate there is anything on it? Why would you install the bootloader to the mbr of the internal drive as you said you did with Mint if you are not going to regularly have the external attached? Most of the Grub boot files are on the Linux partition, whether Mint or Opensuse Grub. If you have both Mint and Opensuse on the external then installing either bootloader to the mbr of that drive would resolve the problem. You would need to update-grub from Mint and install it to the mbr of that drive first.

I would suggest you go to the site below and read the instructions for the bootinfoscript, download and run it and post the output, a results.txt file here:

http://sourceforge.net/projects/bootinfoscript/
 
Old 06-20-2013, 09:10 AM   #3
AndyInMokum
Member
 
Registered: Jun 2013
Location: Amsterdam, The Netherlands
Distribution: Peppermint Six 32-bit & 64-bi
Posts: 53

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
To clarify, you have Mint on the laptop internal drive and Opensuse on the external, is that correct? If so, the behavior you seem to be describing would be that you installed the Opensuse Grub to the mbr of the internal drive. If you have both Mint and Opensuse on the external and previously had the Mint bootloader in the mbr of the internal then you probably overwrote the Mint Grub with Opensuse Grub. If you want Mint to be the primary bootloader, you would boot Mint and install its Grub.

Not sure what you mean by 'intermittent' in this case?
Is your internal drive empty? You don't indicate there is anything on it? Why would you install the bootloader to the mbr of the internal drive as you said you did with Mint if you are not going to regularly have the external attached? Most of the Grub boot files are on the Linux partition, whether Mint or Opensuse Grub. If you have both Mint and Opensuse on the external then installing either bootloader to the mbr of that drive would resolve the problem. You would need to update-grub from Mint and install it to the mbr of that drive first.

I would suggest you go to the site below and read the instructions for the bootinfoscript, download and run it and post the output, a results.txt file here:

http://sourceforge.net/projects/bootinfoscript/
Hi yancek and greetings from a very wet and thundery Amsterdam. Thank you for replying to me so promptly. To better explain my setup. I have Mint installed on my laptop's hard drive and it's Grub2 boot loader is installed to the MBR of the same hard drive. I have openSUSE installed on the USB external LaCie hard drive and it's Grub2 boot loader is installed to the MBR of the LaCie's hard drive also. If I boot up with the external hard drive attached, I arrive at openSUSE's boot loader screen, (most of the time, sometimes I get a blank screen with a cursor blinking in the top left hand corner). In this boot loader screen I can either boot into Mint or openSUSE with no issues, as I said, when I get to the boot screen. When I try to boot, (just Mint as openSUSE in on the external hard drive) without the external hard drive attached, I get a little welcome to Grub and then the error screen described in my original post. What I am trying to achieve is to be able to have the choice of booting into Mint or openSUSE when the external hard drive is attached and only boot into Mint when the hard drive is not attached. I hope that better explains the situation. Many thanks and I look forward to your reply.
 
Old 06-20-2013, 09:37 AM   #4
AndyInMokum
Member
 
Registered: Jun 2013
Location: Amsterdam, The Netherlands
Distribution: Peppermint Six 32-bit & 64-bi
Posts: 53

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by AndyInMokum View Post
Hi yancek and greetings from a very wet and thundery Amsterdam. Thank you for replying to me so promptly. To better explain my setup. I have Mint installed on my laptop's hard drive and it's Grub2 boot loader is installed to the MBR of the same hard drive. I have openSUSE installed on the USB external LaCie hard drive and it's Grub2 boot loader is installed to the MBR of the LaCie's hard drive also. If I boot up with the external hard drive attached, I arrive at openSUSE's boot loader screen, (most of the time, sometimes I get a blank screen with a cursor blinking in the top left hand corner). In this boot loader screen I can either boot into Mint or openSUSE with no issues, as I said, when I get to the boot screen. When I try to boot, (just Mint as openSUSE in on the external hard drive) without the external hard drive attached, I get a little welcome to Grub and then the error screen described in my original post. What I am trying to achieve is to be able to have the choice of booting into Mint or openSUSE when the external hard drive is attached and only boot into Mint when the hard drive is not attached. I hope that better explains the situation. Many thanks and I look forward to your reply.
I have downloaded the Boot info script and opened to tarball to a folder on my desktop. This what the terminal came back with:

andyinmokum@andy-debimint-li-3710 ~ $ sudo ~/Downloads/bootinfoscript
[sudo] password for andyinmokum:
sudo: /home/andyinmokum/Downloads/bootinfoscript: command not found
andyinmokum@andy-debimint-li-3710 ~ $

Sorry, its not very helpful.
 
Old 06-20-2013, 12:34 PM   #5
AndyInMokum
Member
 
Registered: Jun 2013
Location: Amsterdam, The Netherlands
Distribution: Peppermint Six 32-bit & 64-bi
Posts: 53

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by AndyInMokum View Post
I have downloaded the Boot info script and opened to tarball to a folder on my desktop. This what the terminal came back with:

andyinmokum@andy-debimint-li-3710 ~ $ sudo ~/Downloads/bootinfoscript
[sudo] password for andyinmokum:
sudo: /home/andyinmokum/Downloads/bootinfoscript: command not found
andyinmokum@andy-debimint-li-3710 ~ $

Sorry, its not very helpful.
Just out of curiosity, I ran the script while I was in openSUSE. This is what I got:

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

root's password:
sudo: /home/andyinmokum/Downloads/bootinfoscript: command not found
andyinmokum@linux-0w2p:~>

Again not very helpful.
 
Old 06-20-2013, 03:11 PM   #6
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,187

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
If you have Mint on the internal with its Grub bootloader in the mbr of the internal drive, you should see the Mint Grub screen on boot, that is if you have it set to first boot priority in the BIOS.

If you have Opensuse on the external and its Grub bootloader in the mbr of the external, you would need to select the external drive in the BIOS to boot Opensuse. You could run update-grub and have both Mint and Opensuse in the Mint Grub menu. Also, just booting with the external attached should not get you to the Opensuse boot menu unless you have it set to first boot priority in the BIOS.

What you describe in your last post would indicate to me that you have the Opensuse Grub in the mbr of the internal drive also and the error: no such device with the numbers is most likely that it is looking for the uuid of Opensuse which is not attached. This should be apparent from the bootinfoscript.

If you have the bootinfoscript tar.gz file on your Desktop, you should be able to right-click on its icon and select Extract or Extract here. You should then see a folder named bootinfoscript-061. You would then need to run it (its a bash script) by navigating to that directory:

cd /home/andy/bootinfoscript-061/

then: bash bootinfoscript.sh

Change the 'cd' command above to the appropriate location/user name.
 
Old 06-20-2013, 05:12 PM   #7
AndyInMokum
Member
 
Registered: Jun 2013
Location: Amsterdam, The Netherlands
Distribution: Peppermint Six 32-bit & 64-bi
Posts: 53

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
If you have Mint on the internal with its Grub bootloader in the mbr of the internal drive, you should see the Mint Grub screen on boot, that is if you have it set to first boot priority in the BIOS.

If you have Opensuse on the external and its Grub bootloader in the mbr of the external, you would need to select the external drive in the BIOS to boot Opensuse. You could run update-grub and have both Mint and Opensuse in the Mint Grub menu. Also, just booting with the external attached should not get you to the Opensuse boot menu unless you have it set to first boot priority in the BIOS.

What you describe in your last post would indicate to me that you have the Opensuse Grub in the mbr of the internal drive also and the error: no such device with the numbers is most likely that it is looking for the uuid of Opensuse which is not attached. This should be apparent from the bootinfoscript.

If you have the bootinfoscript tar.gz file on your Desktop, you should be able to right-click on its icon and select Extract or Extract here. You should then see a folder named bootinfoscript-061. You would then need to run it (its a bash script) by navigating to that directory:

cd /home/andy/bootinfoscript-061/

then: bash bootinfoscript.sh

Change the 'cd' command above to the appropriate location/user name.
Hi Yancek, Thanks for getting back to me. Everything that you have suggested here is in place right the way down to the boot order in the BIOS. I have to tell you that I gave up. I nuked the laptop's hard disk and did a reinstall. No problem as I'm a big believer in regular backups. Thanks anyway for the suggestions.
 
Old 06-20-2013, 05:57 PM   #8
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,187

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Glad you got it working anyway. I have to admit that, in my opinion, Opensuse has more possible options in bootloader installation than any other distro I have used. I always have problems trying to install the Opensuse bootloader to a partition rather than the mbr and I've installed 5-6 versions. Good luck with it.
 
Old 06-20-2013, 07:16 PM   #9
AndyInMokum
Member
 
Registered: Jun 2013
Location: Amsterdam, The Netherlands
Distribution: Peppermint Six 32-bit & 64-bi
Posts: 53

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
Glad you got it working anyway. I have to admit that, in my opinion, Opensuse has more possible options in bootloader installation than any other distro I have used. I always have problems trying to install the Opensuse bootloader to a partition rather than the mbr and I've installed 5-6 versions. Good luck with it.
I totally agree. I love using LMDE Cinnamon it is so simple to install and setup. Debian at its best. openSUSE is very pretty but it's a nightmare to configure. Have a great one and thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual booting with a laptop and external hard drive. AndyInMokum Linux - Newbie 17 06-16-2013 03:13 AM
Booting Linux on an external USB hard drive (not a memory stick, a hard drive) comcastuser Linux - Hardware 4 01-13-2010 06:59 PM
Booting from external hard drive Domy Linux - Newbie 5 10-05-2009 09:21 AM
External USB Hard Drive and re-booting coreychch Linux - Hardware 1 04-26-2009 04:36 AM
Clone a dual booting IDE hard drive to a SATA hard drive namida12 Linux - Distributions 1 07-14-2008 10:01 AM


All times are GMT -5. The time now is 11:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration