LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-28-2009, 09:18 AM   #1
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Rep: Reputation: 15
Problems connecting to internet


I have installed ubuntu 9.04 as a dual boot I believe (I have xp installed on one hardrive and ubuntu on another).

When booting in xp this computer connects to the internet via a wireless connection with my DSL-G604T wireless modem/router.

When booting in ubuntu I cannot seem to connect wirelessly.
My wireless connections shows up in wireless networks but I am not able to connect to the network and am unsure what settings to select.
I have tried various settings but can not seem to get a connection.

I then connected the pc to my wireless modem/router via ethernet cable and network manager suggests my wired connection 'auot eth0' is active however I am unable to load web pages in mozilla.

I have run update manager however and it was able to download updates but I had a problem when installing the updates.

I have tried to edit the connection also by making it a static connection but I still cant seem to get a connection although when I point the mouse over network manager it says 'auto eth0 is active'.

I have read and followed all the help instructions but I still cant get a connection.

The strange thing also is when I use Network Tools and run ping ubuntu.com (as explained in the help files to see if the connection is working) it says it was 100% successfull which suggests the connection is working.

Another starnge thing is that while trying different settings there has been at least one occassion where I was able to connect to webpages in mozilla but it only worked momentarilly then stopped. I'm not even sure what I had done to get this connection at that time. I was adjusting the Network Proxy settings from 'Direct to Internet" to 'Automatic' which may have had something to do with it but whatever it was it didn't work for long.

I have been trying to use ubuntu for a while now but this problem is doing my head in as I have reinstalled many times and tried to work this out myself but cant get anywhere and the frustrating thing is that I have at time been able to connect and know it must be something simple.

Can anyone please help as I am keen as to start using ubuntu?
 
Old 07-28-2009, 11:03 AM   #2
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
Hi,

I have recently installed Ubuntu 8.10 and its strange that network configuring is a bit difficult as compare to Fedora and CentOS in my experience.

I still don't know any file configuration method.. who don't you configure..

Click on network screen (Right Corner with date and volume control)
Point to VPN Connection and Click Configure VPN

once the dialogue box pops up

Click on Wireless tab.

Click on Add

Give a name to connection

And fillin the required info in fields.. and see if it works..


I know its not comprehensive

Cheers!!
 
Old 07-28-2009, 11:18 AM   #3
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Quote:
Click on network screen (Right Corner with date and volume control)
Point to VPN Connection and Click Configure VPN
Why VPN?

If you can ping ubuntu.com the connection works.
So seems to me there is a problem with the settings of the browser.
Try to use "no proxy" in the network settings.

For the wireless, try to install wicd

http://www.ubuntugeek.com/wicd-wired...or-ubuntu.html
 
Old 07-28-2009, 11:23 AM   #4
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
because I thought that was the easiest way to get to the wireless connection configuration tab in ubuntu.

Cheers!!
 
Old 07-28-2009, 12:35 PM   #5
geoffupton
LQ Newbie
 
Registered: Mar 2008
Location: Stafford UK
Distribution: debain lenny and debian etch (not on the same system!)
Posts: 13

Rep: Reputation: 0
Thumbs up

if you can't get the wireless card working you could try using ndiswrapper from sourceforge http://sourceforge.net/apps/mediawik...itle=Main_Page

All you need for it is some patients, windows (yuck!) drivers for the wireless card and the installation dvd! You just need to install some modules if you don't have em installed, oh and (of course!) full access to root user.

I've used it on Debian Etch and Debian Lenny and it works well on etch, lenny is being a pain with it, but it does work!

Using ndiswrapper will save your hair for a while!!

good luck, and follow the guide on the link and you should be up and running with wireless in no time!
 
Old 07-31-2009, 03:55 AM   #6
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks Repo, Ethernet connection now working but no wireless still

Thanks Repo - I managed to install wicd and now have a working ethernet connection and I'm replying to this post on my ubuntu machine - Yay.

Baig - I had already tried every possible setting in network manager but nothing would work, but thanks anyway.

Although I have a working ethernet connection I am still not able to connect wirelessly.

When ethernet cable is connected my wireless network shows up in wireless networks in wicd but after putting in my settings wicd attempts to connect but freezes or goes grey and wont connect.

If I reboot without the ethernet cable I cant get my or any wireless network to show up in wicd and if I try to refresh it freezes or goes grey.

Has anyone got any advice to help get my wireless working.

Geoffupton - I went to the ndiswrapper link you posted but that was way over my head, no idea where to start. I am totally new to ubuntu (but loving it so far (especially now i can use internet although with a long cable from room to room) and to be honest I dont even understand some of the terms you use - install some modules / full access to root user.

Thanks so much for your help so far and hoping someone can help me work out how to get wireless up and running.
 
Old 08-02-2009, 10:43 AM   #7
geoffupton
LQ Newbie
 
Registered: Mar 2008
Location: Stafford UK
Distribution: debain lenny and debian etch (not on the same system!)
Posts: 13

Rep: Reputation: 0
my apologies for being technical, but believe it or not its actually quite easy!! Ok, i admit it, im still basically a beginner and I only tried ndiswrapper about 2 months ago (well with serious intention of actually using it) and i scratched my head for a few hours and then just went for it! It was a bit annoying but you can do it! (HONEST!) just make sure you print the instruction pages, keep calm!

Btw, modules are like building blocks for linux, for example, you might have a module that turns on a light or makes a cup of coffee (ok, so they aren't linux examples!) but in a real linux example, you have a module that makes the computers fans work as needed, a module to make the ethernet work, a module to make the monitor work etc etc.

And, the "root" is like the administrator account in windows, basically its the most powerful account on the system and can make sensitive changes to the system. Basically, think of it like this, the root account is "god" and the users are us mere mortals... ok, bit over-the-top explanation but well if it helps you its done its job!
 
Old 08-25-2009, 06:11 AM   #8
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 15
Wireless Problems

I had a good working lan connection with ubuntu 9.04.

I installed wicd network manager but was still not able to get wireless working although my wireless network was showing up in wicd network manager.

geoffupton - I then tried to use ndiswrapper as suggested but could not make any real sense of what to to using the link you provided. I then did a google search 'how to use ndiswrapper ubuntu' and followed the instructions at
"https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper#Load the new driver module".

After following the configuration instructions below I immediatly lost my lan connection and wicd network manager will not open anymore.

3.1. Disable Free Drivers
Firstly, all releases since Ubuntu 6.06 have the open source bcm43xx driver, which was replaced in 8.04 by b43 and b43legacy, see WifiDocs/Driver/bcm43xx. If this driver doesn't work for you, then you should disable it, because it will conflict with ndiswrapper. To disable it, add blacklist bcm43xx lines for each driver to the modprobe blacklist.
echo -e "blacklist bcm43xx\nblacklist b43\nblacklist b43legacy\nblacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist

I continued on until instruction 3.6 'configuring wireless network settings' where I could not continue as I could not understand the instructions.

Now I have no internet connection and it appears no network manager.

Please help.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Connecting to Internet mattireland Slackware 16 03-27-2008 04:17 PM
Problems connecting to the internet Furlinastis Linux - Networking 24 10-14-2007 08:40 PM
problems connecting to the internet skylimit Linux - Networking 5 04-07-2007 06:58 AM
Connecting Problems to Internet FireInTheDark Linux - Networking 3 08-11-2004 10:39 PM
Problems after connecting to internet tuxedo-notebook Linux - Software 12 04-21-2004 11:59 PM


All times are GMT -5. The time now is 11:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration