LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-12-2004, 07:27 PM   #1
metal_monster
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Rep: Reputation: 0
problems booting it up.......


Alright

I have a pentium 4 2.4 ghz computer
with 512 mb ram
dvd drive/cdrw burner, and cd drive
and a ATI RADEO 9000 128 mb video card

now,
i have windows xp alright, and i installed a small 6 gb hd into my system, to just have linux on,
so i got the ide runnin to the linux, then to the windows hd
their both hooked up to power obviously,

and ok,
so unhooked the xp and hooked up the pre-linux drive, installed Red Hat 9, and installed EVERYTHING.....this may be where i screwed up, but not sure,
ok anyways,

i tried to boot up on the linux drive.....xp still not installed......and it says that xserver cannot start up because of something wrong with the display....then it says i can view the details to diagnose the problem.....then it asks if i want to start up the configuration for xserver or something and it just say........ok try starting it again when it is properly configured, then takes me to the root@localhost# prompt......

like what did i do wrong, i want to have the graphical interface,
also, how do i get to decide which drive to run off of when i start up?

i know the grub bootloader is suppposed to do that....but even with both hd's hooked up it just shows the redhat one.......

someone help me out please, thanks
 
Old 01-12-2004, 07:33 PM   #2
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Rep: Reputation: 15
ok....you probly need drivers....download them on another machine. It should have instructions to install them and how to configure x. Usually this involves booting into text mode. To do this press e when you get over your redhat 9 selection in grub. press e again over the line that has kernel and then alot of other crap. Press e again to edit this line. go to the end and put " 3"(notice the space). Then press enter to get out of edit mode. Press b and you will boot into text mode. Note that this is not permanent, so you have to do it every time you want to boot into text mode. You can also edit your bootloader configuration to have a Redhat 9 text mode option. Well get to that bridge when we cross it though .
I hope this helps and good luck!!!
Thad Blankenship
 
Old 01-12-2004, 07:36 PM   #3
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Rep: Reputation: 15
in order to get windows to show up try adding this to the end of /boot/grub/grub.conf :
title Windows 2000
rootnoverify (hd0,2)
chainloader +1

This is out of my grub.conf, but it should work for yours. The setting would have to be changed though. I think you would need to add this:

title Windows XP
rootnoverify (hd0,0)
chainloader +1
 
Old 01-12-2004, 07:40 PM   #4
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Rep: Reputation: 15
oops....i forgot about you being in text mode. You probably do not know how to use the vi text editor. Once you get into text mode, type "vi /boot/grub/grub.conf". Then press insert twice to go into replace mode. Next use the arrow keys to go to the end. Then type in what i told you to at the end of my last post. After you are done hit ESC. Then, when you are sure you want to save type ":wq". If you dont want to save but you want to exit, type ":q!". I hope you get this figured out.
 
Old 01-12-2004, 07:47 PM   #5
mike74
Member
 
Registered: Jan 2004
Location: Mtl, Canada
Distribution: Ubuntu 5.10
Posts: 39

Rep: Reputation: 15
hey!
I'm no pro, but I have a question:
Is the 6GB a slave or a master?
Did you hook up both or not?

Mike

Last edited by mike74; 01-12-2004 at 07:49 PM.
 
Old 01-12-2004, 07:52 PM   #6
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Rep: Reputation: 15
Im guessin its the slave....or at least it should be (if you installed grub to the MBR that is)
 
Old 01-12-2004, 10:35 PM   #7
metal_monster
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Original Poster
Rep: Reputation: 0
oh....well right now the 6gb one is set to master with a slave i think.....is that wrong?
and the xp drive is set to...not sure.....what should they be set to and how do you do it....moving that little plastic thing to the different positions?
 
Old 01-12-2004, 10:37 PM   #8
metal_monster
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Original Poster
Rep: Reputation: 0
oh and what version of xfree86 would i have.....how do i know, what it is....this to know what graphics driver
 
Old 01-13-2004, 12:41 AM   #9
pzatch
Member
 
Registered: Aug 2003
Location: Ohio
Posts: 173

Rep: Reputation: 30
Ok lets go from the standpoint of a duel boot system.
First hook the 6gig drive up as the slave to the master XP drive you have now. Make sure you have an XP boot floppy or disk.
Make sure all jumper pins on cdroms and harddrives are set correctly.
Make sure plug and play are turned off in the bios. Make sure you have all extra USB devices unplugged for now.( They tend to cause funky linux troubles on install)
Put the first linux disk in the cdrom and boot to it.
If you can't get the vidio set up correctly just use the VESA driver for now untill things can be fine tuned.
Go ahead and place the boot loader either on the MBR of the first hard drive or on a blank floppy if you can.
Post back with any trouble.

Oh go ahead and take the latest version of Xfree

Last edited by pzatch; 01-13-2004 at 12:43 AM.
 
Old 01-13-2004, 01:18 AM   #10
metal_monster
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Original Poster
Rep: Reputation: 0
um......i put in the first cd and then what..........how do i set my video from there......it takes me through normal setup....then asks if i want to do something with the boot loaders....nothing with the displays

oh ya


and in the bios......to boot from there is...........floppy, cddrive, and hdd......like only those 3......but i can change any of them to whatever i want.....currently....its set to boot to my windows, then if i switch to hdd1 i think....then it goes to the linux....thats how i've been switching between trying thigns out you guys say........do i maybe have to have both drives boot or something


please help me out, i am also not sure what i should set in the reconfiguring the current boot system

should i set it to be the dos one as default, or the linux one.........i tried setting it to the dos one...then saving to mbr....but it says that there are no packages to update on the drive, nothign has changed.....and thats yet after setting it to boot to the linux drive from the bios....should i maybe be doing this from the windows drive selected in the bios?

please help me out thanks
 
Old 01-13-2004, 01:39 AM   #11
pzatch
Member
 
Registered: Aug 2003
Location: Ohio
Posts: 173

Rep: Reputation: 30
Switching the boot order from one hard drive to the other for me at least causes more trouble than its worth.

Are the jumper pins on the back of the drives set one to master with slave and the other set to slave. (Primary+secondary and secondary.)

Make sure the pins are set correctly before doing anything else.

Boot to the cdrom and load the bott loader to either the MBR or a floppy.
 
Old 01-13-2004, 01:44 AM   #12
metal_monster
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Original Poster
Rep: Reputation: 0
ok.........what setting should it be set to in boss then to the xp or to the linux drive

and yes i set them up properly
 
Old 01-13-2004, 01:52 AM   #13
metal_monster
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Original Poster
Rep: Reputation: 0
well...i went to it....and what should i do....update the boot loader......or do it custom?

if custom....what settings do i use in order to show the grub display screen or some method of selecting which hd to boot up?
 
Old 01-13-2004, 02:00 AM   #14
pzatch
Member
 
Registered: Aug 2003
Location: Ohio
Posts: 173

Rep: Reputation: 30
Set the first hard drive in the bios as the one thats jumpered as master.
It doesn't have to be what you are booting to right now.

Try updating or reinstalling the boot loader.
 
Old 01-13-2004, 02:14 AM   #15
metal_monster
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Original Poster
Rep: Reputation: 0
if i upgrade.....and restart......it just takes me to windows

then if i try doing it customised.....making linux default, and making the drive order

xp
linux

and i try saving it to either the MPR or the first partition of other drive

and when i run either, it says something about kernel and packages
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting Problems kuba Linux - Newbie 10 08-16-2004 06:10 AM
OK, Booting problems rogan999 Linux - Newbie 1 01-10-2004 04:08 PM
problems booting up hobylinux Linux - Newbie 5 09-05-2003 12:17 PM
booting problems linux_guy2003 Linux - Newbie 1 06-21-2003 01:35 PM
Problems booting Daniel(0_0) Linux - Newbie 1 01-24-2002 11:14 PM


All times are GMT -5. The time now is 04:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration