LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-30-2006, 11:54 AM   #1
SibLiant
LQ Newbie
 
Registered: Dec 2006
Posts: 9

Rep: Reputation: 0
Problems adding write privileges to my External USB Drive


Hello all,

running Debian Etch; kernel 2.6

So I create /usb and set the permissions with chmod ugo=rwx.
I do a ls 僕 to verify that the permission are set and everything looks okay.
I mount the device on /usb using
$mount /dev/sdc1 /usb
Output from mount after it痴 mounted is as follows:
/dev/sdc1 on /usb type vfat (rw)
As soon as I mount the drive in the directory my permissions are stripped and set back to
drwxr-xr-x 19 root root 32768 1969-12-31 19:00 usb

Ultimately I知 trying to get access to the drive via win xp & samba
I can see the drive but I can稚 write to it. I知 assuming it痴 this permission problem.

Any ideas? Thanks in advance.
 
Old 12-30-2006, 12:23 PM   #2
raskin
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: approximately NixOS (http://nixos.org)
Posts: 1,900

Rep: Reputation: 68
Did you read 'man mount' about fmask and dmask?
 
Old 12-30-2006, 02:55 PM   #3
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959
The FAT file system does not support Linux permissions and ownership. They have to be simulated with mount options.

The basic option is 'umask=000', where the number is the inverse of the permissions you actually want (ex. if you want 644 permissions, use 'umask=133'). For finer control you can substitute dmask to set directory permissions, and fmask to set file permissions.

Two other useful options for fat mounting are 'uid=username' and 'gid=groupname' to set the owner and group the files belong to.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems adding write privileges to my External USB Drive SibLiant Linux - Newbie 1 01-03-2007 01:12 PM
Fedora Core 5 - unable to write to external USB drive charjoe Linux - Newbie 1 09-21-2006 09:29 PM
Unable to write to external USB drive m_lp_ql_m Linux - Newbie 2 08-29-2005 03:21 PM
External USB drive -- only WRITE as root 1kyle Linux - Hardware 0 08-03-2004 10:00 AM
Write to external USB hard drive Rob Roye Linux - Software 6 07-06-2004 04:15 PM


All times are GMT -5. The time now is 06:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration