LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-26-2010, 12:54 PM   #1
blainemiller
Member
 
Registered: Dec 2003
Posts: 78

Rep: Reputation: 1
Problem writing to nfs mounted mount point


I have two servers, 82 and 70.

My exports file on 82 reads

/ ...70(rw)

on 70 I have a mountpoint called mnt_for_82

I execute on 70

mount -t nfs -o rw ...82:/ mnt_for_82

I go to server 70 and indeed can read and travers the mounted subdirectories. However, I try to create a file or subdirectory under the mount point on 70 and I get a *Permission Denied* error.

I'm sure there is a simple explanation for this issue as well as a correct nomenclature for what I'm trying to do in nfs.

Your time and patience is greatly appreciated...

Thanks!

Blaine
 
Old 10-26-2010, 01:04 PM   #2
Omnicronos
Member
 
Registered: Oct 2010
Location: N. VA
Distribution: Redhat, CentOS, Solaris
Posts: 40

Rep: Reputation: 12
Do you have no_root_squash set in your export?

no_root_ squash = the remote root user will be treated as a root and will be able to change any file and directory.
 
Old 10-26-2010, 01:04 PM   #3
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
Try that set of options:

Code:
/ ...70(rw,no_root_squash,sync,no_subtree_check)
 
1 members found this post helpful.
Old 10-26-2010, 01:26 PM   #4
blainemiller
Member
 
Registered: Dec 2003
Posts: 78

Original Poster
Rep: Reputation: 1
This was it, w1k0 !!! Thanks!

Blaine
 
Old 10-26-2010, 02:03 PM   #5
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
You're welcome, Blaine!

Instead of mounting machines manually you'd put something like that in your fstab:

Code:
...82:/ mnt_for_82 nfs rw,suid,dev,exec,noauto,nouser,sync 0 0
In such case it'll be enough to use the command:

mount mnt_for_82

***

Mark the thread as SOLVED (use the link above your first post).

Last edited by w1k0; 10-26-2010 at 02:48 PM.
 
  


Reply

Tags
mount, nfs, permission denied


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS mount point problem dasuwal Linux - Software 4 06-04-2010 01:19 PM
NFS mount point problem dasuwal Linux - Server 3 04-01-2010 12:17 AM
Mount problem - device already mounted or mount point busy zahoo Linux - General 7 08-28-2009 06:02 PM
Mount Problem: evice already mounted or mount point busy paldebojyoti Linux - Distributions 5 08-27-2009 03:46 AM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration