LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-24-2009, 11:51 AM   #1
perky.nishi
Member
 
Registered: May 2008
Location: delhi, india
Distribution: fedora
Posts: 51

Rep: Reputation: 15
problem with yum update in fedora 9


Dear all,
I am using fedora 9 distribution and am new in linux.

From root I am running the command

$ yum -y update

It is showing the following


Loaded plugins: refresh-packagekit
livna | 2.4 kB 00:00
http://ftp.cc.uoc.gr/mirrors/rpmfusi...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
rpmfusion-nonfree-updates | 2.4 kB 00:00
rpmfusion-nonfree-updates/primary_db | 142 kB 00:01
fedora | 2.4 kB 00:00
rpmfusion-free-updates | 2.4 kB 00:00
rpmfusion-free-updates/primary_db | 420 kB 00:02
rpmfusion-free | 951 B 00:00
updates-newkey | 3.0 kB 00:00
updates-newkey/primary_db | 5.3 MB 05:16
updates-testing-newkey | 3.0 kB 00:00
updates-testing-newkey/primary_db | 300 kB 00:03
http://fedora.tu-chemnitz.de/pub/lin...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
rpmfusion-nonfree | 951 B 00:00
http://fedora.iitm.ac.in/updates/9/x...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
updates | 2.6 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package BackupPC.noarch 0:3.1.0-4.fc9 set to be updated
--> Processing Dependency: NetworkManager >= 1:0.7.0.99-1 for package: NetworkManager-openvpn
--> Processing Dependency: NetworkManager >= 1:0.7.0.99-1 for package: NetworkManager-vpnc
---> Package NetworkManager-glib.x86_64 1:0.7.1-1.fc9 set to be updated
---> Package NetworkManager-gnome.x86_64 1:0.7.1-1.fc9 set to be updated
---> Package akonadi.x86_64 0:1.1.2-1.fc9 set to be updated
---> Package bittorrent.noarch 0:4.4.0-12.fc9 set to be updated
---> Package cairomm.x86_64 0:1.6.4-1.fc9 set to be updated
---> Package cups.x86_64 1:1.3.10-5.fc9 set to be updated
--> Processing Dependency: poppler-utils for package: cups
---> Package cups-libs.x86_64 1:1.3.10-5.fc9 set to be updated
---> Package curl.x86_64 0:7.19.4-5.fc9 set to be updated
---> Package dblatex.noarch 0:0.2.10-2.fc9 set to be updated
---> Package devhelp.x86_64 0:0.19.1-12.fc9 set to be updated
---> Package device-mapper-multipath.x86_64 0:0.4.7-17.fc9 set to be updated
---> Package drupal.noarch 0:6.12-1.fc9 set to be updated
---> Package elfutils.x86_64 0:0.141-1.fc9 set to be updated
---> Package elfutils-libelf.x86_64 0:0.141-1.fc9 set to be updated
---> Package elfutils-libelf-devel.x86_64 0:0.141-1.fc9 set to be updated
---> Package elfutils-libs.x86_64 0:0.141-1.fc9 set to be updated
---> Package evolution-data-server.x86_64 0:2.22.3-4.fc9 set to be updated
---> Package evolution-data-server-devel.x86_64 0:2.22.3-4.fc9 set to be updated
---> Package evolution-data-server-doc.x86_64 0:2.22.3-4.fc9 set to be updated
---> Package fakeroot.x86_64 0:1.12.2-21.fc9 set to be updated
--> Processing Dependency: fakeroot-libs = 1.12.2-21.fc9 for package: fakeroot
---> Package firefox.x86_64 0:3.0.10-1.fc9 set to be updated
---> Package ghostscript.x86_64 0:8.63-3.fc9 set to be updated
---> Package giflib.x86_64 0:4.1.3-10.fc9 set to be updated
---> Package giflib-devel.x86_64 0:4.1.3-10.fc9 set to be updated
---> Package gnome-python2-extras.x86_64 0:2.19.1-27.fc9 set to be updated
---> Package gnome-python2-gtkhtml2.x86_64 0:2.19.1-27.fc9 set to be updated
---> Package gnome-python2-libegg.x86_64 0:2.19.1-27.fc9 set to be updated
---> Package gtk-vnc.x86_64 0:0.3.8-2.fc9 set to be updated
---> Package gtk-vnc-python.x86_64 0:0.3.8-2.fc9 set to be updated
---> Package ipsec-tools.x86_64 0:0.7.2-1.fc9 set to be updated
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-0.25.b09.fc9 set to be updated
---> Package java-1.6.0-openjdk-demo.x86_64 1:1.6.0.0-0.25.b09.fc9 set to be updated
---> Package java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-0.25.b09.fc9 set to be updated
---> Package java-1.6.0-openjdk-plugin.x86_64 1:1.6.0.0-0.25.b09.fc9 set to be updated
---> Package kdebase.x86_64 6:4.2.3-1.fc9 set to be updated
---> Package kdebase-libs.x86_64 6:4.2.3-1.fc9 set to be updated
---> Package kdebase-runtime.x86_64 0:4.2.3-2.fc9 set to be updated
---> Package kdebase-runtime-libs.x86_64 0:4.2.3-2.fc9 set to be updated
--> Processing Dependency: kdebase-kdm for package: fedorawaves-kdm-theme
---> Package kdebase-workspace.x86_64 0:4.2.3-4.fc9 set to be updated
---> Package kdebase-workspace-libs.x86_64 0:4.2.3-4.fc9 set to be updated
---> Package kdeedu.x86_64 0:4.2.3-1.fc9 set to be updated
---> Package kdeedu-kstars.x86_64 0:4.2.3-1.fc9 set to be updated
---> Package kdeedu-libs.x86_64 0:4.2.3-1.fc9 set to be updated
---> Package kdeedu-marble.x86_64 0:4.2.3-1.fc9 set to be updated
--> Processing Dependency: libgps.so.17()(64bit) for package: kdeedu-marble
---> Package kdeedu-math.x86_64 0:4.2.3-1.fc9 set to be updated
---> Package kdelibs.x86_64 6:4.2.3-3.fc9 set to be updated
---> Package kdelibs-common.x86_64 6:4.2.3-3.fc9 set to be updated
---> Package kdepimlibs.x86_64 0:4.2.3-1.fc9 set to be updated
---> Package kernel.x86_64 0:2.6.27.23-78.2.50.fc9 set to be installed
---> Package kernel-devel.x86_64 0:2.6.27.23-78.2.50.fc9 set to be installed
---> Package kernel-firmware.noarch 0:2.6.27.23-78.2.50.fc9 set to be updated
---> Package kernel-headers.x86_64 0:2.6.27.23-78.2.50.fc9 set to be updated
---> Package kpartx.x86_64 0:0.4.7-17.fc9 set to be updated
---> Package krb5-devel.x86_64 0:1.6.3-16.fc9 set to be updated
---> Package krb5-libs.x86_64 0:1.6.3-16.fc9 set to be updated
---> Package krb5-workstation.x86_64 0:1.6.3-16.fc9 set to be updated
---> Package ksysguardd.x86_64 0:4.2.3-4.fc9 set to be updated
---> Package lcms.x86_64 0:1.18-2.fc9 set to be updated
---> Package lcms-libs.x86_64 0:1.18-2.fc9 set to be updated
---> Package libcurl.x86_64 0:7.19.4-5.fc9 set to be updated
---> Package libcurl-devel.x86_64 0:7.19.4-5.fc9 set to be updated
---> Package libdvdcss.x86_64 0:1.2.10-1 set to be updated
---> Package libdvdcss-devel.x86_64 0:1.2.10-1 set to be updated
---> Package libmodplug.x86_64 1:0.8.7-1.fc9 set to be updated
---> Package libsmbclient.x86_64 0:3.2.11-0.29.fc9 set to be updated
---> Package libtalloc.x86_64 0:1.2.0-29.fc9 set to be updated
---> Package libtdb.x86_64 0:1.1.1-29.fc9 set to be updated
---> Package libvolume_id.x86_64 0:124-4.fc9 set to be updated
---> Package lighttpd.x86_64 0:1.4.22-2.fc9 set to be updated
---> Package lighttpd-fastcgi.x86_64 0:1.4.22-2.fc9 set to be updated
---> Package moin.noarch 0:1.6.4-1.fc9 set to be updated
---> Package netpbm.x86_64 0:10.35.61-1.fc9 set to be updated
---> Package netpbm-devel.x86_64 0:10.35.61-1.fc9 set to be updated
---> Package netpbm-progs.x86_64 0:10.35.61-1.fc9 set to be updated
---> Package nss.x86_64 0:3.12.2.0-3.fc9 set to be updated
---> Package nss-devel.x86_64 0:3.12.2.0-3.fc9 set to be updated
---> Package nss-tools.x86_64 0:3.12.2.0-3.fc9 set to be updated
---> Package nss_compat_ossl.x86_64 0:0.9.5-2.fc9 set to be updated
---> Package ntfs-3g.x86_64 2:2009.4.4-1.fc9 set to be updated
---> Package ntp.x86_64 0:4.2.4p7-1.fc9 set to be updated
---> Package ntp-perl.x86_64 0:4.2.4p7-1.fc9 set to be updated
---> Package ntpdate.x86_64 0:4.2.4p7-1.fc9 set to be updated
---> Package oxygen-icon-theme.noarch 0:4.2.2-1.fc9 set to be updated
---> Package pam.x86_64 0:1.0.4-4.fc9 set to be updated
---> Package pam-devel.x86_64 0:1.0.4-4.fc9 set to be updated
---> Package perl.x86_64 4:5.10.0-68.fc9 set to be updated
---> Package perl-Compress-Raw-Zlib.x86_64 0:2.008-68.fc9 set to be updated
---> Package perl-Compress-Zlib.x86_64 0:2.008-68.fc9 set to be updated
---> Package perl-ExtUtils-MakeMaker.x86_64 0:6.36-68.fc9 set to be updated
---> Package perl-ExtUtils-ParseXS.x86_64 1:2.18-68.fc9 set to be updated
---> Package perl-IO-Compress-Base.x86_64 0:2.008-68.fc9 set to be updated
---> Package perl-IO-Compress-Zlib.x86_64 0:2.008-68.fc9 set to be updated
---> Package perl-Module-Pluggable.x86_64 1:3.60-68.fc9 set to be updated
---> Package perl-Pod-Escapes.x86_64 1:1.04-68.fc9 set to be updated
---> Package perl-Pod-Simple.x86_64 1:3.07-68.fc9 set to be updated
---> Package perl-Test-Harness.x86_64 0:3.16-68.fc9 set to be updated
---> Package perl-Test-Simple.x86_64 0:0.86-68.fc9 set to be updated
---> Package perl-devel.x86_64 4:5.10.0-68.fc9 set to be updated
---> Package perl-libs.x86_64 4:5.10.0-68.fc9 set to be updated
---> Package perl-suidperl.x86_64 4:5.10.0-68.fc9 set to be updated
---> Package perl-version.x86_64 3:0.74-68.fc9 set to be updated
---> Package php.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-cli.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-common.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-gd.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-ldap.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-mbstring.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-mysql.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-odbc.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-pdo.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-pgsql.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package php-xml.x86_64 0:5.2.9-2.fc9 set to be updated
---> Package phpldapadmin.noarch 0:1.1.0.7-1.fc9 set to be updated
---> Package preupgrade.noarch 0:1.1.0-1.fc9 set to be updated
---> Package qt.x86_64 1:4.5.1-10.fc9 set to be updated
---> Package qt-mysql.x86_64 1:4.5.1-10.fc9 set to be updated
---> Package qt-x11.x86_64 1:4.5.1-10.fc9 set to be updated
---> Package samba.x86_64 0:3.2.11-0.29.fc9 set to be updated
---> Package samba-client.x86_64 0:3.2.11-0.29.fc9 set to be updated
---> Package samba-common.x86_64 0:3.2.11-0.29.fc9 set to be updated
---> Package samba-winbind.x86_64 0:3.2.11-0.29.fc9 set to be updated
---> Package selinux-policy.noarch 0:3.3.1-133.fc9 set to be updated
---> Package selinux-policy-devel.noarch 0:3.3.1-133.fc9 set to be updated
---> Package selinux-policy-targeted.noarch 0:3.3.1-133.fc9 set to be updated
---> Package sos.noarch 0:1.8-11.fc9 set to be updated
---> Package spawn-fcgi.x86_64 0:1.4.22-2.fc9 set to be updated
---> Package strigi-libs.x86_64 0:0.6.4-4.fc9 set to be updated
---> Package systemtap.x86_64 0:0.9.7-1.fc9 set to be updated
---> Package systemtap-runtime.x86_64 0:0.9.7-1.fc9 set to be updated
---> Package totem.x86_64 0:2.23.2-16.fc9 set to be updated
---> Package totem-gstreamer.x86_64 0:2.23.2-16.fc9 set to be updated
---> Package totem-mozplugin.x86_64 0:2.23.2-16.fc9 set to be updated
---> Package totem-nautilus.x86_64 0:2.23.2-16.fc9 set to be updated
---> Package totem-xine.x86_64 0:2.23.2-16.fc9 set to be updated
---> Package tzdata.noarch 0:2009e-3.fc9 set to be updated
---> Package tzdata-java.noarch 0:2009e-3.fc9 set to be updated
---> Package udev.x86_64 0:124-4.fc9 set to be updated
---> Package vlgothic-fonts.noarch 0:20090422-1.fc9 set to be updated
---> Package vlgothic-fonts-common.noarch 0:20090422-1.fc9 set to be updated
---> Package xine-lib.x86_64 0:1.1.16.3-2.fc9.1 set to be updated
---> Package xulrunner.x86_64 0:1.9.0.10-1.fc9 set to be updated
---> Package xulrunner-devel.x86_64 0:1.9.0.10-1.fc9 set to be updated
---> Package yelp.x86_64 0:2.22.1-12.fc9 set to be updated
--> Running transaction check
---> Package NetworkManager.x86_64 1:0.7.1-1.fc9 set to be updated
---> Package fakeroot-libs.x86_64 0:1.12.2-21.fc9 set to be updated
---> Package kdeedu-marble.x86_64 0:4.2.3-1.fc9 set to be updated
--> Processing Dependency: libgps.so.17()(64bit) for package: kdeedu-marble
---> Package kdm.x86_64 0:4.2.3-4.fc9 set to be updated
---> Package poppler-utils.x86_64 0:0.8.7-1.fc9 set to be updated
updates-newkey/filelists_db | 8.8 MB 08:46
updates-testing-newkey/filelists_db | 2.4 kB 00:00
http://mirror.yandex.ru/fedora/linux...ts.sqlite.bz2: [Errno -1] Metadata file does not match checksum
Trying other mirror.
updates-testing-newkey/filelists_db | 601 kB 00:00
livna/filelists_db | 1.3 kB 00:00
rpmfusion-free-updates/filelists_db | 404 kB 00:00
rpmfusion-nonfree-updates/filelists_db | 84 kB 00:00
--> Finished Dependency Resolution
kdeedu-marble-4.2.3-1.fc9.x86_64 from updates-newkey has depsolving problems
--> Missing Dependency: libgps.so.17()(64bit) is needed by package kdeedu-marble-4.2.3-1.fc9.x86_64 (updates-newkey)
--> Running transaction check
---> Package kdeedu-marble.x86_64 0:4.2.3-1.fc9 set to be updated
--> Processing Dependency: libgps.so.17()(64bit) for package: kdeedu-marble
---> Package kernel.x86_64 0:2.6.27.9-73.fc9 set to be erased
--> Finished Dependency Resolution
kdeedu-marble-4.2.3-1.fc9.x86_64 from updates-newkey has depsolving problems
--> Missing Dependency: libgps.so.17()(64bit) is needed by package kdeedu-marble-4.2.3-1.fc9.x86_64 (updates-newkey)
Error: Missing Dependency: libgps.so.17()(64bit) is needed by package kdeedu-marble-4.2.3-1.fc9.x86_64 (updates-newkey)


I don't know what to do. Please help....
 
Old 05-24-2009, 12:36 PM   #2
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
Try to run the following command:
Code:
rpm --rebuilddb
 
Old 05-24-2009, 03:39 PM   #3
moniker117
Member
 
Registered: May 2005
Location: Los Angeles, CA, USA
Distribution: Arch
Posts: 48

Rep: Reputation: 15
That's the error message you get when yum cannot find a required dependency in one of the configured repositories. The way I see it, there are multiple reasons for why this is happening:

1. From looking at your repository configuration, either the Fedora team or the RPMFusion team jumped ahead of the other and have released something that the other is not ready for. If this is the case, they'll fix it in a short amount of time. How long have you been having this problem for?

2. You have some junk in the cache that needs to be cleared. If you type "yum clean all" it will tell yum to clear everything in it's cache. Then you can try your update again.

3. I noticed from your yum output that you have the updates-testing repository enabled. It is possible that there is an update that is still in testing that your system is trying to install that might be trying to update something from the RPMFusion repository that is in their testing repository. The question would then become, why do you have the updates-testing enabled?
 
Old 05-24-2009, 03:49 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,986

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
having this
Code:
updates-testing-newkey | 3.0 kB 00:00
updates-testing-newkey/primary_db | 300 kB 00:03
turned on will do it every time

That repo is NOT to be on always . Only in case a "testing" rpm is the ONLY way to get something working .
TURN IT OFF .
 
Old 05-28-2009, 02:46 PM   #5
perky.nishi
Member
 
Registered: May 2008
Location: delhi, india
Distribution: fedora
Posts: 51

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by John VV View Post
having this
Code:
updates-testing-newkey | 3.0 kB 00:00
updates-testing-newkey/primary_db | 300 kB 00:03
turned on will do it every time

That repo is NOT to be on always . Only in case a "testing" rpm is the ONLY way to get something working .
TURN IT OFF .
how to turn it OFF? I don't know...a newbie....
 
Old 05-28-2009, 06:55 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,986

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
If you have "yunex" GUI installed then there are a set of check boxes for this , just uncheck it
if yumex is not installed then the other way ( what i use) is to edit the files in /etc/yum.repos.d ( use gedit as root )
Code:
su -
( your root password when asked )
gedit /etc/yum.repos.d/fedora-updates-testing-newkey.repo
and edit line 6 from this
" enabled=1 "
-- to this --
" enabled=0 "
 
Old 06-01-2009, 01:43 PM   #7
perky.nishi
Member
 
Registered: May 2008
Location: delhi, india
Distribution: fedora
Posts: 51

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by John VV View Post
If you have "yunex" GUI installed then there are a set of check boxes for this , just uncheck it
if yumex is not installed then the other way ( what i use) is to edit the files in /etc/yum.repos.d ( use gedit as root )
Code:
su -
( your root password when asked )
gedit /etc/yum.repos.d/fedora-updates-testing-newkey.repo
and edit line 6 from this
" enabled=1 "
-- to this --
" enabled=0 "
Its still not working....showing

Error: Missing Dependency: libgps.so.17()(64bit) is needed by package kdeedu-marble-4.2.3-1.fc9.x86_64 (updates-newkey)

Is it because I am using genome desktop and not kde?
 
Old 06-01-2009, 04:49 PM   #8
soleilarw
Member
 
Registered: Apr 2009
Posts: 107

Rep: Reputation: 19
Before running a yum upgrade sequence please make sure that you have upgraded ALL the release rpm files (like fedora-release-<version-num>.rpm) for the upcoming system. This will update all repository settings. Maybe you did already, but that's not clear from your posting.

Linux Archive

Last edited by soleilarw; 06-18-2009 at 05:18 AM.
 
Old 06-01-2009, 06:53 PM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,986

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
have you tried cleaning yum and rpm database ?
Code:
su -
( type in your root password when asked )
yum clean all
rpm --rebuilddb
yum update
it is also possible that you have some "testing" rpm's installed and that they have not been put into the reg. rpm downloads yet . if that is so then give it a week or two and the problem should fix it's self.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yum update problem in fedora 9 rathishtnair Linux - Desktop 1 03-10-2009 09:49 AM
problem with yum update in fedora core 6 me4linux Linux - Software 1 03-10-2007 03:38 PM
Problem using yum to update iptables and other software on Red Hat 7.3 (Fedora Lgcy) deeBs Fedora 2 08-25-2006 06:20 AM
yum update problem fedora core 4 wisdom Linux - Software 6 12-07-2005 05:39 PM
Fedora Yum update problem klnasveschuk Fedora 3 10-11-2005 07:26 AM


All times are GMT -5. The time now is 10:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration