LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem with Wine on FC5 not detecting CD drive (http://www.linuxquestions.org/questions/linux-newbie-8/problem-with-wine-on-fc5-not-detecting-cd-drive-443779/)

jjrbg 05-11-2006 09:41 AM

Problem with Wine on FC5 not detecting CD drive
 
I'm a newbie :confused: to Linux and I am having problems running DVD Shrink through Wine on FC5.

Every time I put in a disc it mounts ok in /media, but the name of the folder is the name of the CD/DVD not "cdrecorder". This means whenever I change disc, it changes name!

This is causing problems in Wine, as I can't add the drive in the Wine Configuration. It means adding the drive every time I put a different disc.

fstab contains no reference to media at all. I have tried adding:

/dev/hda /media/cdrecorder auto pamconsole,exec,noauto,managed,user 0 0

but no change. Apologies if this is a simple problem, but I have tried searching for a solution to no avail! :cry:

Any help gratefully received.

vegetassj2 05-11-2006 02:46 PM

Did you mount your cdrecorder drive first?:rolleyes:

if not try:

Code:

$ mount /media/cdrecorder
What do you mean by namechanging? is it:
'cdrecorder' changes to 'cd-rom' or what?

jjrbg 05-14-2006 06:40 AM

Got error msg:
mount: can't find /media/cdrecorder in /etc/fstab or /etc/mtab

By name changing, I mean when a cd/dvd is inserted - it mounts automatically in /media named whatever the label of the cd/dvd is. When no disc is in the drive, /media contains nothing.

I have no problems accessing the discs, but can't set drive location in Wine config.

GL1800 05-15-2006 10:16 AM

Here's a way that works to overcome that. Note that these are symbolic links. This goes in .wine/dosdevices. Here:
lrwxrwxrwx 1 ray ray 10 Apr 24 11:44 c: -> ../drive_c
lrwxrwxrwx 1 ray ray 10 Apr 24 11:44 d: -> /mnt/cdrom
lrwxrwxrwx 1 ray ray 8 Apr 24 11:44 d:: -> /dev/hdb
lrwxrwxrwx 1 ray ray 1 Apr 24 11:44 z: -> /
You will need to change these depending on your hardware setup. As you can see, my burner is on /dev/hdb, likely different for you, and I normally mount on /mnt/cdrom. Note the double colons for /dev/hdb.
After you make these links, if your CD is in /dev/hdb, that will appear as a choice in DVDShrink.

d_GeNeRiT 06-15-2006 09:37 AM

Quote:

Originally Posted by GL1800
Here's a way that works to overcome that. Note that these are symbolic links. This goes in .wine/dosdevices. Here:
lrwxrwxrwx 1 ray ray 10 Apr 24 11:44 c: -> ../drive_c
lrwxrwxrwx 1 ray ray 10 Apr 24 11:44 d: -> /mnt/cdrom
lrwxrwxrwx 1 ray ray 8 Apr 24 11:44 d:: -> /dev/hdb
lrwxrwxrwx 1 ray ray 1 Apr 24 11:44 z: -> /
You will need to change these depending on your hardware setup. As you can see, my burner is on /dev/hdb, likely different for you, and I normally mount on /mnt/cdrom. Note the double colons for /dev/hdb.
After you make these links, if your CD is in /dev/hdb, that will appear as a choice in DVDShrink.

GL1800,

THis works on FC 5? Please advise step by step what exactly to type at the terminal. I have never been able to get this to work on FC 5. THanks

GL1800 06-15-2006 09:50 AM

Yes, FC5. NOTE! I mount the dvd using mount /dev/hdb /mnt/cdrom.
You may have to adjust to suit your drive layout. The critical parts:
ln -s d: /mnt/cdrom
ln -s d:: /dev/hdb
The rest is unrelated to the issue.
After this is done dvdshrink will allow selection of your drive.

d_GeNeRiT 06-15-2006 11:04 AM

Quote:

Originally Posted by GL1800
Yes, FC5. NOTE! I mount the dvd using mount /dev/hdb /mnt/cdrom.
You may have to adjust to suit your drive layout. The critical parts:
ln -s d: /mnt/cdrom
ln -s d:: /dev/hdb
The rest is unrelated to the issue.
After this is done dvdshrink will allow selection of your drive.

THanks GL1800 for your fast reply,

I am very excited about this because my DVD-RW drive not appearing in DVDShrink is the ONLY OUTSTANDING issue I have with FC 5. My DVD-RW drive is device /dev/hdc I use DVDShrink with CrossOver Office 5.1 rather than wine. Will this procedure still work?

I followed this procedure before:

http://www.codeweavers.com/support/d...fig#DRIVECONFI

And it did not work. Is this similar to what you are suggesting?

d_GeNeRiT 06-16-2006 03:04 AM

Quote:

Originally Posted by GL1800
Yes, FC5. NOTE! I mount the dvd using mount /dev/hdb /mnt/cdrom.
You may have to adjust to suit your drive layout. The critical parts:
ln -s d: /mnt/cdrom
ln -s d:: /dev/hdb
The rest is unrelated to the issue.
After this is done dvdshrink will allow selection of your drive.

Thanks friend,

I am stuck on this step:

Code:

[alleycat@localhost ~]$ su
Password:
[root@localhost alleycat]# mount /dev/hdc /mnt/dvdrw
mount: you must specify the filesystem type
[root@localhost alleycat]#


thanquol 07-26-2006 02:43 PM

Quote:

Originally Posted by d_GeNeRiT
Thanks friend,

I am stuck on this step:

Code:

[alleycat@localhost ~]$ su
Password:
[root@localhost alleycat]# mount /dev/hdc /mnt/dvdrw
mount: you must specify the filesystem type
[root@localhost alleycat]#


If this is where you are stuck, then its simple:

the command mount works (simplified) like this:
mount -t "type of device" "device" "where to"

that means that you must:
a) have created the map: "/mnt/dvdrw" before you use the command else it will not be able to mount to that point
b) use the option "-t" with an option of what type it is... i.e.: "-t auto" to auto detect the device type.

like this for you:
(first check that the catalogue /mnt/dvdrw exist (else type: "mkdir /mnt/dvdrw"))
[root@localhost alleycat]# mount -t auto /dev/hdc /mnt/dvdrw

This is my edit:
-----------------
I just had to try out this...
This is what I did, and now it works the way that U want:
First I made the directories:
# mkdir /media/cdrecorder
# mkdir /media/cdrecorder1


Then I made a soft link for my first CDROM device:
# ln -s /dev/hdd /home/erik/.wine/dosdevices/d::
# ln -s /media/cdrecorder1 /home/erik/.wine/dosdevices/d:


then I made one for my second CDROM device (actually a DVD-RW):
# ln -s /dev/hdc /home/erik/.wine/dosdevices/e::
# ln -s /media/cdrecorder /home/erik/.wine/dosdevices/e:


I also made a smal adition in my fstab:
# vi /etc/fstab
and put in the following lines (last row):
/dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/hdd /media/cdrecorder1 auto pamconsole,exec,noauto,managed 0 0

(but I havent tried out the last thing this yet)
(I switched device letter a bit unlogically for you, but totaly logical for me... hdd is above hdc on my machine)


All times are GMT -5. The time now is 11:09 AM.