LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 06-24-2003, 10:52 AM   #1
j_l_ajaste
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Rep: Reputation: 0
Problem with USB floppy drive


Hello friends, a question from a total Linux novice.

I have just installed RH 8.0 (kernel version 2.4.18-14) in a dual boot setup with XP, using GRUB, on a Compaq Presario notebook. In order to proceed with the RH 8.0 install, I had to type "linux nofirewire noprobe nopcmcia" at the start of the installation, or else the installation would hang at (various) places. With "linux nofirewire noprobe nopcmcia," the installation proceeds seemingly smoothly.

Later, at the GRUB screen when I am logging on, I find that I also need to hit "a" and add the "nousb" kernel argument, or else the Linux boot will hang at "Initializing firewire controller (ohci1394)". With "nousb," I get "[OK]" at the "Initializing firewire controller (ohci1394)" line in the boot sequence, and proceed into RH without difficulty. However, of course my USB floppy drive is now unavailable! Does anyone know how I can at this point mount my USB floppy drive?? When I right-click on the RH screen and go to "disks," only the CDROM appears.

Any assistance anyone can give with this problem will be gratefully acknowledged.

Jared
 
Old 06-28-2003, 07:26 PM   #2
cropcircle
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Red Hat Linux 9, FreeBSD 4.8, Knoppix 3.2
Posts: 182

Rep: Reputation: 30
First, try getting Linux started as usual :

- Log in as root.
- Insert your USB floppy device.
- Type "dmesg".

(
at the bottom, do you see something like? :

Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: Model: Rev:
Type: Direct-Access ANSI SCSI revision: 02
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3
USB Mass Storage support registered.
)

If so, make a mountpoint where we try to mount the usb device, like this : "mkdir /mnt/usb".

Then do "cdrecord --scanbus" (USB access in Linux 2.4 goes currently with a SCSI emulation subsystem).

Finally, try to mount the USB device with : "mount -t auto /dev/sda1 /mnt/usb/"

If you're having troubles, check if the proper modules are loaded :

"lsmod |grep -i usb"

(Check for "usb-storage", if this one isn't loaded do "modprobe usb-storage").

Good luck.
 
Old 06-28-2003, 10:16 PM   #3
j_l_ajaste
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Thank you. I will try your recommendations and will post a reply.

Jared
 
Old 06-29-2003, 04:39 PM   #4
j_l_ajaste
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
cropcircle,

Upon typing "dmesg" I saw exactly the lines you wrote above. I then created the mount point using "mkdir," then did the "cdrecord --scanbus." When I used the mount command as you state above, I get a message saying that "/dev/sda1 is not a valid block device." I then did "lsmod |grep -i usb" and usb-storage came up ok. But I still get the "/dev/sda1 is not a valid block device" error.

thx/ Jared
 
Old 06-30-2003, 04:09 PM   #5
cropcircle
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Red Hat Linux 9, FreeBSD 4.8, Knoppix 3.2
Posts: 182

Rep: Reputation: 30
Can you post the output of the command "cdrecord --scanbus"?
 
Old 06-30-2003, 09:01 PM   #6
j_l_ajaste
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Cropcircle... through trial and error, using what you outlined above, I was able to mount the USB floppy drive by changing "sda1" to "sda." Not certain why that made a difference, but it did! I don't have the notebook here so unfortunately I can't post the output of "cdrecord --scanbus," but the output from that command did not look abnormal.

However, I notice that I still cannot mount (or unmount) the USB floppy via the GUI (i.e. by right clicking on the RH 8 Gnome desktop and going to "disk" ...only the CDROM appears on the menu.) Is it possible to modify RH 8 so that mounting and unmounting of the USB drive can be done this way? How do I get the drive to appear on that GUI menu every time I log on?

Thanks again for all your help.

Jared
 
Old 07-05-2003, 03:55 PM   #7
cropcircle
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Red Hat Linux 9, FreeBSD 4.8, Knoppix 3.2
Posts: 182

Rep: Reputation: 30
First, the bad news :

The fact that you cannot use the GUI Disks menu for this after plugging in a USB floppy, is because of this is a known bug in the current version of Gnome :

http://bugzilla.gnome.org/show_bug.cgi?id=104179

It will be probably fixed in the next version of Gnome.

And now the good news :

You can make mounting that drive a little easier by modifying the "/etc/fstab" file (you might want to backup this file, before you edit in it).

For example, for my USB memory stick, I've put in the following line at the end of the file :

/dev/sda1 /mnt/usb auto defaults 0 0

Now, if I want to mount my USB memory stick, I'll only have to do the command "mount /mnt/usb".
 
Old 07-05-2003, 06:01 PM   #8
j_l_ajaste
LQ Newbie
 
Registered: Jun 2003
Posts: 10

Original Poster
Rep: Reputation: 0
Interestingly enough, when I added:

"/dev/sda /mnt/usb auto noauto,owner,user 0 0 "

to fstab, the desks menu on the desktop showed "usb" as a mountable option! However, when I take "user" out of the line above, the menu item disappears.

Thanks again for your assistance.

Jared

Last edited by j_l_ajaste; 07-05-2003 at 06:07 PM.
 
Old 07-06-2003, 06:57 PM   #9
cropcircle
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Red Hat Linux 9, FreeBSD 4.8, Knoppix 3.2
Posts: 182

Rep: Reputation: 30
Glad to hear it worked out alright.

ps. The fact that in your case it needs the 'user' option has probably to do with rights. According to the manpage of fstab this option allows a non-root user to mount the device.
 
Old 07-10-2003, 01:38 PM   #10
aru_titi
LQ Newbie
 
Registered: Jun 2003
Location: Argentina - Bs. As.
Distribution: RH9
Posts: 14

Rep: Reputation: 0
Cropcircle solutios its right!!! I have purchased the StarMagic MP3 player that can storage 128Mb (usb connection) & i had no idea how to use with RH9, and this was the final solution.

ThX!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Floppy Drive -- need help KMcD Slackware 2 05-17-2005 06:26 AM
ZipSlack on USB drive--Need a USB-enabled floppy? Adrohak Linux - Hardware 0 11-15-2004 10:14 AM
USB Floppy Drive Craigwd Debian 1 06-20-2004 11:52 AM
USB Floppy Drive problem dave_starsky Linux - Hardware 1 03-14-2004 03:20 PM
usb floppy drive taizhu Linux - Hardware 16 11-02-2003 06:42 PM


All times are GMT -5. The time now is 01:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration