LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-05-2007, 03:52 PM   #1
alinextre
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Unhappy problem with the .php files on linux slackware 12


I have installed linux slackware 12.0 and i started the httpd , all is working well but when i upload a .php file to my http of the localhost it apears like a .txt file example: i uploaded a index.php but when i enterd in the internet explorer it looks like a txt file a index.txt . what should i do ? can u help me ?

Last edited by alinextre; 11-05-2007 at 03:54 PM.
 
Old 11-05-2007, 04:01 PM   #2
complich8
Member
 
Registered: Oct 2007
Distribution: rhel, fedora, gentoo, ubuntu, freebsd
Posts: 104

Rep: Reputation: 16
You need to add a handler for php (either using the php module or as a cgi).

See also: http://www.php.net/manual/en/install.unix.apache2.php for how to install php (including enabling module support at config-time on apache).
 
Old 11-06-2007, 01:36 PM   #3
llathrop
LQ Newbie
 
Registered: Mar 2004
Location: Modesto, CA
Distribution: slackware
Posts: 2

Rep: Reputation: 0
enable the php module

PHP is turned off by default in Slackware.

To turn on, see the end of the file /etc/httpd/httpd.conf, and uncomment the line concerning php
 
Old 07-09-2008, 03:10 AM   #4
cobain
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
i've just install slackware 12,
my apache is already run,
i can see the page "it works" in localhost,
n then i uncomment
Include /etc/httpd/mod_php.conf in /etc/httpd/httpd.conf
to enable php.
on /etc/httpd/php.ini i use
magic_quotes_gpc = On,
the problem is,
why my php did not show in my browser when i access page of php,
ex: localhost/xxx.php
the php page did not show,
but when i use console like this,
#php -r 'echo "Hello\n";'
the php was show,
why my php not show in my browser ???
i use konqueror and mozilla firefox for my browser.

please help me.....!!!!
 
  


Reply

Tags
slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP problem slackware 12 yonescu_marius Slackware 8 01-02-2009 11:11 PM
Problem with configuring php on Slackware 10.2 JockVSJock Slackware 38 11-11-2006 09:10 AM
.php files running on a linux webserver graziano1968 Linux - Networking 2 10-24-2006 12:54 AM
slackware-current apache/php problem hjles Slackware 3 03-10-2003 12:34 PM
Slackware PHP Problem djdrastic Linux - Newbie 0 02-21-2003 06:28 AM


All times are GMT -5. The time now is 07:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration