Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 08-23-2005, 11:26 PM   #1
LQ Newbie
Registered: Jul 2005
Posts: 5

Rep: Reputation: 0
Question problem with starting Samba service

System: Fedora core 4
Tried to start the Samba server serveral times (tried from GUI: server settings -> services, and checked smb, then clicked start, also tried from terminal by typing service smb start). Error message says: "smb failed. The error was: Starting SMB services: [FAILED]

Starting NMB services: " Status is: "smbd is stopped
nmbd (pid 2528) is running..." .

Everytime when system boots up, Samba service also failed to start.

uninstalled and reinstalled Samba server, the problem still exists.

Please help me, thanks in advance!
Old 08-24-2005, 12:21 AM   #2
Registered: Aug 2005
Distribution: Gentoo
Posts: 228

Rep: Reputation: 31
# /etc/init.d/samba

That do anything?
Old 08-24-2005, 05:14 PM   #3
LQ Newbie
Registered: Jul 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Originally posted by flower.Hercules
# /etc/init.d/samba

That do anything?
Thanks for help, I tried exactly what your said and got the following error:
Starting SMB services: /etc/init.d/functions: line 83: 23749 Aborted $nice $*
Starting NMB services:
Old 09-01-2005, 10:13 AM   #4
LQ Newbie
Registered: Jul 2005
Posts: 10

Rep: Reputation: 0
looks like this is a known bug with SE linux
Old 09-23-2005, 02:35 PM   #5
LQ Newbie
Registered: Jun 2004
Distribution: FC3/4, Debian, SuSE
Posts: 7

Rep: Reputation: 0
(disclaimer) Below is a shotgun approach. See later posts for better solutions.

From `man samba_selinux` :
"You can disable SELinux protection for the samba daemon by executing:"
              setsebool -P smbd_disable_trans 1
              service smb restart
The above worked for me on FC4 (2.6.12-1.1447), with selinux-policy-targeted-1.25.4-10.1

Last edited by schmee; 10-01-2005 at 07:06 PM.
Old 09-24-2005, 12:29 PM   #6
LQ Newbie
Registered: Mar 2004
Posts: 9

Rep: Reputation: 0
problem with starting Samba service

Check the context of secrets.tdb and smbpasswd they both need to be set to samba_secrets_t also check booleans.local file there should be a line that reads "samba_enable_home_dirs=1" without the quotes. This will allow SELinux to work proporly with Samba and visa-versa...

Last edited by James_Ecker; 09-24-2005 at 12:32 PM.
Old 01-04-2006, 12:20 AM   #7
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4
Posts: 46

Rep: Reputation: 15
disabling SE_Linux at FC 4

I got the same error. here is what I did

at Desktop->System_Setting->Security Level disbaled the SELinux. And restarted the smb - it is working for me now.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem starting Samba Service on Mandrake 9 Box StewieG Linux - Networking 3 05-15-2005 01:38 AM
Won't Boot - Starting Printer Service - Starting CUPS jeansond Linux - Newbie 0 10-11-2004 07:39 PM
Problem starting, needed service "Netmount" not started The_fuzzy_cow Linux - Hardware 1 07-26-2004 07:08 AM
Samba Starting problem pnh73 Linux - Networking 2 08-20-2003 01:06 PM
Problem starting java service during bootup TomCruise2002 Linux - Newbie 0 01-29-2003 10:44 PM

All times are GMT -5. The time now is 01:48 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration