LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-10-2004, 11:31 AM   #1
fac
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
Problem with screen blank and usb mouse


Hi

I have a problem with my laptop with fedora core 1 installed on it. I use external mouse, keyboard and monitor. Mouse and keyboard are connected with USB.

The problem is that after a certain amount of time my monitor goes blank - looks like power saving. Then I can turn it back on again my using the internal mouse. But I don't wanna do this all the time. So how do I turn this screen blank off?

I do not know if it has any influence on this, but my mouse driver is the APLS mousepad, not the external mouse. Because if I choose a external mouse driver it sometimes just won't work.

FAC
 
Old 08-10-2004, 11:52 AM   #2
Eagle_Seven
Member
 
Registered: Aug 2004
Distribution: Suse 9.1 Pro
Posts: 54

Rep: Reputation: 15
Double post. Oops. See below
 
Old 08-10-2004, 11:53 AM   #3
Eagle_Seven
Member
 
Registered: Aug 2004
Distribution: Suse 9.1 Pro
Posts: 54

Rep: Reputation: 15
It sounds like the computer is confused as to which mouse you are using. If there is a way, I suggest deactivating the inside mouse in the bios. If this is not possible, erase the mouse drivers, and make sure your usb is working.






PS. I am a noob, too. (3months)
 
Old 10-09-2004, 07:56 AM   #4
worldwiderob
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 22

Rep: Reputation: 15
I don't think it has anything to do with your chosen mouse driver. I have exactly the same problem except my mouse driver is just the standard IMPS/2 (which is absolutely correct for my mouse).
 
Old 10-10-2004, 01:27 AM   #5
fac
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Original Poster
Rep: Reputation: 0
No, I don't think it is the mouse driver either. I have later talked with some sort of linux expert, and he told me that it would be smart to update my distrubution. So I would use kernel 2.6.
I have plans to do that but I have just got FC1 to run almost perfect, and I don't wan't to update to an old most outdated FC2 so when FC3 is realesed I'll update.
And then everything will be fine I hope, or else I must realize that he wasn't much of an linux expert after all
 
Old 10-10-2004, 01:25 PM   #6
worldwiderob
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware
Posts: 22

Rep: Reputation: 15
I don't believe this issue has anything to do with Linux at all. Do you dual boot with Windows? I don't so I can't test whether the problem exists under Windows too. But what I discovered is that Linux' power management acknowledges USB. When I use perhaps:

xset dpms 0 0 10
or
setterm -blank 1

the system stays active beyond 10 seconds and 1 minute respectively if I am using my USB mouse/keyboard. Additionally, they resume using USB mouse/keyboard. More evidence that it isn't Linux: with these power management features disabled, and apm=off as a kernel option, my screen will still blank in that most frustrating way.

The answer is that the BIOS in my laptop is stupid and turns of my LCD after a period of activity that my system decides internally.

I was able to switch off the LCD blanking using the configuration utility particular to my laptop. The way the configuration utility describes the LCD blanking "feature", it is quite clear that this function only recognises the internal keyboard, PS/2 mice and keyboards attached through a special adapter. This is IBM's configuration utility; its clearly a hardware thing and mpt anything to do with Linux.

Maybe you can disable the screen blanking in the BIOS or with some software disk that came with your system? Then just use the nice Linux power saving stuff for the display. The rest of the power management can be left as it is. There maybe be slightly less power saved with "xset dpms..." and "setterm -blank..." than with the BIOS display off, because they apparently don't switch off the LCD. So one alternative might be to disable your APM BIOS stuff and just use ACPI. ACPI is handled by the operating system, and might give better results.

Hope that helps
rob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Blank Screen Problem with X server in Fedora Core 1 is driving me crazy!!! koodoo Linux - Newbie 2 03-17-2005 03:35 PM
Blank screen and KB/Mouse freeze when booting to kernel. testeng Linux - Newbie 1 03-05-2005 11:56 PM
rdesktop: blank login screen problem hctif Linux - Software 0 11-26-2004 07:07 AM
Fedora install problem - blank screen The Oate Fedora - Installation 12 08-21-2004 09:07 PM
nvidia driver problem with X - blank screen hollywoodb Linux - Hardware 12 09-03-2003 12:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration