LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-16-2004, 04:29 AM   #1
op_stager
LQ Newbie
 
Registered: Aug 2004
Location: Toronto
Distribution: SuSe
Posts: 20

Rep: Reputation: 0
Question PROBLEM WITH RUNNING GAMES : SUSE 9.1 : ATI driver


Hi all I am new to LinuxQuestions.org my name is Ryan , i am having a problem with running games.

I get this error when running as regular user:

================================================
Code:
ryan1@ryan:/usr/local/games/armyops> ./armyops 
Couldn't set video mode: Couldn't find matching GLX visual


History: 

Exiting due to error
ryan1@ryan:/usr/local/games/armyops>
================================================

Running as root i get this error:

================================================
Code:
ryan:/usr/local/games/armyops # ./armyops 
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

No dynamic GL support in video driver

History: 

Exiting due to error
ryan:/usr/local/games/armyops #
========================================

also when i run fglrx it says im still using mesa drivers

Code:
ryan1@ryan:/usr/local/games/armyops> fglrxinfo 
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: w w w . mesa3d . o r g
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.4 Mesa 5.0.2)

ryan1@ryan:/usr/local/games/armyops>
my educated guess is that fglrx driver is not being loaded also glx is loaded in my XF86config. I am using SUSE 9.1 with Nforce2 chipset. A7N8X-E mobo. All I want to do is get ati drivers working so i can get rid of windows from my hardrive thank you for your time sinceryl Ryan Currah.

Last edited by op_stager; 08-16-2004 at 04:30 AM.
 
Old 08-16-2004, 05:00 AM   #2
trickle
Member
 
Registered: Aug 2004
Location: South Africa
Distribution: Mandrake 9.1, 10; Red Hat 9.0, winxp and Suse 9.1 Pro, Fedora Core 3
Posts: 52

Rep: Reputation: 15
Hey There,

What I did on Mandrake 10 was the following:

I downloaded the newest drivers from the ATI site, then went into a terminal without x being started. I logged in as root and forced the rpm to be installed with the following command:

rpm -i --force rpmname.rpm

after that, you have to go to a certain location, I think its:

/lib/modules/fglrx or sumthing like that then just look for the following files, you can also use locate to find it:
make.sh
install.sh - this one is in a directory one folder before the one you find make.sh in

after doing that, just run fglrxconfig and finetune the settings for the card, that should do the trick, if you struggle, just read the help file that is extracted after the installation is completed, should also indicate to you what to do while installing the drivers, so just check for the part at the beginning where they indicate to lok for those two files I mentioned.

Hope it helps.

Regards,
Trickle
 
Old 08-16-2004, 05:10 AM   #3
op_stager
LQ Newbie
 
Registered: Aug 2004
Location: Toronto
Distribution: SuSe
Posts: 20

Original Poster
Rep: Reputation: 0
thanks for the reply, i think it is different in SUSE, cause they released there own set of Moddified drivers and intructions i followed those i would post the link but i have to make 5 new threads in order to be able to post a url.
 
Old 08-16-2004, 06:08 AM   #4
trickle
Member
 
Registered: Aug 2004
Location: South Africa
Distribution: Mandrake 9.1, 10; Red Hat 9.0, winxp and Suse 9.1 Pro, Fedora Core 3
Posts: 52

Rep: Reputation: 15
Just a pleasure. Don't know Suse, never used it, but have you at least tried looking for those to sh files? I also had a problem with my system and my drivers, couldn't even run Tux Racer, it would just give a blank screen. Only started working when I installed those to packages by typing:

sh make.sh
then
sh install.sh

So you are welcome to try it, I have no idea if it will work, but it's at least worth a try. Good luck with it though.
 
Old 08-16-2004, 06:19 AM   #5
op_stager
LQ Newbie
 
Registered: Aug 2004
Location: Toronto
Distribution: SuSe
Posts: 20

Original Poster
Rep: Reputation: 0
rem

Last edited by op_stager; 08-16-2004 at 06:20 AM.
 
Old 08-16-2004, 06:19 AM   #6
op_stager
LQ Newbie
 
Registered: Aug 2004
Location: Toronto
Distribution: SuSe
Posts: 20

Original Poster
Rep: Reputation: 0
I tried it all i get is

Code:
ryan:/usr/src/kernel-modules/fglrx # sh make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.5-7.104-default/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.
ryan:/usr/src/kernel-modules/fglrx # make install.sh
make: *** No rule to make target `install.sh'.  Stop.
ryan:/usr/src/kernel-modules/fglrx # sh install.sh
install.sh: install.sh: No such file or directory
ryan:/usr/src/kernel-modules/fglrx #
thanks for the help but i dont think it is going to work
 
Old 08-16-2004, 07:04 AM   #7
trickle
Member
 
Registered: Aug 2004
Location: South Africa
Distribution: Mandrake 9.1, 10; Red Hat 9.0, winxp and Suse 9.1 Pro, Fedora Core 3
Posts: 52

Rep: Reputation: 15
Not a problem, sorry it didn't work tho.

I'll try and send you the correct location tomorrow of where Mandrake stores the files, hope it helps then. Did you actually try to install the drivers from the ATI site? I installed RH9 at some stage and I also had to install those drivers before my card, ATI Radeon 9200 SE, actually worked properly.

Good Luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.1, Kernel 2.6.5-1.104, ati driver 3.11.1 problem eiffel Linux - Hardware 3 08-26-2004 08:08 AM
PROBLEM WITH RUNNING GAMES : SUSE 9.1 : ATI driver op_stager Linux - Software 0 08-16-2004 04:32 AM
ATI Driver problem on SuSE 9 TheOtaku Linux - Software 3 04-22-2004 05:42 PM
Windows 3d games not running @ ATI R9200 leadazide Linux - Games 1 04-10-2004 01:51 PM
Problem running ATI driver test script chrisjbzero Linux - Newbie 1 03-28-2004 04:23 PM


All times are GMT -5. The time now is 06:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration