LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-04-2007, 06:02 AM   #1
vladakg85
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Rep: Reputation: 15
problem with resolution


ok Slackware 11 kernel 2.6.19.2 newest nvidia driver, geforce 7300gt, monitor tft wide
I installed this driver but here is the problem:
I go to nvidia-settings to setup resolution 1440x900 60hz and thats OK, but when I go to kde configure monitor there is 1440x900 80hz. Thats imposible! How to be sure everything is OK? And if I want to edit xorg.conf what steps should I take for securing myself?
Please help me I don't want to kill my monitor!
 
Old 02-04-2007, 06:31 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Make sure your display can handle 80hz refresh rate. That seams a bit high for an LCD monitor, but maybe that is a difference between active and passive displays.

For LCD monitors I would recommend keeping it normally at the native resolution. Assuming that is 1440x900, you could generate your own Modeline using the gtf program.

Code:
> gtf 1440 900 60 -x

  # 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
  Modeline "1440x900_60.00"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
I would recommend dropping the ".00" in the label:
Code:
  # 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
  Modeline "1440x900_60"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
If your /etc/X11/xorg.conf file has a Modelines section, then insert it there. If not, insert it in the "Monitor" section. In the latter, the "Monitor" section will have a statement like: "UseModes Modelines[0]" to include the modelines.

These values are just an example. Run "gtf" on your own system. Best results might be obtained if the system isn't loaded down when you run it.

To safely change the xorg.conf file, back the old one first. For example "mv xorg.conf xorg.conf.bu"

You can edit it from the console using "sudo vim /etc/X11/xorg.conf" or use any editor. You can use "kdesu kate /etc/X11/xorg.conf" if you aren't familiar with vim and are in KDE.

Last edited by jschiwal; 02-04-2007 at 06:33 AM.
 
Old 02-04-2007, 06:32 AM   #3
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
The minute you make changes to your xorg.conf file, a new file should show up in /etc/X11 called "xorg.conf.backup.nvidia. That file is your safety.
 
Old 02-04-2007, 06:37 AM   #4
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Sorry jschiwal

We posted at the same time, I agree, the refresh rate seems a little high, it should be around 60hz. As I mentioned above, if you want to go back to original xorg.conf, just re-name the xorg.conf.backup.nvidia to xorg.conf after deleting the modified xorg.cong file, and log out and log back in.
 
Old 02-04-2007, 07:32 AM   #5
vladakg85
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Original Poster
Rep: Reputation: 15
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Fri Dec 15 10:13:06 PST 2006

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/misc/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Maxdata (RogenTech) B1925S1W"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7300 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "1440x900_60 +0+0; 800x600 +0+0; 640x480 +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
=========================
this is mine xorg.conf, and monitor
http://www.belinea.com/Products/TFT_...8&artnr=111932
jschiwal
I ussualy don't like to somebody do job for me but I am scared and not shure about this so can you edit my xorg.conf please.
 
Old 02-04-2007, 01:30 PM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
From your monitor's spec sheet:
Code:
Max. image refresh rates in Hz
for resolution analogue / digital
640 x 480 75 / –
800 x 600 75 / –
1024 x 768 75 / –
1152 x 864 75 / –
1280 x 1024 75 / –
1400 x 900 60 / –
So for 1400 x 900, use "gtf 1400 900 60 -x" to generate a modeline.
 
Old 02-04-2007, 01:50 PM   #7
vladakg85
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Original Poster
Rep: Reputation: 15
root@vlada:/home/zajcev/zajcev/kde# gtf 1400 900 60 -x
bash: gtf: command not found
root@vlada:/home/zajcev/zajcev/kde# which gtf
which: no gtf in (/usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin)
root@vlada:/home/zajcev/zajcev/kde#
 
Old 02-06-2007, 08:22 AM   #8
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
For SuSE, the gtf program is installed along with the Xorg server package.

On my system:
which gtf
/usr/bin/gtf
jschiwal@hpmedia:~> rpm -qf /usr/bin/gtf
xorg-x11-server-7.2-30

However, for you it might by under /usr/lib/X11/bin/ or /usr/X11R6/bin/ or something similar, so you might have it but it isn't in your path.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another Resolution Problem EclipseAgent SUSE / openSUSE 1 06-22-2006 08:57 PM
Resolution Problem umphreak Mandriva 3 06-13-2006 04:22 AM
X Resolution problem henkelarsson12 *BSD 3 06-11-2006 09:41 AM
yet another resolution problem pafrica Linux - Hardware 2 02-14-2006 05:11 AM
Resolution problem mmunro Mandriva 2 02-21-2004 06:39 PM


All times are GMT -5. The time now is 01:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration