LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-12-2011, 03:52 PM   #1
adraganov
LQ Newbie
 
Registered: Apr 2011
Location: Edinburgh
Distribution: SL
Posts: 5

Rep: Reputation: 0
Problem with passwordless SSH to the same host


Hi guys,

I am trying to run OpenNebula on a set of 2 machines. One of the machines(called host1) must be able to access the others(including itself) with passwordless ssh.
Both machines have the same user and use mounted folder from host1 for home directory(exported with NFS). So single key generation should be enough for this configuration - all the machines have access to the same .ssh folder.
What I am getting at the end is passwordless ssh from host1 to host2 which is great, but no success from host1 to host1. Host2 to host2 is also OK, host2 to host1 wants password like host1 to host1.

Both machines have the same sshd_config and ssh_config files.
File permissions required by ssh should be correct since it works for host1 to host2.
The only difference(I see) between the machines is that host1 runs nfs service, so host2 has access to the exported folders.
The ssh-keygen is executed on host1

authorized_keys has the same public key two times(to authorize access for host1 on host1 and host2).

The distro is Scientific Linux 6.0 aand I also use rsa.
Something else - no pass ssh with another user from host1 to host1 works, so I suppose the problem comes from this mounted folder.
There is something I am missing, so any help will be highly appreciated!
 
Old 06-12-2011, 05:39 PM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
Apart from anything else, accessing your private key over a network basically destroys the security of ssh. You should also only need 1 copy of the public key in authorized_keys.
 
Old 06-13-2011, 10:34 AM   #3
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Debian, OS X
Posts: 1,298

Rep: Reputation: 102Reputation: 102
Try steps given here
 
Old 06-14-2011, 02:04 PM   #4
adraganov
LQ Newbie
 
Registered: Apr 2011
Location: Edinburgh
Distribution: SL
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for your responses!
Quote:
Originally Posted by smoker View Post
Apart from anything else, accessing your private key over a network basically destroys the security of ssh. You should also only need 1 copy of the public key in authorized_keys.
Ok, I moved the key pair to a folder that is not exported(outside of the home directory for my user) and changed IdentityFile property in the .ssh/config file to the needed location(call it someOtherLocation/id_rsa.pub). So now I have a pair of keys(id_rsa & id_rsa.pub) in someOtherLocation on host1 and ~/.ssh/authorized_keys file that holds the public key and it is shared between the hosts. And the result is the same - password-less host1 to host2 and password prompt for host1 to host1.
Everything I do is:
ssh-keygen -q -f /someOtherLocation/id_rsa
ssh-copy-id -i /someOtherLocation/id_rsa.pub host1
So for host1 to host1 I expect this to work, but it does not. It works for host1 to host2, since they have authorized_keys file shared in the exported directory.
thats the debug output for ssh on host1
Code:
-bash-4.1$ ssh -v host1
OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
debug1: Reading configuration data ~/.ssh/config
debug1: Applying options for *
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to host1 [::1] port 22.
debug1: Connection established.
debug1: identity file /someOtherLocation/.ssh/id_rsa type 1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
debug1: match: OpenSSH_5.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'host1' is known and matches the RSA host key.
debug1: Found key in ~/.ssh/known_hosts:2
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_503' not found

debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_503' not found

debug1: Unspecified GSS failure.  Minor code may provide more information


debug1: Next authentication method: publickey
debug1: Offering public key: /someOtherLocation/.ssh/id_rsa
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: password
This scenario works for other user that does not use mounted directory as a home folder, but I need it in this way.
 
Old 06-20-2011, 12:45 PM   #5
adraganov
LQ Newbie
 
Registered: Apr 2011
Location: Edinburgh
Distribution: SL
Posts: 5

Original Poster
Rep: Reputation: 0
selinux

My problem was with selinux. I didn't look for what was exactly different between these two hosts in the configuration files and I just disabled it. That's a test environment anyway.
Actually there was a pretty nice message in /var/log/messages about the problem. So everything is fine now!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
passwordless ssh from one host to another host mahmoodn Linux - Networking 74 08-08-2011 01:47 PM
problem with passwordless ssh mahmoodn Ubuntu 2 01-08-2011 02:27 PM
passwordless ssh problem blckspder Linux - Server 6 03-05-2009 10:29 AM
Passwordless SSH with SSH commercial server and open ssh cereal83 Linux - General 7 04-18-2006 01:34 PM
Passwordless SSH problem? LQYY Linux - Software 5 06-09-2005 10:56 PM


All times are GMT -5. The time now is 08:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration