LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2005, 12:32 AM   #1
hari78
Member
 
Registered: Dec 2004
Distribution: FC3, RH enterprise 3
Posts: 46

Rep: Reputation: 15
problem with mounting


i am unable to mount one partition. i am using knoppix.. ithe fstab file is paster below.when i try to mouint all of them, the following error message comes:mount: fs type errors=remount-rw not supported by kernel
.. It is /dev/hda2/ that does not get mounted. any body plz tell what changes to be made in fstab.thanks in advance

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
proc /proc proc defaults 0 0
/dev/hda2 /home/hari/academic defaults,errors=remount-rw 0 1


/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
/dev/hda1 none swap defaults 0 0
# Added by KNOPPIX
 
Old 08-04-2005, 12:55 AM   #2
volvogga
Member
 
Registered: Aug 2004
Location: MI, USA
Distribution: Fedora Core 3
Posts: 137

Rep: Reputation: 15
It looks like your fstab doesn't identify the file system of this partition.

Put in the filesystem (ext3, vfat, or other) and I bet it will work.
 
Old 08-04-2005, 01:30 AM   #3
hari78
Member
 
Registered: Dec 2004
Distribution: FC3, RH enterprise 3
Posts: 46

Original Poster
Rep: Reputation: 15
when the file system is given the follwing message comes:


wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
 
Old 08-04-2005, 01:59 AM   #4
volvogga
Member
 
Registered: Aug 2004
Location: MI, USA
Distribution: Fedora Core 3
Posts: 137

Rep: Reputation: 15
Hrmm. Thats not good. What is the file system that you formated it as?

Also, have you tried to get it working with just the mount command?
 
Old 08-04-2005, 02:08 AM   #5
hari78
Member
 
Registered: Dec 2004
Distribution: FC3, RH enterprise 3
Posts: 46

Original Poster
Rep: Reputation: 15
i formatted it as ext3. i tried the mount command as well./
 
Old 08-04-2005, 02:41 AM   #6
volvogga
Member
 
Registered: Aug 2004
Location: MI, USA
Distribution: Fedora Core 3
Posts: 137

Rep: Reputation: 15
I'm not sure what the problem is here, but you could try...

mount -t auto /dev/hda2 /home/hari/academic

Could be the partition is corrupted too. I'm afraid I don't know the command to check the filesystem.
 
Old 08-04-2005, 04:13 AM   #7
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 14.1
Posts: 1,469

Rep: Reputation: 46
fsck.ext3
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem mounting CD azlan Linux - Hardware 3 09-02-2005 03:52 AM
HD mounting problem OverDrive Linux - Hardware 1 08-24-2005 05:30 PM
mounting problem angelusx Linux - Newbie 1 11-11-2004 05:52 AM
mounting problem scng Linux - Newbie 3 09-04-2004 10:36 AM
mounting problem ziggie216 Linux - Software 6 10-11-2003 01:23 AM


All times are GMT -5. The time now is 02:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration