LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-03-2004, 05:10 AM   #1
flubber
LQ Newbie
 
Registered: Oct 2003
Location: Lithuania
Distribution: Arch 0.6
Posts: 27

Rep: Reputation: 15
problem with lilo


I have recompiled kernel, and he's not booting now. When lilo appears what button should I press that would go to the command line? When I will go to the command line I'll change lilo.conf to kernel statment to /boot/vmlinuz. Please help me!
 
Old 04-03-2004, 05:41 AM   #2
jmorse
Member
 
Registered: Mar 2004
Location: United Kingdom
Distribution: LFS
Posts: 74

Rep: Reputation: 15
You may be confusing GRUB with LILO. As far as I am aware LILO doesn't have a boot time command line.

After you have compiled the new kernel copy <kernel-root>/arch/i?86/boot/bzImage to your /boot directory [assuming you are using bzImage's] Copy the System.map file as well.

Open /etc/lilo.conf [as root] in your favourite editor [eg: [in an xterm] vi /etc/lilo.conf]

Add a new section:

image=/boot/vmlinuz
label=MyNewKernel
read-only
root=<ROOT_PARTITION>

Save the file then run '/sbin/lilo' to make lilo read the new configuration, and change the boot sector accordingly.

I haven't used LILO for a while, so there may be something glaringly obvious I have forgotten!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yet another lilo problem killahsmurf Slackware - Installation 6 04-24-2005 12:33 AM
Lilo vs Grub - PROBLEM with lilo nelsonnery Linux - Software 2 09-09-2004 12:09 PM
LILO problem CommandoHamster Linux - General 4 07-22-2003 12:52 PM
LiLo Installation problem ?and (GNOME and KDE problem) hitesh_linux Linux - Software 1 01-01-2002 05:56 AM
Problem with Lilo not updating (yes I ran lilo after changing the conf) webguy Linux - General 2 06-24-2001 08:12 PM


All times are GMT -5. The time now is 09:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration