LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-24-2004, 01:52 AM   #1
sweet
LQ Newbie
 
Registered: May 2004
Location: Plzen, Czech Republic
Distribution: SuSE 9.0
Posts: 2

Rep: Reputation: 0
problem with kernel 2.6.6 and LVM - where to switch off automount /dev ?


hi all,

I can't still boot with 2.6.6 and reason is the LVM (even if is compiled into kernel)

I have read that this helps , but I don't know where set it:

--------
I finally found the problem: one has to switch off
the "automount /dev" option!

Hope other people find this helpfull too.
------------------

Where I have to switch off the "automount /dev" option ? (kernel option, fstab ...??)

many thanks
 
Old 05-25-2004, 09:22 AM   #2
jmorse
Member
 
Registered: Mar 2004
Location: United Kingdom
Distribution: LFS
Posts: 74

Rep: Reputation: 15
/etc/fstab is read by init to mount filesystems... Try adding 'noauto' to the fstab line for devfs. It probably reads 'defaults' change it to 'defaults,noauto', save and reboot.

Hopefully...

[Thats for turning off automount for /dev, about the LVM, I have no idea!]
 
Old 05-25-2004, 03:07 PM   #3
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
If you use a devfs kernel you can turn off automounting by passing an option to the kernel at boot-time, even if "Mount automatically on boot" is enabled in your kernel config. Append devfs=nomount on the kernel line in your grub.conf or on the append= line in lilo.conf.


Håkan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev problem with new kernel AxXium Slackware 19 06-02-2005 08:39 AM
thread switch results in kernel stack switch superstition Linux - General 1 05-18-2005 12:48 AM
Switch stdout between /dev/null and a file? gremlin2000 Linux - General 2 06-08-2004 08:12 AM
Switch stdout between /dev/null and a file? gremlin2000 Linux - Newbie 1 06-01-2004 11:13 AM
Problem with kernel 2.6.5 - missing /dev/hda sm0q Linux - Newbie 8 04-09-2004 05:25 PM


All times are GMT -5. The time now is 12:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration