LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-04-2009, 07:35 PM   #1
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 131

Rep: Reputation: 20
problem with gtk2,2 glib with different version fc9


well, i want to use msfgui [metasploit framewrok gui],and because of that i must install gtk2 on my fc9 os,
i install pkg-config version 0.23 then glib version 2.20 with no problem and all gtk2 dependencies ,but when i try to install gtk2 it gives me error that i must install glib version 2.17.3 or better but i just already install glib version 2.20, also glib version 2.** has been setup when i install fc9 on my laptop.i think I've got 2 glib with different version.
thank you for helping,
 
Old 08-04-2009, 09:24 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,745
Blog Entries: 1

Rep: Reputation: 224Reputation: 224Reputation: 224
First, why not use your package manager to install gtk+? In fact, I wouldn't be surprised if you already have gtk+ installed and simply need to install the dev package.

Did you install pkg-config from source or using your package manager? Where did you install all the gtk+ dependencies? If you didn't install them in the same prefix you installed pkg-config, then the pc files won't be in the default search path for pkg-config and you'll need to set the PKG_CONFIG_PATH variable.
 
Old 08-05-2009, 10:24 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,939

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
1) su , password

2) yum -y install pkgconfig gtk2-devel

... provides gtk2 ( development files ) version 2.12.9 ...

Installing another version may trash all applications,
gnome included.

.....
 
Old 08-05-2009, 11:03 AM   #4
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 131

Original Poster
Rep: Reputation: 20
i really appreciate weibullguy,
but i'm new to linux.i can't use package manager it gave me repo error,
[have gtk+ installed and simply need to install the dev package.] what is dev package?? would you please explain more,
also i don't know when i install a software, where will it be installed? [i always use binary package for installation,not rpm],
what is the pc file and how can i edit PKG_CONFIG_PATH variable,

as i said i'm really new and i just can't figure it out,
if it's possible for you, would you please give me a complete explanation,
thank you knudfl too.
 
Old 08-05-2009, 01:09 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,939

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
If you are new to Linux, Fedora 9 is not the best to use.
'End of life' for Fedora 9 was a month ago, meaning that
'updates' no longer works the way it used to.
But I have no problems installing gtk2-devel, except for
"a missing key" for a package.

Try using the command line for installing :
Open a terminal window and do ...
1) su , password
2) yum install gtk2-devel --nogpgcheck
.....
And let us know, if you have any problems.
It is easy to copy a text from the terminal window,
to show the errors here.
You cannot do that from the Package Manager → → → →
(Menu) System > Administration > "Add / Remove Software"
.....
.....
An 'rpm package' is a binary package. If you install by
doing ./configure && make .. su , make install, the files
are copied to /usr/local/bin/ , /usr/local/lib/ .
.....
.....
To know, which rpm packages you have installed :
rpm -qa | sort > installed-rpms.txt
or
yum list installed > yum-list.txt
which will provide text lists in /home/"user"/ ,
in two different formats, with all installed rpm's.
.....
.....
A -dev / -devel package is : the development files for
the library in question, e.g. gtk2 : files needed to
compile other applications using the gtk2 library.
.....
Try this : rpm -ql gtk2 , and all files are displayed.
And : rpm -ql gtk2-devel , when you have installed it.
.....

Last edited by knudfl; 08-05-2009 at 01:16 PM.
 
Old 08-05-2009, 03:27 PM   #6
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 131

Original Poster
Rep: Reputation: 20
when i run yum install gtk2-devel --nogpgcheck that is what i get:
[Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mir...ra-9&arch=i386 error was
[Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again]
i can't connect to internet with linux,
right now i have glib version 2.12 and glib-devel version 2.12 installed,i did install the glib [tar.gz format] version 2.20 with no problem but fc9 still shows the old one,
in /usr/local/bin and /usr/loca/lib i find glib 2.0 i don't know whether it's 2.12 or 2.20?
i think i must do smlink but i don't know how,
also i can'r run Computer from my desktop it gave me this one:
[couldn't display computer:///
there is no application for this file type]
isn't it because of the new glib that i've installed??
it's not finish yet alt+f2 doesn't work neither.
i know if i upgrade fc9 to 11 everything would be fine but i really want to deal with my problems in order to learn more, upgrading would be my last solution
tnx for helping.

Last edited by z99; 08-05-2009 at 03:56 PM.
 
Old 08-05-2009, 05:13 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,939

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
Yes, do not expect anything to work with a different
glib2, etc. files in /usr/local/lib.
'glib2' / 'gtk2' : 500-600 of your applications depends
on the installed versions.
Better delete the files, else no Fedora 9.
You have just been lucky, that the most still work.

And why in the first place do you want to replace
the stable glib2 , gtk2 in /usr/lib/ ? ?

If you want special packages, there are 10,000 here
http://download.fedora.redhat.com/pu...6/os/Packages/
from fedora.redhat.com.
... which you can download .....
... and install with
1) su
2) rpm -Uvh <package>.rpm
.....

Last edited by knudfl; 08-05-2009 at 05:24 PM.
 
Old 08-05-2009, 07:20 PM   #8
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 131

Original Poster
Rep: Reputation: 20
i don't want special package, i just want to run msfgui[metasploit framework],which needs gtk2 and because gtk2 needs glib version 2.17.3 or better,i download glib newest version after installation this bad story happens,
my question is if glib 2.20 is really installed? [so whay when i rpm -qa | sort > installed-rpms.txt i didn't find glib 2.20 but the old version??],if it's not installed so what the hell was the installation process for? and what did it do? just ruin the glib's old library??!!!!!
so moving to fc11 is the best way? ha!
what do you suggest my friend knudfl!!?
 
Old 08-05-2009, 08:48 PM   #9
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,745
Blog Entries: 1

Rep: Reputation: 224Reputation: 224Reputation: 224
Quote:
Originally Posted by z99 View Post
i can't use package manager it gave me repo error
I'm not a Fedora user, so I can't help you fix your package manager. You're better off fixing your package manager so I'll let knudfl help you out.

Your package manager can't find the 2.20 glib you installed because you didn't use your package manger to install it. Thus, the glib 2.20 install wasn't recorded in the package manger database. Your package manager only knows about the earlier glib version.

It is highly probable that your original glib was installed in /usr. If you didn't pass the --prefix option to glib 2.20 when you installed it, then it will be installed in /usr/local. Therefore, it is unlikely that your original version of glib was overwritten. The version of glib you're finding in /usr/local is likely the 2.20 version you installed from source. To find out for sure
Code:
grep Version /usr/local/lib/pkgconfig/glib-2.0.pc
Before you execute the configure script for gtk+,
Code:
export PKG_CONFIG_PATH="$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig"
That will add the path where you (presumably) installed the glib 2.20 metadata file. The gtk+ configure script should find your 2.20 glib after that.

Of course, my advice is still to fix your package manager problem and install the development package for gtk+ using that.

Last edited by weibullguy; 08-05-2009 at 08:50 PM.
 
Old 08-05-2009, 11:37 PM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,939

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
Ref. post # 6
Quote:
I can't connect to internet with linux, ..
I'd say, this is an issue hindering a
function-able package manager.


Without an internet connection :
You can also install 'gtk2-devel' from the install DVD.
gtk2 is already installed, you just miss the files from
the -devel package :

When configure asks for <libname> , it always means
libname-devel.
.....

Last edited by knudfl; 08-05-2009 at 11:50 PM.
 
Old 08-06-2009, 08:52 AM   #11
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,939

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
About the internet connection :
Why isn't it working on your Linux ? ?
.....

And now to msfgui ...
you will have to get these Fedora 9 packages :

subversion
ruby-gtk2
ruby
ruby-libs
ruby-atk
ruby-cairo
( ruby-devel )
ruby-gdkpixbuf2
ruby-glib2
( ruby-glib2-devel )
ruby-gtk2
ruby-pango
ruby-libglade2
ruby-gnome2
ruby-gnomecanvas2
ruby-libart2
( no gtk2, glib2 : you already have it ! ).

Next, please do this command ( on another Linux computer
with internet ? Or may be you already have the framework ? ) :
svn co http://metasploit.com/svn/framework3/trunk framework3-trunk

And when it is downloaded :
1) cd framework3-trunk
2) ./msfgui
... a nice GUI will appear, runs fine using gtk2-2.12.9.
.....

Last edited by knudfl; 08-06-2009 at 09:05 AM.
 
Old 08-06-2009, 01:52 PM   #12
John VV
Guru
 
Registered: Aug 2005
Posts: 13,051

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
seeing as you are new to linux ( and Fedora ) Fedora is not the easiest to learn on . many things MIGHT need fixing to work .

Also Fedora 9 is NOLONGER supported . There will NEVER be any updates to it EVER .

Fedora 11 is the current .If you do want to stay with fedora then install Fedora 11 .

but be warned some ( most/almost all ) have had problems with sound and if your 3d card is ati then you WILL have problems with the graphics .

Ubuntu is a good choice to install for the new Linux user , BUT fedora WILL teach you how to fix things
 
Old 08-07-2009, 08:05 PM   #13
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 131

Original Poster
Rep: Reputation: 20
well thank for helping guys,
yes i did install metasploit and i can run it easily,framework runs in 3 modes, web mode,command line and gui,when i try to do command ./msfgui it gave me error of gtk2,anyway i just install fc11 today,but when i try to log off at the first time it stops with a blank screen and for the first time a text blink and it [the text] was: noaveau 000:01:00.0:noveau-fifo-free:freeing fifo.1 after 7,8 second it stops and nothing happen,the only thing i cauld do was to restart.
well i got another question
i can't connect to internet with my notebook,but i can connect with my pc.
my question is how can i share internet from my pc runing xp,and connect my notebook running fc11 to my pc in order to use the shared internet?
 
Old 08-07-2009, 08:22 PM   #14
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,745
Blog Entries: 1

Rep: Reputation: 224Reputation: 224Reputation: 224
Quote:
Originally Posted by z99 View Post
well i got another question
Then start a new thread.
 
Old 08-08-2009, 11:12 AM   #15
z99
Member
 
Registered: Aug 2009
Location: Iran-Sari
Distribution: CentOS,Fedora,Slitaz
Posts: 131

Original Poster
Rep: Reputation: 20
thanks weibullguy,
but what about the problem that happened in the log off process
at the first time it stops with a blank screen and the second time a text blink and was: noaveau 000:01:00.0:noveau-fifo-free:freeing fifo.1. after 7,8 second it stops and nothing happen but that message was shown clearly,the only thing i cauld do was to restart.is is a bug or i don't know maybe s.th else?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gtk+2.0 installation problem(older glib version ) anirudh.iitm Ubuntu 1 08-16-2006 01:37 PM
GIMP Toolkit - Glib/GTK+ Version Problem lucky6969b Programming 1 01-05-2006 05:16 PM
glib - version ... problem dramen Slackware 27 05-18-2005 08:50 PM
Related to gtk2.0, gdk & glib nedian123 Linux - Software 1 08-05-2004 09:38 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM


All times are GMT -5. The time now is 06:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration