LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-27-2012, 01:19 AM   #1
wagmare
Member
 
Registered: Jan 2009
Posts: 62

Rep: Reputation: 15
problem with GLib


Hi friends,

my RHEL-6 has gstreamer-0.10.29

I tried to install base plugins of gstreamer -0.10.35..
i installed the source of gstreamer-0.10.35 in rhel-6

and when i tried to install gst-plugins-base

it shows
gstreamer require >0.10.35

it requires the path of gstreamer-0.10.35 pkgconfig

so i did
PKG_CONFIG=/usr/local/lib:$PKG_CONFIG ./configure

next it is showing
configure Error: This package requires GLib >=2.22 to complile ..

but my
rpm -qa | grep glib2
shows

glib2-devel-2.22.5-5.el6.i686
glib2-2.22.5-5.el6.i686

it has the version but still it is showing same error while i tried to configure the gst-plugin-base-0.10.35 ...

please help ...

Thanks in advance ...
 
Old 01-27-2012, 05:46 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
"gst-plugins-base"
Quote:
requires GLib >=2.22 to compile ..
I'd guess, it's a typo in the configure* scripts, etc.
When gst-plugins-base-0.10.35 is compiled, the dependency says "glib2" >= 2.24.0
http://packages.debian.org/wheezy/li...ins-base0.10-0

Usually not a problem :
To have gstreamer-plugins-base-0.10.35, you would just use a later
version of Fedora. And not use a server OS like RHEL ?
( RHEL 6 is Fedora 12 based.)


The solution could be to install a well hidden version, glib-2.24
to e.g. --prefix=/usr/local/glib224/ .
Requires pointing to /usr/local/glib224/lib/pkgconfig/ at compile time
and to /usr/local/glib224/lib/ at run time.

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cent OS GLib 2.12.3 pkg-config --modversion glib-2.0' returned 2.22.2 Styles Linux - Distributions 1 10-09-2009 04:12 AM
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
'pkg-config --modversion glib-2.0' returned 2.16.3, but GLIB (2.14.6) pgb205 Linux - Software 7 05-17-2008 04:21 PM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM


All times are GMT -5. The time now is 10:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration