LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem with font - Greek font in applications (http://www.linuxquestions.org/questions/linux-newbie-8/problem-with-font-greek-font-in-applications-845835/)

Akaya 11-22-2010 11:29 AM

Problem with font - Greek font in applications
 
Hi,

currently I got a strange problem with some of my applications. In some programs (LibreOffice, Skype) a Greek font is displayed instead of the original one.
The problem with Skype was fixed by an "aptitute remove skype" and a local install using the packages of Skype for Debian.
But I have no idea how to fix this problem with LibreOffice.
I hope some solved a similar issue and can help me.

Currently I am using a Debian (Sidux aka aptosid) with Xfce.

With regards from Germany
Akaya

DavidMcCann 11-24-2010 10:58 AM

Your problem seems to have puzzled everyone! Perhaps we need some more information.

If you are getting Greek letters where you should get Latin, it might be an encoding problem. In pre-Unicode days people used fonts that just put Greek instead of Latin, so you typed "font" and got "φοντ". What font is it that is showing up strangely?

Akaya 11-24-2010 11:12 AM

Hi,

thanks for the reply. Currently I can provide these information:
It seems, that the encoding or font in Xfce is related to the used gkt2-engine. I used the axiom theme, which provides in all gtk based apps a clear ui (I think the standard font is sans).

Strangly OpenOffice/LibreOffice and Skype, that I installed using aptitude, showed Greek letters instead of the latin ones. In Skype the whole ui was Greek. In OpenOffice were only the menu-items in the wrong font - everything which was typed, was in a latin font.
Removing skype and using the static pakage solved the issue for this application.
For OpenOffice, I didn't found the solution, but by changing the theme solved the issue.

Maybe some knows, what problem lies behind this behavior and explain it. For everyone else with this problem, I hope the "workaround" would fix the issue.

DavidMcCann 11-25-2010 05:14 PM

The menu in Writer would be the only thing controlled by the theme, so that's where the bug is. It's a good thing there are so many themes to choose from! It would be a good idea to report the bug to Xfce.

somecallitblues 07-25-2011 09:34 AM

I had just come across this issue on the latest Debian install. The problem was in the Application Font setting under Appearances menu. If you use the symbol font it will render as Greek font in Skype. No other application had this issue on my machine.


All times are GMT -5. The time now is 05:34 AM.