LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-07-2004, 11:01 AM   #31
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Thumbs up DONE!!!


PROBLEM SOLVED.
I post this from my Linux RedHat 8.0 box...

THis thread is not about a hardware incompatibility concern. My ethernet card worked well with MS Windows and I was able to connect the internet through my LAN from my laptop. The mess came when I decided to experiment with RedHat Linux 8.0 on that laptop. But now it's OK.

Indeed I had TWO ethernet cards I think, "eth0" and "eth1".

I decided to delete "eth0" and only kept "eth1" wich I configured like under MS. I give you here the details of what I did to access the internet through my LAN using an ethernet card.

THE FOLLOWING ARE DETAILS UNDER TABS OF THE NETWORK TOOL TO CONFIGURE (Start\System Tools\Peripheric Control\ Then click on configure if it is the right NIC (read all this post) that is selected. Highlight the NIC to configure ("eth1" for this case) and then "modify" as follows :

GENERAL/
Set to run automatically at boot
Static : IP, MASK (255.255.255.0), GATEWAY (on my case the gateway was the comp directly connected to the internet and it has its own IP I chose myself 192.168.x.x)

ROUTE/
Was also configured using the same details

MATERIAL/
"Sticked" with the right MAC address (detect) so activate here

THAT'S FOR THE NIC ITSELF.

FOR OTHERS DETAILS :

HOSTS/

127.0.0.1
HERE, NAME OF THE BOX TO CONNECT TO THE LAN
localhost. localdomain localhost

DNS/Very important

HERE, NAME OF THE BOX TO CONNECT TO THE LAN
PUT THEN THE DNS (1,2,3) YOUR ISP USES (they are the same you used probably under your MS box directly connected to the NET

For troubleshooting, you may verify firewall is not running (someone told me that RedHat 8.0 had a bug and indicates the highest security even if firewall is disabled). When problem solved the firewall must be in use for your security!

Verify the "eth1" is really ACTIVATED. If impossible to activate it, then retry from the beginning, or simply add it manually.

That's all folks. Oh and what I would suggest (some people suggested me that here in this thread : thanks!) is to ping from the terminal (Start\System Tools\Terminal) and as a root -type su- 127.0.0.1 AND the static IP you gave your NIC (in this case there is no DHCP) AND of course the gateway in order to determine what exactly is going on. The "ifconfig" command (from the terminal is also useful of course for outputs you can post then).

Have all a nice day/night

Last edited by xbbd; 03-07-2004 at 11:28 AM.
 
Old 03-07-2004, 02:36 PM   #32
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
alt234
You never really said what your problem is, just that it was similar, however, the original post said "unable to resolve www.google.com" and you seem to be able to do that. I did notice you have eth0 setup for 2 separate networks:
Code:
192.168.1.0    *                  255.255.255.0  U        0         0     0      eth0
169.254.0.0    *                  255.255.0.0      U        0         0     0      eth0
Which of those networks has your gateway device?
 
Old 03-07-2004, 02:51 PM   #33
abbey
LQ Newbie
 
Registered: Mar 2004
Location: malindi kenya
Distribution: nothing
Posts: 1

Rep: Reputation: 0
how can identify my ip server
 
Old 03-07-2004, 05:04 PM   #34
alt234
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora
Posts: 4

Rep: Reputation: 0
My problem is that I can't connect to the internet thrugh an ethernet card.

I'm not really sure why there are 2 networks configured. I believe the network that has my gateway device should be 192.168.1.0.
 
Old 03-08-2004, 07:43 AM   #35
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Just try to gather as much infos on your network. If the material (cables) seem to work and you were able to connect a MS box then it is a good start. Don't give up.
 
Old 03-08-2004, 05:29 PM   #36
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
alt234
You are getting an IP. Ping works, nslookup works, dig works. But you say you can't get on the internet?

Have you checked the browser settings to make sure it says direct connection to internet?

What is this device 192.168.1.2?


You could add these two lines to /etc/sysconfig/network. It probably wont fix your problem but you will not need to add default route anymore.
GATEWAY=192.168.1.2
GATEWAYDEV=eth0


abbey
What do you want to do? I don't understand your question.
 
Old 03-08-2004, 06:25 PM   #37
alt234
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora
Posts: 4

Rep: Reputation: 0
Quote:
Don't give up.
Oh I won't =)

Quote:
You are getting an IP. Ping works, nslookup works, dig works. But you say you can't get on the internet?
Yep.

I looked around the browser settings, didn't see that option, any idea where it is? A guy on a different forum recommended I try Lynx to see if its a problem with the browser, thing is though update programs and the like can't connect either so getting Lynx on there seems like it might be a waste of time. Am I wrong?

192.168.1.2 must be the server that I am directly connected up to. It only takes me 1 hop to get to it. I should maybe explain my setup. I'm on a network at college, I have an ethernet drop in my room, then that goes out to the servers so I don't have physical access to the servers or routers.

I don't really think it would make a difference, but on this network there are cetain things that are blocked. UDP and FTP specifically. I really don't think this would have anything to do with it since HTTP works fine on XP through the same drop on the same machine with the same settings, but who knows. I'm a Linux newbie, quite the newbie to networking too, thats why I'm here, haha.

Last edited by alt234; 03-08-2004 at 06:30 PM.
 
Old 03-08-2004, 07:11 PM   #38
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
I agree this probably this isn't the problem if other programs don't work but it doesn't hurt to check:
In mozilla check:
Edit -> Preferences -> Advanced -> Proxies
And the check box "Direct connection to Internet" should be checked.

For Konqueror it is:
Settings -> Configure Konqueror -> Proxy
And make sure the box "Use Proxy" in UN-checked.

Try this and post any interesting results:

nmap -sP 192.168.1.0/24
nmap -sP 169.254.0.0/24

You could also do a port scan of the gateway device.

nmap -sS -F -O 192.168.1.2
 
Old 03-08-2004, 09:01 PM   #39
alt234
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora
Posts: 4

Rep: Reputation: 0
Ok, Direct connection to the Internet is selected.

Tried running the commands you gave me, but it says the command nmap isn't found. Theres gotta be an alternate command so I'm looking right now for it.

Thanks for all the help!
 
Old 03-08-2004, 09:54 PM   #40
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
I would suggest you go ahead and install nmap. It is a valuable security tool and troubleshooting aid.
 
Old 03-19-2004, 03:59 AM   #41
heldeen
LQ Newbie
 
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
using a new kernel per chance?

I had the same problem on my box, RH9 (upgraded from kernel 2.4.whatever to 2.6.3) where i could resolve ip addresses from domain names but I couldn't connect to the web sites. I had enabled ethernet congestion notification in the networking part of the kernel and built and installed a new kernel with that. My router, a cheep quest rental, any many others do not support that part of the protocol so I couldn't get any where on the web. I disabled it by using the runtime config for the new kernel to turn it off and the internet worked perfectly after that. To permanetly set that option to off I added a line to the /etc/sysctl.conf file. This fix probably only will work if you compiled your own kernel and turned on this option. Runtime config is only availible in 2.6 (maybe 2.5, not familiar with that dev kernel). If you didn't build your own kernel then you probably dont have this situation and I am sorry I couldnt be of more help.


quick fix for my problem: # /sbin/sysctl -w net.ipv4.tcp_ecn=0
permenent fix: add net.ipv4.tcp_ecn = 0 to the /etc/sysctl.conf file or recompile the kernel without this option enabled not needed if this is the only thing wrong with the build.

Load up one of the kernel config editors with your current config file used to build your current kernel to check if you did infact enable this option.

-heath
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ethernet and internet unionjak Ubuntu 6 12-13-2005 08:44 PM
Problem w/connecting to internet through ethernet or wireless starchild321 Linux - Wireless Networking 2 09-27-2005 06:36 PM
Getting an internet connection... Ethernet Card problem.. Tony Empire Linux - Hardware 3 11-30-2004 06:57 PM
Can't connect to the internet... most likely ethernet card problem DannyW Mandriva 5 09-01-2004 06:14 PM
Cannot connect to the internet : Ethernet card problem!!! sha77 Linux - Newbie 5 07-20-2004 07:14 PM


All times are GMT -5. The time now is 04:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration