LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-06-2004, 02:26 AM   #16
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,113

Rep: Reputation: 65
Default route?


If you cannot ping the gateway, I suspect your default route is screwed up. What do you see when you enter "route"? There should be a line that says something like "default a.b.c.d 0.0.0.0 UG 0 0 0 eth0". I'd expect yours to read 192.168.59.79 in place of "a.b.c.d". If it doesn't, look at the file "/etc/sysconfig/network". There should be a line that reads "GATEWAY=192.168.59.79". If not, your default route is undefined. The entire file shouldn't be anything more than:
Code:
NETWORKING=yes
HOSTNAME=your.hostname.here
GATEWAY=192.168.59.79
The DNS servers should be specified in "/etc/resolv.conf". For example: "nameserver 132.123.67.24" but without the quotes.

Sorry for the file references but I never used the Red Hat GUI to set up my network. :-)

Hope this helps a bit...

Good luck,

Rick
 
Old 03-06-2004, 02:30 AM   #17
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Re: Default route?

Quote:
Originally posted by rnturn
If you cannot ping the gateway, I suspect your default route is screwed up. What do you see when you enter "route"? There should be a line that says something like "default a.b.c.d 0.0.0.0 UG 0 0 0 eth0". I'd expect yours to read 192.168.59.79 in place of "a.b.c.d".
Hope this helps a bit...

Good luck,

Rick
Yes I have default 192.168.59.79

Thanks for your help all!
 
Old 03-06-2004, 02:38 AM   #18
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Can you type "/sbin/route " and post the output?

Last edited by Demonbane; 03-06-2004 at 02:39 AM.
 
Old 03-06-2004, 02:44 AM   #19
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,113

Rep: Reputation: 65
Re: Re: Default route?

Quote:
Yes I have default 192.168.59.79
Dang! Thought that would be it. I assume that you've restarted the network service following any change to the networking settings. If not, use "/etc/rc.d/init.d/network restart" to stop and start the network processes. (You should do that as root, BTW.)

If the Windows system is able to reach the internet, I'd try disconnecting the Windows system and, using the same cable, connect your problem system. Just to check that it's not something silly like a bad cable.

Interesting problem but I'm afraid that the eight hours of sleep that I've had in the last 36 hours just ain't cuttin' it. Be back in the morning to see what you've found.

Good luck...
 
Old 03-06-2004, 03:00 AM   #20
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
@Demonbane

Quote:
Originally posted by Demonbane
Can you type "/sbin/route " and post the output?
On my redhat 8.0 box sbin/route in the terminal shows this (I translate)

Bash : sbin/route : no file or such directory

Anyway, and again thanks to all
 
Old 03-06-2004, 03:29 AM   #21
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Well, all!

I really think the problem is the security settings are set to the highest level and I can't disable the firewall. Someone tried to help me, but the fact is every time I check the security level, even after having disabled the firewall, it is always set to "high".

So my question is : how to disable totally all the security features especially the firewall so i will be bale to check if the problem was there? I tried to kill ipchains and so on but without results I guess even as root.

Anyway feel free to give up the thread since you all have already helped me a lot.

Have a nice day/night
 
Old 03-06-2004, 03:31 AM   #22
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
You probably forgot the slash sbin/route
or make sure you're in the root directory

try
/etc/rc.d/init.d/iptables stop

if that still doesnt work try executing these commands
Code:
/sbin/iptables -F
/sbin/iptables -X
/sbin/iptables -P INPUT ACCEPT
/sbin/iptables -P OUTPUT ACCEPT
/sbin/iptables -P FORWARD ACCEPT

Last edited by Demonbane; 03-06-2004 at 03:35 AM.
 
Old 03-06-2004, 03:52 AM   #23
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
@demonbane

/etc/.....stop worked : complete cleaning! Still doesn't work but...what is amazing is that another people out there can help you, take care of your problem and try to teach you step by step how to solve it.

And you realize it is true what Linus Torvalds said (read his book) : it isn't by keeping secret (for ex. the source code) something that you really learn and create someting good : it is by sharing.
And I saw many here who were sharing, taking on their own time.

:-;

Last edited by xbbd; 03-06-2004 at 03:56 AM.
 
Old 03-06-2004, 09:12 AM   #24
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 69
Couple of things:

In RH 8 there is a bug in the firewall setting GUI that will have it always display "high" no matter what the true setting is.

If you can't ping the gateway by its IP address, it certainly sounds like your routing table is misconfigured. In the output you posted, it looks like you forgot the leading slash:
Bash : sbin/route : no file or such directory
should have been /sbin/route

It might also be helpful if you posted the output of /sbin/ifconfig (you can trim the output to remove the loopback interface) as well as verify that you have the correct nameservers in /etc/resolv.conf
 
Old 03-06-2004, 10:28 AM   #25
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,113

Rep: Reputation: 65
Quote:
And I saw many here who were sharing, taking on their own time.
Well, now you know of a few people who don't have cable. :-)

Actually, we're just folks working to further Linus's World Domination goal one user at a time.

Have fun...
 
Old 03-06-2004, 11:26 AM   #26
alt234
LQ Newbie
 
Registered: Mar 2004
Distribution: Fedora
Posts: 4

Rep: Reputation: 0
same problem

I'm having a very similar problem as the starter of this thread and though I should continue posting in here instead of making a new thread.

I'm really new to Linux, just installed Fedora last night. I've read through this entire post and tried pretty much all of it. I have Fedora set up on a dual-boot with XP Home. I'm trying to connect to a permanently connected LAN. The connection works fine in XP. I'm having it automatically get the IP Address as it is in XP so it's not static.

Here is everything I have done thus far...

route add default eth0 - Seemed to do something, no fix though
pinged my primary DNS - worked
pinged 127.0.0.1 - worked
nslookup www.google.com - worked
dig www.google.com - worked
ran /etc/rc.d/init.d/ipstables stop - ran fine but didn't fix anything
rebooting after these changes - no fix

Here is some output...

*the network file*
NETWORKING=yes
HOSTNAME = localhost.localdomain

*resolve.conf*
; generated by /sbin/dhclient-script
search x.x.x.x
nameserver 198.108.x.x

*route command*
Code:
Destination     Gateway      GenMas            Flags  Metric  Ref  Use  Iface
192.168.1.0    *                  255.255.255.0  U        0         0     0      eth0
169.254.0.0    *                  255.255.0.0      U        0         0     0      eth0
127.0.0.0        *                  255.0.0.0          U        0         0     0      lo
default            192.168.1.2   0.0.0.0            UG      0         0     0      eth0

*ifconfig command (left out the loopback)*
Code:
eth0     Link encap:Ethernet   HWaddr 00:10:B5:0E:08:13
             inet addr:192.168.1.119  Bcast:192.168.1.255  Mask:255.255.255.0
             UP BROADCAST RUNNING MULTICAST MTU:1500 METRIC:1
             RX packets:517 errors:0 dropped:0 overruns:0 frame:0
             TX packets:151 errors:0 dropped:0 overruns:0 carrier:0
             collisions:0 txqueuelen:1000
             RX bytes:49324 (48.1 Kb)  TX bytes:13057 (12.7 Kb)
             Interrupt:5 Base address:0xe000
The output might look goofy getting posted but I think that should be sufficient.

Thats about everything I think. Any ideas?

Last edited by alt234; 03-08-2004 at 06:47 PM.
 
Old 03-06-2004, 03:57 PM   #27
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Hi all,

Here is the output of /sbin/route

Destination Gateway Genmask Indic Metric Ref

127.0.0.0 * 255.0.0.0 U 0 0

@Alt234 :

Welcome in this thread, I notice that you have a better config since you can ping out of your box what I'm unable to indeed.

Thanks all
 
Old 03-06-2004, 04:18 PM   #28
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Strange that the routing table isnt setup properly
but anyway try this:
Code:
route add -net 192.168.59.0 netmask 255.255.255.0 eth0
route add default gw 192.168.59.79
then make sure you put DNS servers in /etc/resolv.conf

Last edited by Demonbane; 03-06-2004 at 07:07 PM.
 
Old 03-06-2004, 07:03 PM   #29
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
@demonbane :

Was reinstalling the entire system and configured the network and nic since the beginning. I will try some solutions given here and will get back to you
 
Old 03-06-2004, 09:07 PM   #30
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Unhappy

ALways the same problem. REady to give up (at least with that Linux flavor).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ethernet and internet unionjak Ubuntu 6 12-13-2005 08:44 PM
Problem w/connecting to internet through ethernet or wireless starchild321 Linux - Wireless Networking 2 09-27-2005 06:36 PM
Getting an internet connection... Ethernet Card problem.. Tony Empire Linux - Hardware 3 11-30-2004 06:57 PM
Can't connect to the internet... most likely ethernet card problem DannyW Mandriva 5 09-01-2004 06:14 PM
Cannot connect to the internet : Ethernet card problem!!! sha77 Linux - Newbie 5 07-20-2004 07:14 PM


All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration