LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-05-2004, 05:44 PM   #1
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Rep: Reputation: 15
Problem with ethernet/internet (SOLVED!)


Hi all,

Frankly I don't know if the problem I have has been resolved somewhere in another thread, so sorry if this bothers someone. I'm totally new to linux.

I use Redhat 8.0 on a Sony PCG FX 501 laptop. I succesfully installed all the packages and then tried to connect the laptop to my own LAN.

The ethernet card is a realtek RTL 8139. I disabled the redhat firewall, and configured as follow the ethernet card eth0 (static):

IP 192.168.59.81
MASK 255.255.255.0
Gateway (another comp directly connected to a winmodem) 192.168.59.79

It seems I'm very close to the solution but when trying to connect, after some time I got "unable to resolve xxx.google.xxx". All firewalls have been desactivated and if I'm able to ping 127.0.0.1 I'm unable to ping successfully the gateway 192.168.59.79

Anyone can help ?

Thanks

Last edited by xbbd; 03-07-2004 at 10:12 AM.
 
Old 03-05-2004, 05:53 PM   #2
sirpimpsalot
Member
 
Registered: Feb 2004
Posts: 141

Rep: Reputation: 15
I am assuming that you are using another computer with a modem as a "gateway" to the internet... that is why you have that other pc address set up as your default gateway, right? if so MAKE SURE THAT IP FORWARDING IS ENABLED ON THAT BOX. VERY IMP.

did you assign DNS servers to the linux box? they would be responsible for resolving www.google.com to an ip address. and would explain that error message.

if yes, then try pinging them. if you cant ping them, youve got a connection problem on the other side of your modem (verify the gateway comp can reach the internet). if you can ping the dns servers, then run NSLOOKUP (a utility that lets you manually do name resolution.... ie you type in www.linuxquestions.org and the program responds with the numeric IP address).
 
Old 03-05-2004, 06:00 PM   #3
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Trying to follow :-)

The PC connected to the internet works fine along with another one with MS. Indeed the laptop also worked fine and was able to connect to the internet using the same config under an MS box. But it seems that the same manual config doesn't work with linux. Indeed I can't see if a DNS is set on the linux box. How to verify? A

Another way of helping me would be, if some have some time, to explain how YOU would proceed to connect a laptop on an existing an d working LAN (under MS though).

Anyway thanks for the help : I will help myself if I can
 
Old 03-05-2004, 06:07 PM   #4
sirpimpsalot
Member
 
Registered: Feb 2004
Posts: 141

Rep: Reputation: 15
Im pretty sure its just dns then (please try using nslookup... it will fail if you dont have dns entries)

what distro are you using...

dns is almost always configured on the same page (or on the advanced tab) as the IP address/sub mask/gateway
 
Old 03-05-2004, 06:08 PM   #5
sirpimpsalot
Member
 
Registered: Feb 2004
Posts: 141

Rep: Reputation: 15
~~~~~~~~~~~~~~~~~

Distribution: Redhat 8.0 The PC connected to the internet works fine along with another one with MS.
~~~~~~~~~~~~~~~~~~~~~~~~~

is the other ms computer you refered to above using 192.168.59.79
as the gateway?
 
Old 03-05-2004, 06:14 PM   #6
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Still walking

OK. Under redhat 8.0 "nslookup" doesn't show nothing. And "dig" says :
conn. timed out; no servers could be reached.
Also I can't figure how to set an ISP DNS since I will have to switch then to a DHCP config?
 
Old 03-05-2004, 06:20 PM   #7
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Yes the MS comp directly connected uses 192.....79 as a gateway. Well I agree it must be a DNS problem since the web browser first seems to run well (resolving host...) and then fails with this error message:
www.xxx couldn't be found. Please check the name and try again. While using the IP address of the web site nothing works (connection refused).
 
Old 03-05-2004, 06:21 PM   #8
sirpimpsalot
Member
 
Registered: Feb 2004
Posts: 141

Rep: Reputation: 15
quite the opposite.... if you DO USE dhcp you cannot specify DNS (they will be aquired from the DNS server)... in your case you are using a static address (right?) so you MUST fill in the DNS fields.

under redhat it is easy

go to start -> system settings -> network

fill in the primary and secondary fields under the DNS tab.
 
Old 03-05-2004, 06:33 PM   #9
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
A little confused but my fault only my fault!

Well I filled with the ISP DNS under the DNS tab but still doesn't work.

I think I won't bother the users with this (little) problem any more. I'm already happy to have installed a linux OS even if it isn't a big deal :-) since it was a quasi automatic process.

I will probabbly have to read tons of doc until I will solve the problem (you know what I mean).

So I won't say OK thanks folks for your help but it is still the mess, I will say instead thanks to have taken your time to show me some ways for solving the problem
 
Old 03-05-2004, 06:39 PM   #10
sirpimpsalot
Member
 
Registered: Feb 2004
Posts: 141

Rep: Reputation: 15
sheeet bro, dont stop now...

I think all you have to do is reinitialize/reload the network

or you could reboot...

are you using the same dns entries as your (working) ms computers


you are really close - dont give up now.
 
Old 03-05-2004, 06:46 PM   #11
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Still walking and now singing "HASTA SIEMPRE" (kidding) :-)

Yes, I'm rebooting of course and used the correct DNS server. I agree it will work soon since...I can't accept the present situation (you readers know what I mean : trying and trying again until the problem is solved). I just don't wnat others to waste (too much!) time.

By the way I have here a Suse Pro 9.0 and plan of course to try it... :-;

Last edited by xbbd; 03-05-2004 at 06:47 PM.
 
Old 03-06-2004, 12:49 AM   #12
Abe_the_Man
Member
 
Registered: Jul 2003
Location: Oshawa, Ontario, Canada
Distribution: ?????
Posts: 324

Rep: Reputation: 30
are the correct modules for your ethernet card loaded?? do "lsmod" without quotes to see what modules are loaded. The module for your card should be "8139too", or maybe just "8139". If neither of these are loaded then do "modprobe 8139too(or 8139)" to load the module. If it says there is no such module, then you will have to recompile the kernel with it. Can you ping the interface itself?? Because if you can't then your problem is with the nic itself.
 
Old 03-06-2004, 01:08 AM   #13
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
@Abe_the_Man
Yes the lsmod shows 8139too...And pinging 127.0.0.1 works fine
 
Old 03-06-2004, 01:11 AM   #14
Abe_the_Man
Member
 
Registered: Jul 2003
Location: Oshawa, Ontario, Canada
Distribution: ?????
Posts: 324

Rep: Reputation: 30
Quote:
Originally posted by xbbd
@Abe_the_Man
Yes the lsmod shows 8139too...And pinging 127.0.0.1 works fine
Sorry, what i meant by pinging the interface was to ping the ip of it. If you set it's ip to 192.168.0.101 then ping that address. Other than that, i've really got no idea and i'm really quite tired. I'll try and post some more help tommorow, but i'm beat and i can't hardly think straight. Keep at it, but try not to lose too much sleep!
 
Old 03-06-2004, 01:14 AM   #15
xbbd
Member
 
Registered: Mar 2004
Distribution: Redhat 8.0
Posts: 54

Original Poster
Rep: Reputation: 15
Yes by pinging the NIC IP I've manually set it works fine also.Thanks for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ethernet and internet unionjak Ubuntu 6 12-13-2005 07:44 PM
Problem w/connecting to internet through ethernet or wireless starchild321 Linux - Wireless Networking 2 09-27-2005 05:36 PM
Getting an internet connection... Ethernet Card problem.. Tony Empire Linux - Hardware 3 11-30-2004 05:57 PM
Can't connect to the internet... most likely ethernet card problem DannyW Mandriva 5 09-01-2004 05:14 PM
Cannot connect to the internet : Ethernet card problem!!! sha77 Linux - Newbie 5 07-20-2004 06:14 PM


All times are GMT -5. The time now is 12:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration