LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-02-2003, 01:35 PM   #1
the_pixies
LQ Newbie
 
Registered: Apr 2003
Location: Härnösand, SWEDEN
Distribution: Debian, slackware
Posts: 1

Rep: Reputation: 0
problem with /etc/lilo.conf running 3 OS:es


Hello.

First i got WinXP and debian istalled on my computer. That worked fine, but i wanted to try Slackware too. I created a new swap partition, a reiserFS root partition for slackware. Then the problems began. The installation program noticed my other swap partition (te one being used by debian) and asked if i wanted to use these two as swap partition for slackware. There was no option to choose just one of these... either both och none... so i choosed both... is it possible to share partitions between the distributions??
Secondly i accidently choosed to have lilo installed to MBR, which resulted in that when i rebooted my lilo boot menu just contained Linux... nothing else.... i tried to edit the /etc/lilo.conf
but in vain.

The information on all the NTFS partitions and the debian root partition can be mounted so the data is not lost... i just want to know how to make the lilo boot menu to show all the OS:es that i can boot from.

have a look at my /etc/lilo.conf and see if you have a solution for my problem...

Code:
boot="/dev/hda"
prompt
timeout="1200"
message=/boot/message
root=/dev/hda5
vga="773"
default=NT

image="/boot/vmlinuz"
	label="vmlinuz"
	root="/dev/hda5"
	read-only

image="/boot/vmlinuz-ide-2.4.20"
	label="2.4.20"
	root="/dev/hda5"
	read-only

image="/usr/src/linux/arch/i386/boot/bzImage"
	label="Linux_Compiled"
	root="/dev/hda5"
	read-only
	optional

other=/dev/hda1
	label="NT"
image="/dev/hda1"
	root="/dev/hda5"

image="/dev/hda1"
	root="/dev/hda5"

other=/dev/hdb1
	label="NT"

other=/dev/hdb2
	label="NT"

other=/dev/hdb3
	label="NT"
 
Old 04-02-2003, 09:07 PM   #2
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
I'd strongly suggest you let ntbootloader take care of the boot menu.

To rescue XP,
boot XP CD
enter Recovery Console
choose the partition
enter admin passwd
fixboot
fixmbr

Then follow this:
http://jetblackz.freeservers.com/Con...tiBooting.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with lilo.conf Beegie_B Linux - Newbie 2 08-04-2004 12:57 AM
lilo.conf and lilo.conf.anaconda difference blackzone Linux - General 1 07-06-2004 03:15 AM
Problem with lilo.conf Khan Linux - Software 1 04-05-2004 11:30 PM
Lilo.conf problem Vincent_Vega Linux - Newbie 3 01-01-2004 11:12 AM
Problem with Lilo not updating (yes I ran lilo after changing the conf) webguy Linux - General 2 06-24-2001 07:12 PM


All times are GMT -5. The time now is 01:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration