LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-08-2015, 11:21 AM   #1
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Rep: Reputation: 33
Problem with epel


Hello

I try to install the epel repository so I can install ejabberd.

I do not have epel, it seems :

Code:
[root@serv src]# ls /etc/yum.repos.d/
CentOS-Base.repo  CentOS-Debuginfo.repo  CentOS-fasttrack.repo  CentOS-Media.repo  CentOS-Vault.repo  n2.repo
So I try to install epel :

Code:
[root@serv src]# rpm -Uvh http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
Retrieving http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
Preparing...                ########################################### [100]
	package epel-release-6-8.noarch is already installed
But when I try to install ejabberd :

Code:
[root@serv src]# yum install ejabberd
Loaded plugins: downloadonly, fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: ftp.nluug.nl
 * extras: ftp.nluug.nl
 * updates: ftp.nluug.nl
No package ejabberd available.
Error: Nothing to do
Something is wrong with epel.
 
Old 04-08-2015, 11:38 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,808

Rep: Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604
Someone (you?) has removed your EPEL repo config files. Uninstall then reinstall epel-release.
 
Old 04-08-2015, 01:53 PM   #3
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by AlucardZero View Post
Uninstall then reinstall epel-release.
What do I need to uninstall and how do I do that ?
 
Old 04-08-2015, 03:19 PM   #4
rknichols
Senior Member
 
Registered: Aug 2009
Distribution: CentOS
Posts: 2,959

Rep: Reputation: 1268Reputation: 1268Reputation: 1268Reputation: 1268Reputation: 1268Reputation: 1268Reputation: 1268Reputation: 1268Reputation: 1268
Just run
Code:
yum reinstall epel-release
The epel-release RPM is available in the CentOS repos, so that should find it. Or, you can manually download the RPM and run
Code:
yum reinstall /path/to/epel-release-6-8.noarch.rpm
 
1 members found this post helpful.
Old 04-09-2015, 04:29 AM   #5
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Original Poster
Rep: Reputation: 33
OK I was able to erase and reinstall epel repository.

I however can still not install ejabberd :

Code:
[root@serv src]# yum install ejabberd
Loaded plugins: downloadonly, fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                                                                                               |  26 kB     00:00     
 * base: mirror.denit.net
 * epel: ftp.nluug.nl
 * extras: ftp.nluug.nl
 * updates: ftp.nluug.nl
epel                                                                                                                                                                                        | 4.4 kB     00:00     
epel/primary_db                                                                                                                                                                             | 6.5 MB     00:00     
No package ejabberd available.
Error: Nothing to do
It should be in the epel repo.
 
Old 04-09-2015, 11:22 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
No ejabberd in EPEL http://dl.fedoraproject.org/pub/epel...r_e.group.html

Used to be in this repo ...
ftp5.gwdg.de/pub/opensuse/repositories/home:/Ledest:/ErlangPro/CentOS_CentOS-6/
* The package is available from http://rpm.pbone.net/index.php3
... but may have "impossible" dependencies ?


`ejabberd 15.03' https://www.process-one.net/en/ejabberd/downloads/


-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with new epel l0pht Linux - Newbie 5 06-04-2014 06:20 AM
EPEL Repo problem newbie14 Linux - Server 26 03-14-2013 01:38 PM
Epel 6 jokar.mohsen Linux - Software 1 03-10-2012 03:47 AM
EPEL REPO - Problem agriz Linux - Server 2 12-01-2011 05:59 AM
EPEL jokar.mohsen Linux - Software 1 04-26-2011 07:32 AM


All times are GMT -5. The time now is 06:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration