LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-27-2010, 06:55 AM   #16
sumeet inani
Member
 
Registered: Oct 2008
Posts: 881
Blog Entries: 26

Original Poster
Rep: Reputation: 47

SOLUTION
This time i did
Code:
$sudo apt-get remove ffmpeg x264 libx264-dev
Then nothing special just
Code:
$cd x264;./configure;make;sudo make install;sudo ldconfig# no need of shared enable
$ cd ffmpeg ;./configure --enable-gpl --enable-postproc --enable-swscale --enable-pthreads --enable-x11grab --enable-libdc1394 --enable-libfaac  --enable-libgsm --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-nonfree ;make;sudo make install;no need of exporting LD_LIBRARY_PATH
Code:
i also learnt that 'make distclean' removes file created by configure unlike 'make clean'
thanks to knudfl (tarballing git was good) , bathory (for persisting and 'nm'=list symbol from object file)
 
Old 10-13-2010, 05:58 PM   #17
fmayfield
LQ Newbie
 
Registered: Oct 2010
Posts: 1

Rep: Reputation: 0
Days of trying to get this right. One addition..

Before doing the configure on ffmpeg, make sure on your configure of x264 you include --enable-shared --enable-pic . Then do the configure make and install as noted here.
 
Old 09-22-2012, 09:55 PM   #18
madmaze
LQ Newbie
 
Registered: Sep 2012
Posts: 1

Rep: Reputation: Disabled
I just ran into the same/very similar issue.

Most important thing was to remove the packaged libx264 so that the system finds the right one to link against.
Mainly because if you append the the LD_LIBRARY_PATH like so:
Code:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/path/to/be/added
LD will try to use the first version of the library it comes across and if there is another copy of libx264 installed, which was in the original LD_LIBRARY_PATH, it will use that one before it even looks in the path you just appended.

better to do it like so:
Code:
export LD_LIBRARY_PATH=/path/to/be/added:$LD_LIBRARY_PATH
By doing the apt-get remove you basically just removed the other copy it was finding.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] installing ffmpeg from tarball with libx264 enabled sumeet inani Linux - Newbie 6 06-21-2010 10:35 PM
Is there a resize option on ffmpeg? comcastuser Linux - Software 4 04-16-2010 03:22 PM
LINUX UBUNTU PHP FFMPEG INSTALLED BUT libx264 while installing ERROR??? trinay123 Ubuntu 2 03-13-2010 10:22 AM
[FFMPEG] Error with libx264 not found nikhil010586 Linux - Software 11 09-23-2009 03:48 AM
dependency issue: libx264.so.54 needed by ffmpeg PhilTR Fedora 22 01-23-2007 11:06 AM


All times are GMT -5. The time now is 05:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration