LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-25-2011, 12:38 PM   #1
koolgirl
LQ Newbie
 
Registered: Jul 2011
Location: Outside the darkest recess of Atlanta, GA
Distribution: opensuse 10.3
Posts: 7

Rep: Reputation: Disabled
Unhappy problem with dynamic ip config in opensuse 10.3


OK, so I'm a beginning/intermediate programmer, working mostly in perl and java at the moment, obviously from the forum I'm in, I'm not where I should be in linux admin, but I'm doing my best to remedy that.

I have comcast xfinity high speed dsl, with a dual boot win2000/opensuse 10.3 system. I'm connected in win2000, but I can't quite figure out how to configure comcast's dynamic ip address' in opensuse 10.3, either on command line, or in KDE with YAST (scream on the latter attempt).

I've looked up all man/help pages on ip cpnfig, but the problem is that my last internet connection was through a router with a static ip address, and I can't quite figure out the shell command from man pages ( I've tried dozens of combos like ip addr [change] {dynamic|on} etc. from what I could gather from man page instructions, but I can't seem to get the dev object and options worded just right), and I'm about ready to throw my monitor at the wall during every YAST attempt (and of course YAST doesn't pick up my dsl automatically and why it's asking for a comcast userid upon manual entry I haven't the slightest).

Could anyone please help me with the proper linux command/commands to accomplish this on the command line?

I've been part of a few linux communities and I already know about rtfm, which I've tried very hard to cover thoroughly before this post, so if I seem a bit exasperated I do apologize, all the hours I've spent trying to rtfm before this post, are probably the reason for that.

Thank you so much for your time, and if you've already wasted the 15 minutes it took to read my rant/babbling/question, you might as well answer

exasperated in atlanta
koolgirl
 
Old 07-25-2011, 12:50 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hello koolgirl, welcome to LQ,

are you using DHCP? if yes, your Win2000 should receive it's IP-configuration automatically. Same thing for Suse, you'll have to check, if the ethernet-adapter is recognized by the system. Could you please open a terminal and post the output of the following two commands:
Code:
lspci -k | grep -iA5 ether
Code:
ifconfig
if the first command does not show any output you may alternatively use the command
Code:
lspci -k | grep -iA5 net
Markus
 
1 members found this post helpful.
Old 07-25-2011, 01:19 PM   #3
koolgirl
LQ Newbie
 
Registered: Jul 2011
Location: Outside the darkest recess of Atlanta, GA
Distribution: opensuse 10.3
Posts: 7

Original Poster
Rep: Reputation: Disabled
Question reply to markus' suggestions..

Quote:
Originally Posted by markush View Post
Hello koolgirl, welcome to LQ,

are you using DHCP? if yes, your Win2000 should receive it's IP-configuration automatically. Same thing for Suse, you'll have to check, if the ethernet-adapter is recognized by the system. Could you please open a terminal and post the output of the following two commands:
Code:
lspci -k | grep -iA5 ether
Code:
ifconfig
if the first command does not show any output you may alternatively use the command
Code:
lspci -k | grep -iA5 net
Markus
First of all, please forgive time lapses, dual boot so I do have to re-start, log-in to linux, then re-start back into win2000, etc.

Ok, so the first command,
Code:
lspci -k | grep -iA5 ether
produced an error saying -k was not a valid command

the second command,
Code:
ifconfig
produced
Code:
eth0 
link encap:Ethernet HWaddr 00:BO:DO:CF:DC:74
inet addr: 98.192.42.235 Bcast:255.255.255.255 Mask: 255.255.248.0
inet6 addr:fe80::2bo:doff:fecf:dc 74/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST
lo
link encap:Local loopback
inet addr:1270.0.1 Mask 255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOP BACK RUNNING
as you can see, the ip address configurations are still set to what they were configured before for the router/static ip. I've read and been told before that suse should pick up my new DSL automatically, and I'm not sure why it doesn't, as I stated, even YAST in the KDE windows environment won't pick it up. However I do know there isn't a connection problem w/ethernet cable,etc. because win2000 is up and running just fine. ??

And also, when I had to config win2000 in control panel, I did have to set DHCP to dynamic per comcast's request, so I suppose the answer would be yes to that?
 
Old 07-25-2011, 01:26 PM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
This looks like a pppoe connection to me. Could you please in Win2000 open the cmd (dosshell) and post the output of
Code:
ipconfig /all
Markus
 
1 members found this post helpful.
Old 07-25-2011, 01:35 PM   #5
koolgirl
LQ Newbie
 
Registered: Jul 2011
Location: Outside the darkest recess of Atlanta, GA
Distribution: opensuse 10.3
Posts: 7

Original Poster
Rep: Reputation: Disabled
Ok, so this is cut/paste response to ipconfig /all in windows command prompt:

Code:
E:\Rockware_Programming_Inc>ipconfig /all

Windows 2000 IP Configuration

        Host Name . . . . . . . . . . . . : stickyfingers
        Primary DNS Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Broadcast
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : hsd1.ga.comcast.net.

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : hsd1.ga.comcast.net.
        Description . . . . . . . . . . . : 3Com 3C920 Integrated Fast Ethernet
Controller (3C905C-TX Compatible)
        Physical Address. . . . . . . . . : 00-B0-D0-CF-DC-74
        DHCP Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 98.192.42.232
        Subnet Mask . . . . . . . . . . . : 255.255.248.0
        Default Gateway . . . . . . . . . : 98.192.40.1
        DHCP Server . . . . . . . . . . . : 69.252.196.196
        DNS Servers . . . . . . . . . . . : 68.87.68.166
                                            68.87.74.166
        Lease Obtained. . . . . . . . . . : Monday, July 25, 2011 2:01:54 PM
        Lease Expires . . . . . . . . . . : Friday, July 29, 2011 7:22:25 AM
 
Old 07-25-2011, 01:40 PM   #6
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
It looks like you have a valid pppoe connection on both systems, Suse and Windows.

Which trouble do you have with Linux? did you try to access the internet with Suse? if yes, which problems did you have?

Markus
 
1 members found this post helpful.
Old 07-25-2011, 01:51 PM   #7
koolgirl
LQ Newbie
 
Registered: Jul 2011
Location: Outside the darkest recess of Atlanta, GA
Distribution: opensuse 10.3
Posts: 7

Original Poster
Rep: Reputation: Disabled
Well, when I first connected ethernet/modem/etc. when I self-installed comcast equipment, in win2000 I couldn't connect to internet, it would just be waiting, waiting, then after about ten minutes say can't reach server at wherever.com. So, I of course figured out that I had to configure for dynamic ip address and dynamic dhc server etc.

So, then in linux, the same thing happened, and I assumed it was same problem. So when I went into YAST (KDE) it didn't pick up a dsl connection at all. I still can't connect but looking now at both outputs, I see in comparison the ip address numbers are the same except for the very last number...is that a problem, or is that due to linux on seperate partition, ? Perhaps the connection problem is not with linux but with kde, therefore not an ip address problem but a kde config problem.

Also, when I tried to enter the connection manually in YAST, since it couldn't find it, it asked for provider, which I gave comcast, then asked for a userid and password which I don't even know what those would be...???

By the way, irregardless of what I might accomplish, thank you for helping me, I sincerely appreciate as a coder myself how important your time and expertise are...
 
Old 07-25-2011, 02:00 PM   #8
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
The difference in both IP-adresses is because everytime you start the computer you get a new lease via DHCP from your provider.

I cannot seem to find out why your connection with Suse does not work. Did you open a browser and open any website?

btw: KDE has nothing to do with the network-connection, KDE is a Desktop environment. But there is the kppp tool in KDE, maybe this would help, but as you wrote you don't have to configure your provider, userid and password. So I think your connection should work without any additional configuration.

Markus
 
Old 07-25-2011, 02:16 PM   #9
koolgirl
LQ Newbie
 
Registered: Jul 2011
Location: Outside the darkest recess of Atlanta, GA
Distribution: opensuse 10.3
Posts: 7

Original Poster
Rep: Reputation: Disabled
Lightbulb

Well, actually, in the kde environment, YAST said that i needed to dl the kppp package to configure the connection, but I can't connect to the suse repository because I can't connect in linux.

Also, about the ip address, I've had that same address since I first connected, I just keep getting a new lease on it, and in the win2000 output, the lease is good till 7/29/11, so shouldn't that last number still be the same in linux?

Maybe not, maybe I'm getting a different address/lease through linux. Well, I guess I've got some more research to do, there must be something going on I've missed, because it looks as though from what you've said, and from output, that the ip address might not be the problem. I'm going to try and ping their machine from the command line. If I can, then the problem maybe only exists in kde...I'm still a lil perplexed about that last number...

Thanks marush, I appreciate your help, and I may still have some work to do, but at least you helped me figure out what wasn't happening..
 
Old 07-25-2011, 02:33 PM   #10
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,768

Rep: Reputation: 322Reputation: 322Reputation: 322Reputation: 322
@ Reply

Hi there,

Welcome to LQ!!!

I am trying to catch up with issue you are facing. As I can understand your ethernet card still uses the static IP which was in use before and now you want to eth to obtain IP using DHCP.

Try out the following steps:

1. Find a file with the name ifcfg-eth0. To find this you can use the following command:
Code:
 find / -name ifcfg-eth0
2. If you get multiple locations then paste the locations here (Though it shouldn't show multiple locations) but still.

3. Use a text editor to edit the file that you found using find command:
Code:
 vi /etc/location_of_the_file/ifcfg-eth0
4. You will find something in that file which says BOOTPROTO=none or BOOTPROTO=static. Change this parameter to BOOTPROTO=dhcp

5. Save the file and exit.

6. Restart the network using the following command
Code:
service network restart
or
Code:
ifdown eth0 and then ifup eth0
I hope this will work. Give it a try and let us know the result.
 
Old 07-25-2011, 03:52 PM   #11
koolgirl
LQ Newbie
 
Registered: Jul 2011
Location: Outside the darkest recess of Atlanta, GA
Distribution: opensuse 10.3
Posts: 7

Original Poster
Rep: Reputation: Disabled
Thumbs up I see said the blind man..........

Alright, I'm on my linux box, and connected to the internet very successfully, and my monitor is still in tact and not thrown through my 2nd story window...thank you both so very much!

T3rm1nventor, thank you sooo much, however, the command you gave me for some reason was pulling up every single file in my system, it was matching on '/', but I wrote a quick regex after I figured that out, found the ifcfg-eth0 file, /etc/sysconfig/network, btw, and I used joe in place of vi, but your advice worked like a charm.

Thanks for the help, as well, markush, you taught me a great way on comparing win2000/suse output.
 
Old 07-26-2011, 01:44 PM   #12
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,768

Rep: Reputation: 322Reputation: 322Reputation: 322Reputation: 322
@ Reply

Great!!! Am glad it worked!!! Enjoy Linux...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSUSE 11.1 standard .config Simon1987 Linux - Distributions 3 08-06-2009 05:27 AM
LXer: OpenLDAP Quick Tips: Switch to the dynamic config backend (cn=config) LXer Syndicated Linux News 0 11-27-2008 04:00 PM
[SOLVED] Opensuse 10.3 : LAMP install, but problem with starting / config mysql hophop Linux - Newbie 1 11-25-2008 11:13 PM
SSH config on OpenSuse 10.2 andy.l Suse/Novell 3 04-23-2007 05:32 PM
postfix with dynamic ip config jay820 Linux - Software 30 08-11-2003 11:26 AM


All times are GMT -5. The time now is 02:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration