LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-14-2015, 03:27 AM   #1
Sunny.soni
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Rep: Reputation: Disabled
Unhappy Problem with Creating Malicious Node For OLSR in Ubuntu 14.10 with ns 2.35


Experts,


I need your help to create malicious nodes for OLSR routing protocol. I completly patch OSLR in ns 2.35 in ubuntu 14.10 (32-bit) and its working but when I am try to create any malcious node by defining it "Malicious" or "hacker" it show me an error and not running that .tcl file.

for an example.

$ns_ at 0.0 "[$node_(8) set ragent_] hacker "
$ns_ at 0.0 "[$node_(14) set ragent_] hacker "
$ns_ at 0.0 "[$node_(20) set ragent_] hacker "
$ns_ at 0.0 "[$node_(26) set ragent_] hacker "



Help me to solve this problem.
I searched over internet but couldn't find any solution.

Help me to solve this.

Thank you.
 
Old 04-14-2015, 03:36 AM   #2
naren.ad.13
LQ Newbie
 
Registered: Mar 2015
Posts: 5

Rep: Reputation: Disabled
Ya I have same Problem as you have.

I already put that in my previous post but i didn't get any answers.
 
Old 04-14-2015, 05:57 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
I guess you will have to add malicious (hacker) to OLSR**.cc. OLSR**.h,
... like it's added for AODV. ( Or ZRP.) . ... And try if it works.

Malicious : aodv-malicious_ns235.patch
https://drive.google.com/file/d/0B7S...ew?usp=sharing

Malicious ZRP : zrp-malicious_ns235.patch
https://drive.google.com/file/d/0B7S...ew?usp=sharing


-
 
Old 04-14-2015, 06:32 AM   #4
Sunny.soni
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
Dear knudfl,


I tried that too but it's not working for OLSR.
So , If you have any other idea please help me.
 
Old 04-28-2015, 06:34 AM   #5
Sunny.soni
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
Unhappy

Hey,

I tried But its not working.

Can anyone help me to add misbehaving node for OLSR ..??
 
Old 04-28-2015, 07:50 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
Well, lots of information to find .... but no code ?


Google https://www.google.com/webhp?hl=all&...2+olsr+attacks
-------
http://link.springer.com/article/10....2826773#page-1
http://link.springer.com/article/10.1007%2FBF02826773

http://www.ijcsit.com/docs/Volume%20...0140503379.pdf

http://www.researchgate.net/profile/...17f2fa81ea.pdf

http://www.ijaiem.org/volume3issue4/...-04-30-091.pdf

etc.
 
1 members found this post helpful.
Old 05-08-2015, 04:00 AM   #7
Sunny.soni
LQ Newbie
 
Registered: Apr 2015
Posts: 4

Original Poster
Rep: Reputation: Disabled
I am facing another problem in ns 2 from now
Hey Experts,

I installed two version of ns2 in ubutntu 14.10
ns 2.34 and ns 2.35

so I set path in .bashrc file completly correct also when actually i m going to run any .tcl file it not showing me nam but showing xgraphs.

so anyone can help me with this .

error :


Can't find a usable init.tcl in the following directories: /home/sunny/ns/ns-allinone-2.34/tcl8.4.18/library:/usr/lib /home/sunny/ns-allinone-2.35/lib/tcl8.5 ./lib/tcl8.5 ./lib/tcl8.5 ./library ./library ./tcl8.5.10/library ./tcl8.5.10/library
 
Old 05-08-2015, 05:39 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
Re #7.

Please read the OLSR postings (again) http://www.linuxquestions.org/questions/tags/olsr/ ,
also > > > http://www.linuxquestions.org/questi...-4175503158/#2
... and you will know that ns2 doesn't require any *PATH settings ( in .bashrc ).


ns-2.34 , ""Can't find a usable init.tcl "" :
The executable 'ns_any-name' is hard coded to know it`s library location :
ns-allinone-2.34/{ bin/tcsh8.4 , lib/*/* }. (And .bashrc cannot change that location.)
... So the only way "cannot find" will appear, is if you moved ns-allinone-2.34/ to a new location.
( Or deleted { bin/ , lib/ } .)

Moving the ns2: You will have to leave a copy of ns-allinone-2.34/{bin/, lib/} in the build location.


Installing ns-allinone is :
cd ns-allinone-2.34/ns-2.34/ && cp ns ns234-olsr && sudo cp ns234-olsr /usr/local/bin/

cd ns-allinone-2.35/ns-2.35/ && sudo make install
cp ns ns235-olsr && sudo cp ns235-olsr /usr/local/bin/
cd ../nam-1.15/ && sudo make install

Then you have /usr/local/bin/{ nam, ns, ns234-olsr, ns235-olsr }
Simulation : ns234-olsr mezyana-30.tcl


-

Last edited by knudfl; 05-08-2015 at 05:45 AM.
 
Old 05-18-2015, 10:55 AM   #9
koko123
LQ Newbie
 
Registered: Mar 2015
Posts: 2

Rep: Reputation: Disabled
hello
how to add a malicious node in ns2.35 protocol OLSR
please help me
 
Old 05-18-2015, 10:58 AM   #10
koko123
LQ Newbie
 
Registered: Mar 2015
Posts: 2

Rep: Reputation: Disabled
hello
how to add a malicious node in ns2.35 protocol OLSR
please help me
 
  


Reply

Tags
ns2, olsr


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i tried to add malicious node in aodv anand755 Linux - Networking 13 02-28-2016 03:51 PM
getting error in .tcl while creating malicious node in aodv in ns2.35 saa-6611 Linux - Software 12 05-22-2014 07:00 AM
malicious node detection in wsn navinkb Linux - Wireless Networking 1 04-15-2014 07:31 AM
NS-2: Malicious node in AODV Error amissan Linux - Software 1 05-05-2013 11:28 AM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration