LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-23-2006, 10:30 PM   #1
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Rep: Reputation: 30
Problem while installing xchm


hi nice ppl

i want to install xchm(to read chm files),when installing xchm it requested
wxwidgets while the configure program and it also requested GTK+ the same thing with GTK+(configure) showed amessage like that:
Quote:
checking for BASE_DEPENDENCIES... Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found
configure: error: Package requirements (glib-2.0 >= 2.11.4 atk >= 1.9.0 pango >= 1.13.0 cairo >= 1.1.8) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
then i installed the glib every thing was ok with the glib,so when getting back to install GTK+ i got the same error message above

pls any ideas or suugestions are welcome

many thanks
 
Old 08-25-2006, 07:13 AM   #2
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
Quote:
Originally Posted by adilturbo
hi nice ppl

i want to install xchm(to read chm files),when installing xchm it requested
wxwidgets while the configure program and it also requested GTK+ the same thing with GTK+(configure) showed amessage like that:

then i installed the glib every thing was ok with the glib,so when getting back to install GTK+ i got the same error message above

pls any ideas or suugestions are welcome

many thanks
where do you have glib installed?

Run set and see if you have PKG_CONFIG_PATH
if it does not contain /usr/lib/X11R6/lib/pkgconfig
you'll want to add that in your .bash_profile, but to start you can just do

export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/X11R6/lib/pkgconfig

more than likely that will fix the problem.
 
Old 08-25-2006, 10:49 AM   #3
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
hi again

ok i did what u said(rane tha set command) but i did not find the PKG_CONFIG_PATH

so what shall i do now please?

thanks
 
Old 08-25-2006, 05:16 PM   #4
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
Quote:
Originally Posted by adilturbo
hi again

ok i did what u said(rane tha set command) but i did not find the PKG_CONFIG_PATH

so what shall i do now please?

thanks

For the time being, type: export PKG_CONFIG_PATH=/usr/X11R6/lib/pkgconfig and try it again.

Then use a text editor on your .bash_profile and put the line above into it (if it works). That way it will be set from then on.

(NOTE: Make sure that X11R6 is actually in the usr directory)
 
Old 08-26-2006, 10:34 AM   #5
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
hi

1st i want just to tell you that i do not have the pkgconfig directory in /usr/X11R/lib it exists in /usr/lib and /usr/local/lib so

i typed export PKG_CONFIG_PATH=/usr/lib/pkgconfig then editing the .bash_profile then ./configure for gtk+ i got the same error message

so please any solution ?

thanks in advance
 
Old 08-28-2006, 07:57 AM   #6
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
hi kind ppl

please any other solutions

thanks
 
Old 08-28-2006, 08:46 PM   #7
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
You put usr/lib in, but not usr/local/lib

find / -name glib* and see if it may be in the usr/local/lib... if so that also needs to be in your PKG_CONFIG_PATH
 
Old 08-28-2006, 09:57 PM   #8
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
could you please clarify wht exactly i shall do?

thanks
 
Old 08-29-2006, 09:36 PM   #9
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
type export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig
 
Old 08-30-2006, 01:56 PM   #10
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
hi again

ok i did what you said,thanks,every thing was right.

now i moved to install the atk which is also requiered bt the GTK+,

while the configure program i got an error :

Quote:
*** 'pkg-config --modversion glib-2.0' returned 2.12.0, but GLIB (2.4.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.12.0, but GLIB (2.4.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
and i have the PKG_CONFIG_PATH loks like that:
PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig:/usr/local

the problem is that when i installed glib-2.12.0 in /usr/local:
./configure --prefix=/usr/local

when i look for it in the /usr/local using either(the locate or find commands)i do not find it(glib-2.12.0)

so what is the solution?

thank you so much
 
Old 08-30-2006, 09:36 PM   #11
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
find / -name glib*.pc

as root

If you come up with two glib.pc files do an ls -la on them both to see which is older(on your system)

,
I think the main problem is that you installed an older version of glib over an already existing version of glib. The thing is if you had not installed glib again and just set the pkg-config-path, everything would probably be fine now, but now we have to clean up our mess :P

Also do a set and see if you have LD_LIBRARY_PATH as we might just skip over the PKG_CONFIG_PATH on this one.

As a side note, make sure you add the PKG_CONFIG_PATH line from above to your .bash_profile, so that it is loaded everytime you restart.

Last edited by debiant; 08-30-2006 at 09:48 PM.
 
Old 08-31-2006, 12:30 PM   #12
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
for LD_LIBRARY_PATH i did not find it with the set command(please what's its goal). but i configured the /etc/ld.so.conf added the /usr/local/lib path, then moving to to pango(also needed by GTK+) so it needs the fontconfig.pc i installed it, then moved to cairo(also requested by GTK+).the pblm i had is that i tough that installing glib-2.12.0 so i should find glib-2.12.0.pc,in fact it is glib-2.0.pc

so now during the cairo configure i got message:
Quote:
checking for xlib... Package x11 was not found in the pkg-config search path.
Perhaps you should add the directory containing `x11.pc'
to the PKG_CONFIG_PATH environment variable
No package 'x11' found
checking whether cairo's Xlib backend could be enabled... no (requires X development libraries)
checking for cairo's Xlib Xrender backend...
checking whether cairo's Xlib Xrender backend could be enabled... no (requires --enable-xlib)
checking for cairo's Microsoft Windows backend...
checking whether cairo's Microsoft Windows backend could be enabled... no (requires a Win32 platform)
checking for cairo's Microsoft Windows font backend...
checking whether cairo's Microsoft Windows font backend could be enabled... no (requires a Win32 platform)
checking for cairo's PNG backend...
configure: WARNING: Could not find libpng in the pkg-config search path
checking whether cairo's PNG backend could be enabled... no
configure: error: requested PNG backend could not be enabled
so please what is the solution?

many thanks
 
Old 08-31-2006, 08:45 PM   #13
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
What distro are using, out of curiousity, that you are installing all of this by hand?

I'm not going to give you a solution to this one, you have to locate the x11.pc, how have we done that so far? How have we loaded that path? See if that fixes the rest of the problems, although you will probably also have to install libpng... a never ending list of dependencies for this one.
 
Old 09-01-2006, 09:08 AM   #14
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
hi

i'm using mandrake 10.1

about x11.pc i did not find it?

so please what shall i do?
 
Old 09-02-2006, 12:58 AM   #15
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
Quote:
Originally Posted by adilturbo
hi

i'm using mandrake 10.1

about x11.pc i did not find it?

so please what shall i do?
Sanity Check, do you have xorg or Xfree86 installed?

also, you man need to install the X11 development libraries.

Is there a reason you are installing all of these the way you are. doesn't mandrake use rpm? If so, why not use rpm with dependency checking. Holy hell it would save a lot of hassle.

why not do urpmi xchm

Last edited by debiant; 09-02-2006 at 01:17 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xchm error NNP Linux - Software 1 08-25-2006 06:38 AM
Problem with Xchm viewer for linux Thatusr Linux - Software 11 01-22-2006 03:01 PM
xchm problem kb_ganesh Red Hat 0 07-24-2005 02:23 AM
xchm problem Nizzuri Linux - Newbie 5 08-16-2004 11:49 PM
xchm problem Nizzuri Linux - Software 1 08-15-2004 05:16 PM


All times are GMT -5. The time now is 10:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration