LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-17-2011, 02:19 AM   #1
rbala14
LQ Newbie
 
Registered: Jan 2008
Location: India
Posts: 11

Rep: Reputation: 0
Smile Problem while configuring YUM


Hi All,
I want to setup an local repositories to distribute .rpm files for users in RHEL-5. I installed yum & created the folder in "/var/pub/ftp/Servers" when i try to access it from client i am getting the below error
Loaded plugins: rhnplugin, security
Repository rhel-debuginfo is listed more than once in the configuration
Traceback (most recent call last):
File “/usr/bin/yum”, line 29, in ?
yummain.user_main(sys.argv[1:], exit_code=True)
File “/usr/share/yum-cli/yummain.py”, line 309, in user_main
errcode = main(args)
File “/usr/share/yum-cli/yummain.py”, line 157, in main
base.getOptionsConfig(args)
File “/usr/share/yum-cli/cli.py”, line 187, in getOptionsConfig
self.conf
File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 664, in
conf = property(fget=lambda self: self._getConfig(),
File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 253, in _getConfig
self.plugins.run(‘init’)
File “/usr/lib/python2.4/site-packages/yum/plugins.py”, line 179, in run
func(conduitcls(self, self.base, conf, **kwargs))
File “/usr/lib/yum-plugins/rhnplugin.py”, line 111, in init_hook
login_info = up2dateAuth.getLoginInfo()
File “/usr/share/rhn/up2date_client/up2dateAuth.py”, line 217, in getLoginInfo
login()
File “/usr/share/rhn/up2date_client/up2dateAuth.py”, line 184, in login
li = server.up2date.login(systemId)
File “/usr/share/rhn/up2date_client/rhnserver.py”, line 52, in __call__
raise self.__exception_from_fault(f)
up2date_client.up2dateErrors.AbuseError:
Error Message:
Abuse of Service detected for server rhel5-64 (1016133212)
Error Class Code: 49
Error Class Info:
You are getting this error because RHN has detected an abuse of
service from this system and account. This error is triggered when
your system makes too many connections to Red Hat Network. This
error can not be triggered under a normal use of the Red Hat Network
service as configured by default on Red Hat Linux.

The Red Hat Network services for this system will remain disabled
until you will reduce the RHN network traffic from your system to
acceptable limits.

Please log into RHN and visit https://rhn.redhat.com/help/contact.pxt
to contact technical support if you think you have received this
message in error.


The .repo file in client is as shown below

bash-3.2$ more /etc/yum.repos.d/Server.repo
[rhel-debuginfo]
name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=ftp://server.com/pub/Server
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

I have even tried by commenting the gpgcheck line but getting the same error. Also the service VSFTP is running in server and i am able to telnet to it via FTP from the client.
Could some help me to setup an separate repo?

Thanks.

Last edited by rbala14; 01-17-2011 at 02:27 AM.
 
Old 01-17-2011, 02:36 AM   #2
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello,

I'm no RHEL expert at all but there's one thing that jumps out:
Code:
[rhel-debuginfo]
name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=ftp://server.com/pub/Server
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
The line in bold indicates your repo is NOT enabled. Set it to 1 and try again. Don't know if you have to do a yum clean all first or not.

As it looks from your errors you're trying to connect to RHN instead of your own FTP I imagine. Also, did you disable or rename the other repo files on your local servers, leaving only your FTP repo enabled?

Kind regards,

Eric
 
Old 01-18-2011, 01:09 AM   #3
rbala14
LQ Newbie
 
Registered: Jan 2008
Location: India
Posts: 11

Original Poster
Rep: Reputation: 0
Hi EricTRA,

I have made enabled=1, also run the command yum clean all and renamed the original .repo file to .repo-bak and tried.
But then also its trying to connect to RHN instead to my ftp.

In the server the .repo file is as shown below

bash-3.2$ more Server.repo
[rhel-debuginfo]
name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=file:///var/ftp/pub/Server
enabled=1
#gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release



And in the client the .repo file is as shown below

bash-3.2$ more Server.repo
[rhel-debuginfo]
name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=ftp://server.com/pub/Server
enabled=1
#gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release




Hope now u get clear idea of my config & u can help me.
Thanks.

Last edited by rbala14; 01-18-2011 at 01:11 AM.
 
Old 01-18-2011, 01:18 AM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
I think you need the createrepo cmd
http://www.cyberciti.biz/tips/redhat...etup-repo.html
http://www.howtoforge.com/creating_a...ository_centos
etc
 
Old 01-18-2011, 02:14 AM   #5
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

chrism01 has a good point here. Looks like you didn't set up the repository like it should be. There is no use for a .repo file on the server side. Using the createrepo command as pointed out to you by chrism01 creates a directory with some compressed files and a repomd.xml file which get downloaded and read by the client when connecting to your repository. Follow the guides chrism01 pointed you to and you should be up and running in no time.

Kind regards,

Eric
 
Old 01-18-2011, 04:45 AM   #6
rbala14
LQ Newbie
 
Registered: Jan 2008
Location: India
Posts: 11

Original Poster
Rep: Reputation: 0
Hi EricTRA & Chris,

No i have used the createrepo and the repodata dir si at the location /var/ftp/pub/Server/repodata inside this i am able to find the files both in Server side & in client side

bash-3.2$ sudo ls -l /var/ftp/pub/Server/repodata/
total 16
-rw-r--r-- 1 root root 170 Jan 18 03:30 filelists.xml.gz
-rw-r--r-- 1 root root 165 Jan 18 03:30 other.xml.gz
-rw-r--r-- 1 root root 177 Jan 18 03:30 primary.xml.gz
-rw-r--r-- 1 root root 951 Jan 18 03:30 repomd.xml


Even then when i give yum update getting the above said error in clint side only.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help configuring YUM zak4u Linux - Newbie 5 03-23-2009 07:32 AM
Problem with configuring yum to use DVD cheezmode Fedora 17 04-15-2007 07:30 AM
problem configuring of yum Gogul Linux - Software 2 05-19-2006 03:28 PM
Configuring YUM taborekle Fedora 3 02-23-2006 02:35 PM
help configuring yum J0sep Fedora 1 01-13-2005 03:00 PM


All times are GMT -5. The time now is 08:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration