LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 04-15-2011, 04:45 AM   #1
fabio vinc
LQ Newbie
 
Registered: Apr 2011
Location: Italy,Turin
Distribution: Red Hat 3.4.5-2
Posts: 3

Rep: Reputation: 0
Problem upgrade php to 5.2.x from 5.1.6 missin php-common


(I apologize to everyone for my English).
I need to upgrade PHP 5.1.6 to 5.2.x.

I have a problem with php-common dependency.

Code:
yum update php
result :
Code:
[root@62 ~]# yum update php
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
extras                    100% |=========================| 2.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
atomic                    100% |=========================| 1.9 kB    00:00
addons                    100% |=========================|  951 B    00:00
ftp://mirror.fraunhofer.de/centos.org/5  repomd.xml: [Errno 4] IOError: [Errno ftp error] timed out
Trying other mirror.
updates                   100% |=========================| 1.9 kB    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package php.i386 0:5.3.6-2.el5.art set to be updated
--> Running transaction check
--> Processing Dependency: php = 5.1.6-15.el5 for package: php-devel
--> Processing Dependency: php-common = 5.3.6-2.el5.art for package: php
--> Processing Dependency: php-cli = 5.3.6-2.el5.art for package: php
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package php-devel.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-cli.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-common.i386 0:5.3.6-2.el5.art set to be updated
--> Running transaction check
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-snmp
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-xml
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-gd
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-pdo
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-odbc
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-mbstring
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-mysql
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-ldap
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-ncurses
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-imap
--> Processing Dependency: libedit.so.0 for package: php-cli
--> Processing Dependency: php-common = 5.1.6-15.el5 for package: php-xmlrpc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package php-snmp.i386 0:5.3.6-2.el5.art set to be updated
---> Package libedit.i386 0:3.0-2.20090923cvs.el5.art set to be updated
---> Package php-imap.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-xmlrpc.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-pdo.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-ldap.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-mysql.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-odbc.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-mbstring.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-ncurses.i386 0:5.2.17-1.el5.art set to be updated
---> Package php-xml.i386 0:5.3.6-2.el5.art set to be updated
---> Package php-gd.i386 0:5.3.6-2.el5.art set to be updated
--> Running transaction check
--> Processing Dependency: libmysqlclient.so.16 for package: php-mysql
--> Processing Dependency: php-common = 5.2.17-1.el5.art for package: php-ncurses
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: php-mysql
--> Processing Dependency: libt1.so.5 for package: php-gd
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package mysql-libs.i386 0:5.1.56-1.el5.art set to be updated
---> Package t1lib.i386 0:5.1.2-2.el5.art set to be updated
--> Running transaction check
--> Processing Dependency: php-common = 5.2.17-1.el5.art for package: php-ncurses
--> Processing Dependency: libXaw.so.7 for package: t1lib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libXaw.i386 0:1.0.2-8.1 set to be updated
--> Running transaction check
--> Processing Dependency: php-common = 5.2.17-1.el5.art for package: php-ncurses
--> Processing Dependency: libXmu.so.6 for package: libXaw
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libXmu.i386 0:1.0.2-5 set to be updated
--> Running transaction check
--> Processing Dependency: php-common = 5.2.17-1.el5.art for package: php-ncurses
--> Finished Dependency Resolution
Error: Missing Dependency: php-common = 5.2.17-1.el5.art is needed by package php-ncurses
I'm not an expert. I've tried (among other commands unsuccessful)

Code:
yum remove php-common. (idea suggested here
result:

Code:
Transaction Summary
=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove      96 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
memory alloc (4 bytes) returned NULL.

I followed this procedure :

wget http://www.atomicorp.com/installers/atomic.sh; sh atomic.sh

yum update php

(mv /etc/httpd/conf.d/php.conf.rpmnew /etc/httpd/conf.d/php.conf) = not performed to solve the first problem php-common dependency

service httpd restart

any suggestions?
Thank you in advance.

greetings
 
Old 04-15-2011, 04:48 AM   #2
fabio vinc
LQ Newbie
 
Registered: Apr 2011
Location: Italy,Turin
Distribution: Red Hat 3.4.5-2
Posts: 3

Original Poster
Rep: Reputation: 0
opps, I forgot
OS version

cat /etc/*release*

CentOS release 5 (Final)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum update PHP on CentOS - missing dependency php-common AndyMillne Linux - Server 7 05-21-2013 06:34 AM
Upgrade from PHP Version 4.3.9 to PHP 5.2 on CentOS nuttynibbles Linux - Software 10 06-15-2010 02:35 PM
Getting Error: Missing Dependency: php-common, when trying to install php-soap amish123 Linux - Software 3 02-18-2010 07:26 PM
PHP5 Upgrade Error: Missing Dependency: php = 4.3.x is needed by package php-pear vsystems Linux - Server 1 05-02-2007 07:17 AM


All times are GMT -5. The time now is 12:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration