LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-06-2003, 10:19 PM   #1
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Rep: Reputation: 15
Problem to connect the internet, Modem not found!


Hi!

I have some trouble making kppp work in kde.

On my laptop, the pcmia modem has been found but the tool bar will freeze after connection.

On my PC, the modem is not found. It has worked with another local version of Linux which was not that good and I have reinstalled red hat 9 over it. So I know that the modem works for linux. What can I do?

Also, how to give permission to access the internet to al users. A pop up keeps asking for root password for kppp.

Thanks for help.

Michel

 
Old 12-07-2003, 02:48 AM   #2
Scruff
Member
 
Registered: Oct 2002
Location: Stoughton, MA
Distribution: Gentoo x86_64 & PPC
Posts: 949

Rep: Reputation: 30
I dont really know anything about pcmia. On your PC, open a terminal and type: cat /proc/pci and post the output here. That should list the specific modem you are using so we know what driver you need for it.

Here is an interesting thread that deals with red hat. Both with kppp access as non-root user, and the modem not being detected. Check this out first http://www.linuxquestions.org/questi...pp+root+access
 
Old 12-09-2003, 09:56 AM   #3
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
Thank you for the link and info:

1) Concerning access of kppp from a user account I tried this first:
**********************************************
Change the following line in the file /etc/pam.d/kppp from:
auth sufficient /lib/security/pam_rootok.so
to:
auth sufficient /lib/security/pam_permit.so
*************************************************
It worked but it gave root permission to the user to use kppp but also everything else, a little bit risky so I did not keep it.

2) The second and best solution for me is below:
***********************************************
When connecting to the Internet using KPPP, it will ask you for root's user name and password. There are three problems with this.

You may not want to give root's password to regular users.

You don't want the inconvenience

After entering roots password, and connecting, your panel is dead. With kppp being a console helper program, no matter which options (dock on panel, etc) were selected, it would overlay roots panel on top of the regular users control panel, making it essentially useless.

Red Hat chose to install kppp as a so-called consolehelper application. This PAM based mechanism avoids a setuid root installation. A quick and dirty solution to revert to the original behavior is to delete the link to consolehelper and make the real binary setuid root. Open a terminal window, su to root and enter the following commands:

rm /usr/bin/kppp
chmod u+s /usr/sbin/kppp
ln -s /usr/sbin/kppp /usr/bin/kppp
********************************************************
After doing this, kppp is accessible from a user account with no popup for root password, the panel does not die and it works.

I am posting all the detail in case that this can help someone with the same problem.

Michel
 
Old 12-09-2003, 09:57 AM   #4
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
Concerning the modem not found,this is what I have after the command:

cat /proc/pci

*******************************************************************
PCI devices found:
Bus 0, device 0, function 0:
Host bridge: PCI device 8086:2560 (Intel Corp.) (rev 2).
Prefetchable 32 bit memory at 0xd0000000 [0xd7ffffff].
Bus 0, device 1, function 0:
PCI bridge: PCI device 8086:2561 (Intel Corp.) (rev 2).
Master Capable. Latency=64. Min Gnt=12.
Bus 0, device 29, function 0:
USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 2).
IRQ 5.
I/O at 0xd800 [0xd81f].
Bus 0, device 29, function 1:
USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 2).
IRQ 11.
I/O at 0xd000 [0xd01f].
Bus 0, device 29, function 2:
USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 2).
IRQ 9.
I/O at 0xd400 [0xd41f].
Bus 0, device 29, function 7:
USB Controller: Intel Corp. 82801DB USB EHCI Controller (rev 2).
IRQ 5.
Non-prefetchable 32 bit memory at 0xe4000000 [0xe40003ff].
Bus 0, device 30, function 0:
PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 130).
Master Capable. No bursts. Min Gnt=6.
Bus 0, device 31, function 0:
ISA bridge: Intel Corp. 82801DB ISA Bridge (LPC) (rev 2).
Bus 0, device 31, function 1:
IDE interface: Intel Corp. 82801DB IDE U100 (rev 2).
IRQ 9.
I/O at 0xf000 [0xf00f].
Non-prefetchable 32 bit memory at 0x10000000 [0x100003ff].
Bus 0, device 31, function 3:
SMBus: Intel Corp. 82801DB SMBus (rev 2).
IRQ 9.
I/O at 0x5000 [0x501f].
Bus 0, device 31, function 5:
Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio (rev 2).
IRQ 9.
I/O at 0xe000 [0xe0ff].
I/O at 0xe400 [0xe43f].
Non-prefetchable 32 bit memory at 0xe4001000 [0xe40011ff].
Non-prefetchable 32 bit memory at 0xe4002000 [0xe40020ff].
Bus 1, device 0, function 0:
VGA compatible controller: nVidia Corporation NV11 (GeForce2 MX) (rev 178).
IRQ 9.
Master Capable. Latency=32. Min Gnt=5.Max Lat=1.
Non-prefetchable 32 bit memory at 0xe0000000 [0xe0ffffff].
Prefetchable 32 bit memory at 0xd8000000 [0xdfffffff].
Bus 2, device 1, function 0:
Communication controller: Conexant HSF 56k HSFi Modem (rev 1).
IRQ 11.
Master Capable. Latency=32.
Non-prefetchable 32 bit memory at 0xe3000000 [0xe300ffff].
I/O at 0xc000 [0xc007].
Bus 2, device 2, function 0:
Ethernet controller: Davicom Semiconductor, Inc. Ethernet 100/10 MBit (rev 49).
IRQ 11.
Master Capable. Latency=32. Min Gnt=20.Max Lat=40.
I/O at 0xc400 [0xc4ff].
Non-prefetchable 32 bit memory at 0xe3010000 [0xe30100ff].

************************************************************

In the previous linux system I had in etc/modem point to a file: ttySHSF0. But I am not able to copy the shortcut and file to transfer it on the new system (I still have one computer working on theold system).

Thanks for help.

Michel
 
Old 12-09-2003, 07:58 PM   #5
Scruff
Member
 
Registered: Oct 2002
Location: Stoughton, MA
Distribution: Gentoo x86_64 & PPC
Posts: 949

Rep: Reputation: 30
Communication controller: Conexant HSF 56k HSFi Modem (rev 1).
IRQ 11.
Master Capable. Latency=32.
Non-prefetchable 32 bit memory at 0xe3000000 [0xe300ffff].
I/O at 0xc000 [0xc007].

Thats the info you need. Do 'lsmod' and post the output so we can see if any drivers are already loaded for that modem. If not, I saw plenty of sites that have a linux driver for that modem. Here's a good site I found about your modem: http://www.linuxant.com/drivers/hsf/...cb6ed711e9ea5a
 
Old 12-11-2003, 05:56 AM   #6
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
Hi!

Thank you for all your help Scruff,

I will do the 'lsmod' thing on staurday when I access the computer.

Right now I have a computer that still have the old linux distro and modem driver installed. Is there a way I can copy it on disk and install it on my other computer? I tried to do this but it would not copy properly.

I have also the original distro disks and I wonder if there is a way I can extract the modem driver ttySHSF0 from there? ... without installing the os of course.

Thank you.

Michel

 
Old 12-11-2003, 08:08 AM   #7
Scruff
Member
 
Registered: Oct 2002
Location: Stoughton, MA
Distribution: Gentoo x86_64 & PPC
Posts: 949

Rep: Reputation: 30
Quote:
Originally posted by gmichel
Right now I have a computer that still have the old linux distro and modem driver installed. Is there a way I can copy it on disk and install it on my other computer? I tried to do this but it would not copy properly.

I have also the original distro disks and I wonder if there is a way I can extract the modem driver ttySHSF0 from there? ... without installing the os of course.

Thank you.

Michel

You should really just download the RPM and install it with that, or if your comfortable you can compile it from source. But I think for a simple modem driver an RPM would do the trick nicely. When it installs, it will likely place several different files in different places, so that might be why copying it didn't work. You would also have had to tell it to load the driver with 'modprobe drivername' then set it up to load at boot. An RPM should take care of all this for you.

Whats the name of the driver that works for you?
 
Old 12-12-2003, 07:56 AM   #8
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
The modem driver is ttySHSF0

I know where to download it but the free version is only 14k. The 56k version is a paid version and I would like to be sure it works before buying.

 
Old 12-12-2003, 08:25 PM   #9
Scruff
Member
 
Registered: Oct 2002
Location: Stoughton, MA
Distribution: Gentoo x86_64 & PPC
Posts: 949

Rep: Reputation: 30
I see. I did a little searching, and it seems that others have had good luck with that driver and even link to the Linuxant site for obtaining the driver. http://mia.ece.uic.edu/~papers/volans/modem.html has decent instructions. I didn't see anywhere to get a free one either other than the 14.4k version you mentioned. However, if thats the route you're stuck with, you can be confident it will work from reading others success stories. Looks ok to me.
 
Old 12-13-2003, 09:05 PM   #10
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
Thank you Scruff for your help.

First of all I tested the computer and got this about the modem:

***************************************************
02:02.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
Subsystem: Conexant Dynalink 56PMi
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Step
ping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort
- <MAbort- >SERR- <PERR-
Latency: 32
Interrupt: pin A routed to IRQ 5
Region 0: Memory at e3000000 (32-bit, non-prefetchable) [size=64K]
Region 1: I/O ports at c000 [size=8]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot +,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
**********************************************************
That looks similar to the doc you directed me to.

I found on the disks of the previous Linux version this driver which was used and worked previously: hsflinmodem-5.03.27lnxtbeta03042700-1.i386.rpm

I tried an installation which appeared to start well but a problem occured at the end and the driver was not installed. Details of the commands:

**********************************************************

[root@localhost root]# rpm -ivh /root/Desktop/Linux Modem Driver Info/file:/root/Desktop/Linux Modem Driver Info/hsflinmodem-5.03.27lnxtbeta03042700-1.i386.rpm
error: open of /root/Desktop/Linux failed: No such file or directory
error: open of Modem failed: No such file or directory
error: open of Driver failed: No such file or directory
error: open of Info/file:/root/Desktop/Linux failed: No such file or directory
error: open of Modem failed: No such file or directory
error: open of Driver failed: No such file or directory
error: open of Info/hsflinmodem-5.03.27lnxtbeta03042700-1.i386.rpm failed: No such file or directory
[root@localhost root]# rpm -ivh /opt/hsflinmodem-5.03.27lnxtbeta03042700-1.i386.rpm
warning: /opt/hsflinmodem-5.03.27lnxtbeta03042700-1.i386.rpm: V3 DSA signature: NOKEY, key ID d965cc6b
Preparing... ########################################### [100%]
1:hsflinmodem ########################################### [100%]
To complete the installation and configuration of your HSF modem,
please run "hsfconfig" (or "/usr/sbin/hsfconfig")
[root@localhost root]# hsfconfig
Linux HSF softmodem drivers, version 5.03.27lnxtbeta03042700

WARNING: this is an EXPERIMENTAL BETA VERSION of the HSF drivers for Linux.
USE AT YOUR OWN RISK! See the file /usr/lib/hsf/LICENSE for details.

Conexant Systems neither distributes nor maintains this package.
PLEASE DO NOT CONTACT CONEXANT REGARDING THIS SOFTWARE!!!

If you require assistance or need more information, go to:
http://www.linuxant.com/drivers

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

Should we attempt to automatically configure your hardware? [yes] y

Selected PCI VendorID=14F1 DeviceID=2F00
and INF file /etc/hsf/inf/linux_hsfi.inf

Automatically guessed country (using timezone): "THAILAND"

Configuring modem for country: "THAILAND"
You can change this setting later with the command "hsfconfig --country"

This package does not contain pre-built modules suitable for your system:
Distribution: RedHat-9
Kernel arch: i686
Kernel version: linux-2.4.20-8

Trying to automatically re-compile the modules..
(this requires a C compiler and proper kernel sources to be installed)

Where is the linux source build directory that matches your running kernel?
[/lib/modules/2.4.20-8/build] exit

WARNING: missing file exit/include/linux/autoconf.h
The cause of this problem is usually a missing or misconfigured
kernel source tree (and sometimes an incorrect directory or symbolic link).

First, ensure that the proper kernel source and compiler packages
from your distribution vendor and/or the community are installed.

The Linux kernel can then be reconfigured by running "make menuconfig"
under the kernel source directory (usually /usr/src/linux).

Verify that the proper options for your system are selected,
and that CONFIG_SMP ("Symmetric multi-processing support" under
"Processor type and features") is disabled, as this driver is
presently designed to work on single-processor machines.

Then compile and install your new kernel (for more information about
this procedure, see the README file under the kernel source directory),
reboot the system using the new kernel, and re-run "hsfconfig".
[root@localhost root]#

***********************************************************
I do not understand what I have to do to fix the last part. Maybe a kernel problem between the old version of Linux and Red Hat 9 !!

I tried then to download the free version of the driver on the link you gave me (from Windows). After transfering the files to Linux the files have an extension of .rpm.zip . Installation did not work because it says it's not a valid RPM file. When I rename to get rid of the .zip , this says the same...

Well, no success for this time.

Thank you for any suggestion.

Michel

 
Old 12-13-2003, 09:18 PM   #11
Scruff
Member
 
Registered: Oct 2002
Location: Stoughton, MA
Distribution: Gentoo x86_64 & PPC
Posts: 949

Rep: Reputation: 30
First, you might try 'unzip filename.rpm.zip' to turn it into a straight .rpm and see if the newly downloaded file will work. It just might, and that would be the easiest route. Otherwise, it appears as if the install was prepared to compile itself for you when it asked for:
Where is the linux source build directory that matches your running kernel?
[/lib/modules/2.4.20-8/build] exit
and you typed exit there. Verify that /lib/modules/2.4.20-8/build exists on your system, then if you need to use that old rpm again, just hit enter when it gets to that point. If that directory does not exist, then you need to find out where your build directory is; usually /lib/modules/<kernel version here>/build and enter that path when prompted.

Give those a try and let me know how it goes
 
Old 12-14-2003, 04:52 AM   #12
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
Check out this thread. This is how I got my HSF modem to work and it includes a link to the older modem driver (in tar.gz format) which is not speed locked to 14.4k.

Baldrick
 
Old 12-17-2003, 12:43 AM   #13
vinjacob
LQ Newbie
 
Registered: Nov 2003
Distribution: suse 9
Posts: 2

Rep: Reputation: 0
On the same issue, I have a Presario 2540EA, with a connexant modem. I did get the Linuxant driver, it installed correctly, although Suse9 could not connect to the net via modem, I did get kppp to work on 2.4.19. Ever since I updated to 2.4.21-144-default, I have been having problems connecting to the net. (except via ethernet). Tried wvdial, ppp shell scripts, terminal, xplog, kppp and more. Well kppp now disconnects immediately with a pppd error 2, /var/log says invalid option pass to pppd passwordfd.so.
Terminal via kppp prompts me for user name and password from the isp, but I get the response authentication failed. The user name and password are valid as I can log on to the isp's site with the same password. I tried pap,chap and terminal.
Could there be some format that certain isp's look for in the user name and password which is oblivious to users on windows? As I did not have any problems with this isp since win 3.1 right upto 2.4.19 with kpp suse 9. Or am I looking in the wrong black hole?
btw, I have checked the man pages for ppp and kppp and could not deactivate the passwordfd option being passed to ppp yet. I even reach the password propt only via terminal or wvdial or ppp script. All else fails.
I have #'d out all the lines in all the files /etc that had the passwordfd line. my options files is empty. have tried distro independant versions of kppp, ppp, and wvdial. nothing on the suse site either. tried enough boolean searches on google too.
any clues guys? btw I am a newbie so kindly keep it in laymen terms.
thanks and cheers
Vin
 
Old 12-20-2003, 10:39 AM   #14
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
I tried to fix the problem but without any sucess.

In the directory /lib/modules/2.4.20-8/ there is a file named "build", its icon looks like a lock-shortcut and the properties say that the file does not exist. Installation fails as usual.

I tried to create a directory "build" but a popup message says: </lib/modules/2.4.20-8/build is a file, but a directory is expected.>

I moved the build shortcut elsewere and created a new directory "build" hoping installation would work but it failed again...

There are also scary notes like asking for recompiling the kernel and so on... This is with the old previous driver.

I haven't tried the second version of the driver.

Any suggestion?

Thanks.

Michel

 
Old 01-01-2004, 05:45 AM   #15
gmichel
Member
 
Registered: Aug 2003
Location: Bangkok
Distribution: Red Hat 9
Posts: 56

Original Poster
Rep: Reputation: 15
Hi!

After trying many time with the old and new driver (tar version) still no success.
It seemed to work with the tar version but at the end it says the same thing that there is a problem with the kernel and I have to recompile!!!

Scary...

I do not know what to do...

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to internet with my modem Ignorant_User Linux - Newbie 1 10-22-2004 02:15 PM
cannot connect to the internet with modem shams Linux - Software 2 03-26-2004 11:13 PM
can't connect to the internet via modem shams Linux - Software 3 03-18-2004 12:06 AM
problem to set up internet connect through modem using Suse 8.2 ywxf Linux - General 3 06-03-2003 07:08 PM
how do I connect to the Internet with a modem? slice4e Linux - General 2 05-09-2003 11:21 PM


All times are GMT -5. The time now is 02:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration