LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-02-2001, 04:47 AM   #1
kutubjt
LQ Newbie
 
Registered: Mar 2001
Location: Dubai - UAE
Posts: 5

Rep: Reputation: 0
Question


Hi
I have apache web server on linux redhat 6.2 on an
i386 m/c.
I have following rpm packages installed on my system
- apache-1.3.12-2
- ActivePerl-5.6.0.623
- mod_perl-1.24_01-1

When i try to start httpd it gives me following error
cannot load /etc/httpd/modules/libperl.so into server
libperl.so cannot open shared object file No such file
or directory

In my httpd.conf file following lines are there
.
.
.
.
LoadModule mod_perl modules/libperl.so
.
.
.
AddModule mod_perl.c
.
.
.
.

I checked etc/httpd/conf/libperl.so
it does exist.
Please help me to solve this problem.

Thank you.
Kind regards
 
Old 04-02-2001, 03:19 PM   #2
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 11,957

Rep: Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113Reputation: 3113
Make sure /etc/httpd/modules/libperl.so exists (you said /etc/httpd/conf/libperl.so).
 
Old 04-04-2001, 01:31 AM   #3
kutubjt
LQ Newbie
 
Registered: Mar 2001
Location: Dubai - UAE
Posts: 5

Original Poster
Rep: Reputation: 0
Smile

Yeah, i made a mistake in the message. /etc/httpd/modules/libperl.so exists.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem starting web server from rc.local juanb Linux - General 2 10-13-2005 09:56 AM
apache server starting problem ukrainet Linux - Newbie 6 12-02-2004 02:30 AM
setting up password protected web forms on an apache web server AZDAVE Linux - Security 3 07-07-2004 01:03 PM
Starting Apache web server automatically gslater Linux - Newbie 4 05-09-2004 02:44 PM
Apache Web server problem!!!!! yenonn Linux - Networking 1 04-17-2004 01:51 AM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration