LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2010, 03:32 AM   #1
thewhiteeye
LQ Newbie
 
Registered: Jul 2009
Posts: 10

Rep: Reputation: 0
Smile Problem setting QUOTA


Hi I would like to set quota on my system.
Following is the contents of 'fstab' file

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0

The following is the output of df command
[root@SGKPC ~]# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
149280940 108553772 33021776 77% /
/dev/sda1 101086 22107 73760 24% /boot
tmpfs 1032468 0 1032468 0% /dev/shm
[root@SGKPC ~]#

Plz guide me regarding this issue
Also a brief outline about Quotas would also help


Thanks
 
Old 03-12-2010, 04:47 AM   #2
Sayan Acharjee
Member
 
Registered: Feb 2010
Location: Chennai, India
Distribution: Manjaro
Posts: 616

Rep: Reputation: 64
Cool

Quote:
Originally Posted by thewhiteeye View Post
Hi I would like to set quota on my system.
Following is the contents of 'fstab' file

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0

The following is the output of df command
[root@SGKPC ~]# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
149280940 108553772 33021776 77% /
/dev/sda1 101086 22107 73760 24% /boot
tmpfs 1032468 0 1032468 0% /dev/shm
[root@SGKPC ~]#

Plz guide me regarding this issue
Also a brief outline about Quotas would also help


Thanks
hope this will help:
http://www.redhat.com/docs/manuals/l...sk-quotas.html
 
Old 03-12-2010, 05:21 AM   #3
arashi256
Member
 
Registered: Jan 2008
Location: Brighton, UK
Distribution: Ubuntu 12.04 / CentOS 6.5
Posts: 394

Rep: Reputation: 61
As posted elsewhere here. A site search would have pulled it up. A google search would have probably done the same.

Well, I'm primarily going through this to see if I've got it right myself (as I'm sure someone else will correct me if I'm wrong at any point), but really - you should at least make the pretense of having put some effort in yourself...

This assumes a RedHat system, if you're using something else, this will at least get you started.

1. Check that quotas have been set up in the default kernel on your system.

# grep CONFIG_QUOTA /boot/config-`uname -r`

Check that the return is "CONFIG_QUOTA=y"

2. Check that the quota package is installed.

# rpm -qi quota

3. Assuming yes, add quotas to appropriate areas in /etc/fstab - I'll assume /home on the second drive using ext3.

/dev/sdb1 /home ext3 exec,dev,suid,rw,grpquota 1 2

4. Create quota files (done automatically these days, I think) by remounting the selected filesystem and activating quotas.

# mount -o remount /home
# quotacheck -cgm /home

c - performs a new scan.
g - scans for group quotas.
m - remounts the scanned filesystem.

Once the command is run, you should be able to find the "aquota.group" file in the configured directory.

5. Run the "edquota" command to specify quotas for a particular group.

# edquota -g <group>

Differences between soft and hard limits can be found out from Google

6. Save the file.

8. Add a "quotacheck" command to your /etc/crontab to check for quota limits periodically.


...I think that's it - if I'm wrong, I'm sure somebody will post corrections.
 
Old 03-13-2010, 12:31 AM   #4
thewhiteeye
LQ Newbie
 
Registered: Jul 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by arashi256 View Post
As posted elsewhere here. A site search would have pulled it up. A google search would have probably done the same.

Well, I'm primarily going through this to see if I've got it right myself (as I'm sure someone else will correct me if I'm wrong at any point), but really - you should at least make the pretense of having put some effort in yourself...

This assumes a RedHat system, if you're using something else, this will at least get you started.

1. Check that quotas have been set up in the default kernel on your system.

# grep CONFIG_QUOTA /boot/config-`uname -r`

Check that the return is "CONFIG_QUOTA=y"

2. Check that the quota package is installed.

# rpm -qi quota

3. Assuming yes, add quotas to appropriate areas in /etc/fstab - I'll assume /home on the second drive using ext3.

/dev/sdb1 /home ext3 exec,dev,suid,rw,grpquota 1 2

4. Create quota files (done automatically these days, I think) by remounting the selected filesystem and activating quotas.

# mount -o remount /home
# quotacheck -cgm /home

c - performs a new scan.
g - scans for group quotas.
m - remounts the scanned filesystem.

Once the command is run, you should be able to find the "aquota.group" file in the configured directory.

5. Run the "edquota" command to specify quotas for a particular group.

# edquota -g <group>

Differences between soft and hard limits can be found out from Google

6. Save the file.

8. Add a "quotacheck" command to your /etc/crontab to check for quota limits periodically.


...I think that's it - if I'm wrong, I'm sure somebody will post corrections.


I gave the output of the file bcoz i could not find the /home partition in /etc/fstab and the process requires editing the /hpme entry
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Facing problem while setting user's quota on the nfs mounted folder . ilu_nishant Linux - Newbie 2 09-21-2009 07:25 PM
quick quota setting? davidstvz Linux - Newbie 7 04-17-2009 05:33 PM
Problem setting user quota noelcantona Linux - General 0 12-06-2004 02:32 AM
Setting disk quota ray5_83 Linux - General 1 08-09-2004 05:57 AM
Setting a user quota SMB3Master Linux - General 8 08-26-2003 06:44 PM


All times are GMT -5. The time now is 04:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration