LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2016, 08:34 AM   #1
chris_crunch
Member
 
Registered: Jan 2016
Location: Braintree, Essex
Distribution: Ubuntu 14.04
Posts: 107

Rep: Reputation: Disabled
Problem running a .py file


I'm trying to execute a python script from the command line, the file name is "download_model_binary.py". I've been told via google browsing to execute/run it, I just type

Code:
python download_model_binary.py
However I'm getting this error message
Code:
chris@chris-crunch:~/apps/caffe-master/scripts$ python download_model_binary.py 
usage: download_model_binary.py [-h] dirname
download_model_binary.py: error: too few arguments
So I'm assuming my codes wrong, but I can't find out why...
 
Old 02-10-2016, 08:36 AM   #2
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,051

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
not sure what the program does but it seems to be complaining that you are not telling it what directory you want it to do something with ?
 
1 members found this post helpful.
Old 02-10-2016, 08:40 AM   #3
chris_crunch
Member
 
Registered: Jan 2016
Location: Braintree, Essex
Distribution: Ubuntu 14.04
Posts: 107

Original Poster
Rep: Reputation: Disabled
Aha, never mind I was being completely stupid and copy-pasted half a command wrong. (facepalm) Good spot...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problem running a javascript file? Ajit Gunge Programming 7 06-07-2012 02:09 AM
Jar file running problem netpumber Slackware 1 01-28-2009 12:42 PM
problem running a .sh file laney69er Linux - Newbie 2 02-18-2006 12:40 PM
Please help!! Problem on running execute file!! mkwong107 Linux - General 11 10-20-2003 06:59 PM
Please help!! Problem on running execute file!! mkwong107 Linux - General 0 10-20-2003 05:21 PM


All times are GMT -5. The time now is 07:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration