LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2010, 02:26 PM   #1
Krosty
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Rep: Reputation: 0
Problem playing original music cds.


Hi everyone.
I have the a problem playing original cds music in backtrack4.
The problem is that, i can play everything, like mp3 from my hdd or a cd of mp3 files, but when y try with one of my buyed cd's it doesnt work.
I have tried with lot of players like vlc, amarok, audacious, smplayer and ksdc.
The nearest i ve stayed to play it, was with smplayer putting in "device": "/dev/scd0" it ve started to play the first song but with breaks, then i stopped the player, and since that moment i could never make the cd run again.
Now i have try with kscd, when i put in device: "/dev/scd0" and i call the command from the konsole it says:

Quote:
QWidget::setProperty( "text", value ) failed: property invalid, read-only or does not exist
And then the player starts, it shows ALL the cd tracks, with their number track and duration but when i click on "play" nothing happens it stays in "00:00 Unknown Artist - Unknown Title". The strange is that the software recognize all the songs but it is impossible for him to run the songs xD
I also have tried to change the route device for /media/cdrom /dev/cdrom but i have the same problem.
Can anybody help me ?

Last edited by Krosty; 09-10-2010 at 05:29 PM.
 
Old 09-10-2010, 03:54 PM   #2
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778
First, would you please edit your post and remove the swear word. It goes against policy and you post will likely be deleted if you don't.

It sounds like you may have a flaky CD drive. If the MP3 disks are ones you created, if the drive is out of alignment, it would likely still read one written by it, but may have trouble with commercial disks. Here are some suggestions to try and questions for you:

Do you have this same problem with non music, ie data disks? Have you tried copying the files off of the CD and onto your hard drive first? Can you boot the PC into Windows and see if it will read the CDs?
 
Old 09-10-2010, 05:32 PM   #3
Krosty
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Sory, y just edited the text.

Answering you, i dont have problem with other cds, i also try copying the files (there are lot of folders of the songs in diferent formats, in windows only appears .cda) from the cd to the desktop, and when y click play, i only can hear a disstorsion all along the song.
And in windows the cds go well, no problem.
Thanks
 
Old 09-10-2010, 07:55 PM   #4
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778
Hmmm, I wonder if the problem is the file format: .cda. I did a look up on it and it seems quite interesting. Apparently it isn't a music file like a .wav and it doesn't contain all the information of the music and can't be stored on a hard drive or played directly. Nor can it apparently be played on anything other than a "cd-rom" player(?) and it needs to be converted to another format to play on anything else. See the following: http://www.coolutils.com/Formats/CDA
 
Old 09-10-2010, 08:07 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Hi, welcome to LQ!


Quote:
And then the player starts, it shows ALL the cd tracks, with their number track and duration but when i click on "play" nothing happens it stays in "00:00 Unknown Artist - Unknown Title". The strange is that the software recognize all the songs but it is impossible for him to run the songs xD
I also have tried to change the route device for /media/cdrom /dev/cdrom but i have the same problem.
Now ... I don't use kscd, but ...

One thing to check: permissions and ownerships on the cd-device
and the mount-point. Can you please post
Code:
id -a
ls -lL /dev/cdrom
ls -lL /media/cdrom
And (should there be the problem of "playing" w/o music):
A common problem these days is that there's no analog connection
between the CD drive and the sound-card (little flimsy cable).

In those cases people have to resort to "digital extraction",
which means that the CD-ROM doesn't play the track, but that
the software has to. Check whether kscd has a feature/setting
called something like that (digital ...) and enable it.



Cheers,
Tink
 
Old 09-11-2010, 12:14 AM   #6
Krosty
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Well here are the things:


Quote:
mauri@PC-X ~$ id -a
uid=1002(mauri) gid=1002(mauri) groups=0(root),1002(mauri)
mauri@PC-X ~$ ls -lL /dev/cdrom
ls: cannot access /dev/cdrom: No such file or directory
mauri@PC-X ~$ ls -lL /media/cdrom
total 0
Quote:
And (should there be the problem of "playing" w/o music):
A common problem these days is that there's no analog connection
between the CD drive and the sound-card (little flimsy cable).

In those cases people have to resort to "digital extraction",
which means that the CD-ROM doesn't play the track, but that
the software has to. Check whether kscd has a feature/setting
called something like that (digital ...) and enable it.
Yeah i know that, so i tried to put the wire, but my cd-rom doesnt have that option.
I also 've tried to enable the digital audio: and when i enable this the programa shows:

Quote:
CD-ROM read or access error (or no audio disc in drive).
Please make sure you have access permissions to:
/media/sd0
And the same error if i change for /dev/cdrom /media/cdrom /dev/sd0 etc..

Thanks
 
Old 09-11-2010, 12:41 AM   #7
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 56
Quote:
Originally Posted by Krosty View Post
Code:
mauri@PC-X ~$ ls -lL /dev/cdrom
ls: cannot access /dev/cdrom: No such file or directory
There's your problem right there:

Code:
mknod /dev/cdrom
will fix it.
 
Old 09-11-2010, 01:21 AM   #8
Krosty
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
It shows this:
Quote:
mknod /dev/cdrom
mknod: missing operand after `/dev/cdrom'
Try `mknod --help' for more information.
 
Old 09-11-2010, 05:30 AM   #9
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778
This is starting to sound like it might be a driver issue.

As a reference see this thread: http://ubuntuforums.org/archive/index.php/t-282913.html
I don't know what distribution your running but the little flag on your post says ubuntu, so I will assume that is the case. Anway, the executive summary of that thread is that there is a sometimes a conflict with this thing called an APIC controller that can cause issues with CD drives. One easy thing to try would be to add noaipc acpi=off to the end of the line in your grub.conf that looks like kernel /boot/vmlinuz-2.6. See the bottom of the thread for details.

If that doesn't work, you may need to take a look at some other things like what is in the dmesg log for the device and see what is in fstab.
 
Old 09-11-2010, 10:40 AM   #10
Krosty
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks to all of you, i finally did it.
I enter to amarok, and went to "engine" i put in "output extension" OSS (i have alsa, but it didnt work xD) then in configuration oc CD i put "/dev/cdrw3". When i put a cd i cant make it go with the pop window beacuse it changes me automatically cdrw3 to cdrom and with that path the player cant find anything, so i put the cd, go to "action / play audio cd" and thats all :P

Thanks
 
Old 09-11-2010, 10:48 AM   #11
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 56
Try making /dev/cdrom a symlink to /dev/cdrw3, like so:

Code:
ln -s /dev/cdrom /dev/cdrw3
This will ensure that the player finds it.
 
0 members found this post helpful.
Old 09-11-2010, 01:20 PM   #12
Krosty
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
It shows:
Quote:
ln: creating symbolic link `/dev/cdrw3': File exists
 
Old 09-11-2010, 05:50 PM   #13
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by Kenny_Strawn View Post
Try making /dev/cdrom a symlink to /dev/cdrw3, like so:

Code:
ln -s /dev/cdrom /dev/cdrw3
This will ensure that the player finds it.
That's actually the other way around ...
Code:
ln -s /dev/cdrw3 /dev/cdrom


Cheers,
Tink
 
Old 09-11-2010, 05:55 PM   #14
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Sorry for the delayed response: what you want/need to do is
to symlink the device that your machine recognises as the
CD-ROM (check the output of dmesg for it) to /dev/cdrom

Code:
dmesg | grep -E "(CD|DVD)-R[AO]M"
In my case the result is
Code:
$ dmesg | grep -E "(CD|DVD)-R[AO]M"
ata2.00: ATAPI: MATSHITADVD-RAM UJ880A, SB05, max UDMA/33, ATAPI AN
scsi 1:0:0:0: CD-ROM            MATSHITA DVD-RAM UJ880A   SB05 PQ: 0 ANSI: 5
Uniform CD-ROM driver Revision: 3.20
sr 1:0:0:0: Attached scsi CD-ROM sr0
and the device to be linked is sr0. So:
Code:
ln -s /dev/sr0 /dev/cdrom

I am, however, somewhat surprised that your distro
didn't already do that via udev rules in the first place.



Cheers,
Tink
 
Old 09-11-2010, 10:10 PM   #15
Krosty
LQ Newbie
 
Registered: Sep 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Yeah !!
Now it runs perfect
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem playing cds alaios Linux - Software 4 01-27-2006 06:13 AM
Playing music CDs hitest Slackware 21 10-03-2005 04:57 PM
playing music cds through scsi emulation ergo_sum Linux - Newbie 3 11-05-2003 12:06 PM
CDs not playing music thom Linux - Distributions 4 10-30-2003 11:53 PM
playing music cds ergo_sum Linux - Newbie 3 10-21-2003 11:41 AM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration