LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-21-2003, 08:19 AM   #1
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Rep: Reputation: 0
Exclamation problem mplayer


i'm new with linux .
this is the first time i compile a program ..

could you all explain on how to install mplayer .

i have download

MPlayer-1.0pre1.tar
mplayer-gui-0.91-2.i386

can u xplain on how to install those two thing .
 
Old 09-21-2003, 09:25 AM   #2
sidey
Member
 
Registered: Mar 2003
Location: Essex UK
Distribution: rh 8.0 bsd 5.0 slack 9.0 rc2 crux
Posts: 147

Rep: Reputation: 15
tar xvf Mplayer.blah.tar cd <directory>/ ./configure ; make ; make install tar xvf Mplayer.gui and as above
 
Old 09-21-2003, 09:37 AM   #3
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Well, you will need much more than that. You will need to also download the codecs. If you compile mplayer without codecs you will get nothing but a black screen. For informations installing mplayer, read the documentation carefully or you won't make it right:

http://www.mplayerhq.hu/DOCS/en/documentation.html

I can see you don't have much experience with Linux either, so read this thread as well about installing programs:

http://www.linuxquestions.org/questi...threadid=45094

It's a huge learning curve within Linux and that includes a lot of reading

Good luck!
 
Old 09-21-2003, 09:41 AM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Just a little add. Always give informations about which Linux distro you are using. That is helpful because:

1 - Some distros as Mandrake 9.1 is shipped with mplayer. Just look after mplayer into your CD's...
2 - Some distros as Redhat/Debian/Connectiva has easier ways to install mplayer (you install all with one command, apt-get install mplayer)
3 - Some distros also have some pre-compiled packages, so you don't have to compile it from source.

Regards

Last edited by Mega Man X; 09-21-2003 at 09:43 AM.
 
Old 09-21-2003, 10:36 AM   #5
coldy
Member
 
Registered: Nov 2002
Distribution: Debian GNU/Linux, Gentoo
Posts: 75

Rep: Reputation: 15
I don't know what is these tarballs and packages that I've been downloaded but I suggest you to get the latest tarball from http://www.mplayerhq.hu/homepage/design6/dload.html.
The right way to ask question is to tell others what distribution you're using.

I suggest you to use --enable-gui option during ./configure

look here

Edit: I am sorry that my post is "the same" like Megaman X's. I've been writen it and have some work to do, after that I click on "Submit" button. I'm sorry

Last edited by coldy; 09-21-2003 at 10:44 AM.
 
Old 09-21-2003, 11:51 AM   #6
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Original Poster
Rep: Reputation: 0
actually i using redhat9
i have done the step ..

./configure
make
make install

but i still can play the movie

so i try install the rpm package that i state above

but it have the error ..

package not found
mplayer-skin
mplayer-common=0.91

what shoould i do now
 
Old 09-21-2003, 12:09 PM   #7
coldy
Member
 
Registered: Nov 2002
Distribution: Debian GNU/Linux, Gentoo
Posts: 75

Rep: Reputation: 15
Quote:
Originally posted by amuarica
actually i using redhat9
i have done the step ..

./configure
make
make install

but i still can play the movie
here you need to configure MPlayer with --enable-gui
Code:
#./configure --enable-gui
and you need codecs to run the movie

Quote:
so i try install the rpm package that i state above

but it have the error ..

package not found
mplayer-skin
mplayer-common=0.91

what shoould i do now
I suppose the easyest way to install some package is to use apt-get for RedHat http://apt.freshrpms.net/

Look this post http://www.linuxquestions.org/questi...threadid=95119 and http://www.linuxquestions.org/questi...threadid=95146 and be sure, that you were installed mplayer with all dependencies

Nice try is to look in apt cache what is containing "mplayer", so type in the console
Code:
#apt-cache search mplayer
and there are the skins, mplayer-common and if I remember right some codecs for it, but
 
Old 09-21-2003, 12:44 PM   #8
amuarica
LQ Newbie
 
Registered: Sep 2003
Location: malaysia
Posts: 19

Original Poster
Rep: Reputation: 0
i have done
./configure --enable-gui

after that should i recompile that mplayer

could u explain about apt

for your information , i dont have any internet connection to connect into my redhat
 
Old 09-21-2003, 01:07 PM   #9
coldy
Member
 
Registered: Nov 2002
Distribution: Debian GNU/Linux, Gentoo
Posts: 75

Rep: Reputation: 15
when you configure with --enable-gui and install MPlayer, try to run in console gmplayer but I'm not sure if it will work. When I installed Red Hat 9.0 in office, I used apt-get to install mplayer. So install apt-get from http://apt.freshrpms.net (download the rpm and install it) and, but I'm not sure if it depends than, after apt-get is installed on your PC, do
Code:
#apt-get update
than
Code:
#apt-cache search mplayer
and look the packages that contain MPlayer (I mean all mplayer* packages) than you can just type
Code:
#apt-get install mplayer mplayer-skins mplayer-fonts libpostproc
that's all that I remember
I am not sure for the name of last package "libpostproc"

nice try is to read docs about apt-get (man apt, man apt-get)
 
Old 09-21-2003, 01:45 PM   #10
PIayer
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat
Posts: 21

Rep: Reputation: 15
Ok I just installed MPlayer yesterday with out compiling it these are the three rpms I used, and I installed all at once.

http://ftp.falsehope.com/home/rathan....91-2.i386.rpm
http://ftp.falsehope.com/home/rathan....91-2.i386.rpm
http://ftp.falsehope.com/home/rathan...0-2.noarch.rpm

Then the install went like this:
INSTALL (ONE LINE)

rpm -Uvh mplayer-common-0.91-2.i386.rpm mplayer-gui-0.91-2.i386.rpm mplayer-skin-default-1.0-2.noarch.rpm


GL I hope it works out for ya
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer problem saipraveen Linux - Newbie 10 06-14-2005 12:56 AM
yet another MPlayer problem raffi Slackware 5 01-13-2005 04:19 PM
mplayer problem cool_ashwin22 Fedora 0 10-20-2004 10:50 AM
Mplayer Problem. Itsu Linux - Software 5 02-02-2004 10:27 PM
MPlayer Problem #1 Micro420 Linux - Software 9 09-12-2003 05:54 PM


All times are GMT -5. The time now is 09:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration