LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-27-2014, 08:30 PM   #1
cryan
Member
 
Registered: Jan 2014
Posts: 33

Rep: Reputation: Disabled
Problem mounting network raid drive in Ubuntu


Hello everyone.

I'm attempting my first-ever mount in Linux (Ubuntu 12), specifically a network raid drive that contains a photo archive that I want to access with a photo management/editing program.

The drive is accessible through the file manager at the location smb://mybookliveduo/public/PhotoArchive, and I can properly see the files using the Linux machine.

I *think* the command I am looking for is: sudo mount -t cifs //mybookliveduo/public/PhotoArchive /mnt/NetworkPhotoArchive

But I'm getting the following errors. I'd appreciate it if someone could point me in the right direction. Thanks much!

Code:
christopher@Heidi:/mnt$ sudo mount -t cifs //mybookliveduo/public/PhotoArchive /mnt/NetworkPhotoArchive
mount: wrong fs type, bad option, bad superblock on //mybookliveduo/public/PhotoArchive,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

christopher@Heidi:/mnt$ sudo mount.cifs -t cifs //mybookliveduo/public/PhotoArchive /mnt/NetworkPhotoArchive
sudo: mount.cifs: command not found
christopher@Heidi:/mnt$ sudo /sbin/mount.cifs -t cifs //mybookliveduo/public/PhotoArchive /mnt/NetworkPhotoArchive
sudo: /sbin/mount.cifs: command not found
christopher@Heidi:/mnt$
 
Old 01-27-2014, 08:45 PM   #2
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 323

Rep: Reputation: 72
usually smb shares are in form //<server>/<share>, you can see what network shares you can access by "smbtree" command (it scans all your network)
 
Old 01-27-2014, 09:06 PM   #3
cryan
Member
 
Registered: Jan 2014
Posts: 33

Original Poster
Rep: Reputation: Disabled
Thanks, gengisdave.

I ran smbtree and get these results:

Code:
christopher@Heidi:/mnt$ smbtree
Enter christopher's password: 
WORKGROUP
	\\MYBOOKLIVEDUO  		My Book Live Duo Personal Cloud Storage
		\\MYBOOKLIVEDUO\IPC$           	IPC Service (My Book Live Duo Personal Cloud Storage)
		\\MYBOOKLIVEDUO\Public         	Public Share
	\\MYBOOKLIVE     		My Book Live Network Storage
		\\MYBOOKLIVE\IPC$           	IPC Service (My Book Live Network Storage)
		\\MYBOOKLIVE\Public         	Public Share
	\\MEDIASERVER    		
	\\LKGA62336      		
		\\LKGA62336\ADMIN$         	IPC Service ()
		\\LKGA62336\IPC$           	IPC Service ()
		\\LKGA62336\HDD_2_1_1      	For everyone
		\\LKGA62336\HDD_1_1_1      	For everyone
	\\IOMEGA-0059AD  		Iomega Network Hard Drive
	\\FON_5922_N     		Netbios-Arada 0.9.10
	\\ELLE           		
FUTUREOFNEWS
Since the exact reference to the share on the raid drive is "\\MYBOOKLIVEDUO\Public", I tried the following command using that exact reference, but still got the same error.

Code:
christopher@Heidi:/mnt$ sudo mount -t cifs \\MYBOOKLIVEDUO\Public /mnt/NetworkPhotoArchive
mount: wrong fs type, bad option, bad superblock on \MYBOOKLIVEDUOPublic,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
I looked at the properties of the directory /mnt/NetworkPhotoArchive and saw a message saying the directory name was too long. So I deleted the directory and created /mnt/PhotoArch. I've tried using both forward-slashes and backward-slashes, but still get the error about the wrong fs type...
 
Old 01-27-2014, 09:13 PM   #4
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 323

Rep: Reputation: 72
do you have cifs utils installed? something like "apt-get install cifs-utils" or "apt-get install cifs" or "apt-get install smbfs", don't know exactly the package name

EDIT : "cat /proc/filesystems | grep cifs" should show if fs is supported, but i'm not totally sure about it

Last edited by gengisdave; 01-27-2014 at 09:15 PM.
 
Old 01-27-2014, 09:50 PM   #5
cryan
Member
 
Registered: Jan 2014
Posts: 33

Original Poster
Rep: Reputation: Disabled
I ran sudo apt-get install cifs-utils, and it either installed or re-installed. I also ran "cat /proc/filesystems | grep cifs", but just got the command prompt, with no other response.

Interestingly, the error response changed when I re-tried the mount command (I tried it with both backwards and forwards slashes).

Code:
christopher@Heidi:~$ cat /proc/filesystems | grep cifs
christopher@Heidi:~$ sudo mount -t cifs \\MYBOOKLIVEDUO\Public /mnt/PhotoArch
mount.cifs: bad UNC (\MYBOOKLIVEDUOPublic)
christopher@Heidi:~$ sudo mount -t cifs //MYBOOKLIVEDUO/Public /mnt/PhotoArch
mount error: could not resolve address for MYBOOKLIVEDUO: Unknown error
christopher@Heidi:~$
\\MYBOOKLIVEDUO\Public is definitely what's listed in the response to the smbtree command, and it is still visible and accessible in the Nautilis file manager. Mystery...

Last edited by cryan; 01-27-2014 at 10:26 PM. Reason: fixed typo
 
Old 01-28-2014, 12:49 AM   #6
cryan
Member
 
Registered: Jan 2014
Posts: 33

Original Poster
Rep: Reputation: Disabled
Aha! The Western Digital MyBookLiveDuo does not officially support Linux, but it can be accessed by the local network IP address -- just not the //MYBOOKLIVEDUO name. After changing that to the IP address, it successfully mounted.

Thanks!
 
Old 01-28-2014, 01:43 AM   #7
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 323

Rep: Reputation: 72
glad it works probably you have no association in your linux between your hd ip and its netbios name, "cat /etc/hosts" to see all this associations, this is mine:
Code:
#
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.  Just add the names, addresses
#               and any aliases to this file...
#
# By the way, Arnt Gulbrandsen <agulbra@nvg.unit.no> says that 127.0.0.1
# should NEVER be named with the name of the machine.  It causes problems
# for some (stupid) programs, irc and reputedly talk. :^)
#

# For loopbacking.
127.0.0.1               localhost
192.168.1.2             tachi
192.168.1.3             batou
192.168.1.9             motoko

# End of hosts.
where tachi is my laptop, batou the desktop where i'm writing and motoko my nas; just "sudo <your text editor> /etc/hosts" to modify it as you need
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem booting ubuntu after mounting ntfs drive syphos Linux - Newbie 3 02-27-2008 04:32 AM
Mounting split raid drive as normal drive via USB William_Syd Linux - Newbie 2 11-01-2006 08:07 PM
Mounting a RAID-1 Drive after removal ? fire.wisp Linux - General 1 12-06-2004 12:33 PM
mounting a windows raid drive Peter Geraedts Linux - Newbie 0 04-12-2004 01:56 PM
Problem mounting drive on Network install taylortbb Linux - Newbie 2 10-29-2003 12:42 PM


All times are GMT -5. The time now is 07:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration